Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server stürzt dauernd ab.

Frage Microsoft

Mitglied: Jannis92

Jannis92 (Level 1) - Jetzt verbinden

04.03.2014, aktualisiert 21.07.2014, 5744 Aufrufe, 18 Kommentare, 2 Danke

Moin Moin,
ich habe mir vor kurzem einen Home Server (Windows Server 2012 R2) aufgesetzt.
Auf dem Server läuft ein DHCP, DNS, sowie eine VM mit der UTM9 von Sophos.
Der Server dient halt zum einen für die Firewall (UTM) und zum anderen um Datensicherung zu betreiben.
Der Server verfügt über zwei Netzwerkkarten. Davon ist eine OnBoard, und eine über PCIe x1.

Das Problem:
ich habe sehr häufig das Problem, dass der Server einfriert. Er gibt keine Lebenszeichen mehr von sich (weder ein Bild, noch
eine Antwort über das Netzwerk z. B. ping).

Anfangs habe ich natürlich die Hardware in Verdacht gehabt. Habe memtest usw. ausgeführt, timings manuell eingetragen usw.
Problem bestand weiterhin.
DANN ist mir aufgefallen, dass wenn ich meinen Rechner herunterfahre, der Server ab und zu das oben genannte Problem hatte
=> er fror ein.

Daraufhin habe ich eine Batch- Datei erstellt, die jede Minute einen Eintrag mit der aktuellen Zeit in eine log.txt geschrieben hat.
( Die Datei wurde dann beim Herunterfahren (lokale Richtlinien\ Skript beim Herunterfahren ausführen) gestartet).
So konnte ich feststellen, dass wenn mein Rechner heruntergefahren wurde, nehmen wir mal als Beispiel die Zeit: 19:37,
der Server genau zur selben Zeit (19:37) weg war. => Seltsam.
(Die Batchdatei wurde auf dem Server UND auf dem Rechner ausgeführt)

Das größte Problem:
Der Fehler ist nicht reproduzierbar.

Bis eben bestand das Problem auch "nur", wenn ich den Rechner heruntergefahren habe.
Vor ca. einer halben Stunde ist der Server sogar beim Hochfahren meines Rechners eingefroren.
(Die Zeit des einfrierens war wieder identisch mit dem Einschalten meines Rechners)

Hat evlt. einer eine Idee, wo das Problem sein kann?!
Der Server und Rechner sind über einen Switch an eine Fritzbox angeschlossen.

Ich bin echt dankbar für jeden einzelnen Tipp.
Mitglied: Chonta
04.03.2014, aktualisiert um 20:11 Uhr
Hallo,

wenn der Rechnereinfriert und niochts mehr geht, nichtmal die Maus ist es mit großer Wahrscheinlichkeit der RAM oder die CPU.

Steht im Eventlog, das der Server unerwartet runtergefahren wurde oder wurde der Normal runtergefahren?

Die neueste Version von Memtest mittels einer LliveCD machen und auch mehrere Durchläufe, einige Fehler kommen erst wenn die Temperatur höher ist.

CPU mit Prime testen und ggf Kerne deaktivieren.

Es kann natürlich auch ein Hitzeproblem sein, wobei dabei der Rechner meist nicht einfriert sondern neu startet.

Gruß

Chonta

NACHTRAG:

Ok Memtest hast Du schon hinter Dir.. überlesen gehabt.

Wie hängen Server und dein Rechner Netzwerk und Stromtechnisch zusammen. Wie sind die Macadressen und IP-Adressen. (auch v6)
Läuft auf deinem Rechner irgendeine Software über den Du den Server steuerst?
Kannst Du die Rechner mal direkt ohne Switch an die FB hängen?


Switsch/ Netzwerkkabel können auch mit ein Problem sein, bei beiden Beteiligten.

Ein BIOS Problem kann auch dafür sorgen das ein PC einfriert.

Klemm mal deinen PC vom Netzwerk ab und starte den ein Paarmal neu und schau nach ob der Server weiter läuft.
Wenn der Server an bleibt ist eine Der Netzwerkkomponenten hin. (Wenn der Server bei Strom an aus geht, wenn der erst beim OS Start aus geht, kann auch ein Programm auf dem Rechner...)
Wenn der Server aus geht, dann ist was mit der Stromverkabelung im argen, der Server braucht einen Stromkreis der eine andere Sicherung hat als dein PC.
Bitte warten ..
Mitglied: Jannis92
04.03.2014, aktualisiert um 20:20 Uhr
Hey Chonta,
erst mal Danke für die Rückmeldung.
Ich gebe dir Recht, normal ist es meist die Hardware. Aber wieso sollte die Hardware immer dann streiken,
wenn ich meinen PC ein- bzw. Ausschalte? Ergibt für mich keinen Sinn.
Temperatur kann ich ausschließen. befindet sich bei 40-50 °C laut Speedfan.

In den Ereignissen steht leider nichts. Da ich den PC über den Reset- Knopf neu Starte, erscheint natürlich, dass
der PC unerwartet neu gestartet wurde (haha, natürlich, habe ja auch gerade den Knopf drücken müssen^^).

Rechner und Server sind vom Strom "unabhängig". Also sie befinden sich nicht an einer Schaltleiste, falls du das meinst?!.
MAC- Adresse habe ich auch schon geprüft, soll ja mal vorgekommen sein, dass sich da die gleiche Adresse im Netz befand.
Dem ist aber nicht so (hätte mich auch bisschen aus den Latschen gehauen :D ).
IP- Adresskonflikt besteht auch nicht. Server hat zwei feste Ip- Adressen und Rechner bezieht vom DHCP.
Nein, ich manage den Server, indem ich mich über RDP auf diesen anmelde.

Inwiefern könnte das Netzwerkkabel das Problem sein?
Bei dem Switch handelt es sich um einen 08/15 Standard, oder auch "dummen" Switch.
Bitte warten ..
Mitglied: Xaero1982
05.03.2014 um 00:23 Uhr
Hi,

und wenn du die beiden mal netzwerktechnisch trennst?
Server vom Switch abklemmen und nochmal testen.

Gruß
Bitte warten ..
Mitglied: Jannis92
05.03.2014 um 08:37 Uhr
Öhm,
dann ist der Server ja gar nicht erreichbar und meine Firewall *pufffff* weg.
Irgendwie auch nicht so schön.

Dennoch Danke.
Bitte warten ..
Mitglied: Xaero1982
05.03.2014, aktualisiert um 09:02 Uhr
Du willst den Fehler finden und machst dir Gedanken über eine kurzfristige Unerreichbarkeit?
Was meinst du denn wie man Fehler findet?

Wenn du sagst das Ding friert immer im Zusammenhang mit deinem PC ein, dann solltest du da mal ansetzen.

Und an den Server wirst du ja auch einen Monitor anhängen können oder?

Gruß
ps: als nächstes würde ich deinen pc einfach mal nur über die Fritzbox verbinden oder nur den Switch.
Bitte warten ..
Mitglied: Jannis92
05.03.2014 um 09:13 Uhr
Naja, was heißt "kurzfrisitg".
Für mich klingt der Vorschlag so, als wenn ich den Server für einen längeren Zeitraum vom Netz nehmen soll.
Ich erwähne noch einmal....der Fehler ist nicht Reproduzierbar. Er Tritt mal auf, und mal nicht (In Bezug auf das Einschalten/ Herunterfahren)
meines Rechners.

Natürlich könnte ich den Server einmal an die Frizbox anschließen. Das wäre eine Möglichkeit um irgendwie meinen Switch zu umgehen.
Meinen Rechner kann ich leider aufgrund der Räumlichkeiten nicht dort anschließen.

Derzeit ist an dem Server mein TV angeschlossen. Wenn er nicht mehr erreichbar ist und ich meinen TV einschalte und auf "Server"
umschalte, ist der Bildschirm schwarz und es kommt kein Signal (Server läuft allerdings noch).
Bitte warten ..
Mitglied: Robobob
05.03.2014 um 09:35 Uhr
Hallo,

als du kommst doch mit einem Problem ins Forum. Demnach willst du doch Ratschläge und Hilfestellung.
Dein Problem ist relativ interessant und scheint sich nicht so einfach beheben zu lassen.

Und ich bin mir jetzt schon zu 75% sicher das du um dies zu beheben, nicht um eine größere Ausfallzeit herum kommen wirst!

Ich hätte längst mal alles geprüft was im Netzwerk so vorhanden ist.

Den DHCP auf dem Server mal deaktiviert und den der Fritzbox temporär genommen.
Die VM mit der Sophos UTM aus dem Spiel genommen und die Fritzbox das temporär machen lassen etc etc etc.

Aber all das ist mit Arbeit verbunden....
Dann gibts heut Abend halt mal kein Germanys Next Topmodel & Co. im TV.

Gruß

Max
Bitte warten ..
Mitglied: Jannis92
05.03.2014 um 11:19 Uhr
Neeeeeeein, Germanys Next Topmodel kann ich nicht ausfallen lassen
Viel zu wichtig für mich
:D :D :D

Ihr habt recht :p.
Ich werde den Vorschlag, mit DHCP und co. mal prüfen...
Wird wahrscheinlich eine Weile dauern, bis eine Rückmeldung von mir erfolgt, da es einige Tage dauern kann, bis der nächste
freeze kommt.


Danke an euch!
Bitte warten ..
Mitglied: Matze208
05.03.2014 um 12:40 Uhr
Hallo,

Hast du mit deinem Rechner netzlaufwerke auf dem Server verbunden?
Gibt es irgendwelche Scripte (Backup?) die auf deinen Rechner zugreifen ?

Gruß Matze
Bitte warten ..
Mitglied: Jannis92
05.03.2014 um 13:30 Uhr
Moin Matze,
es GAB in der tat ein Script, welches beim Herunterfahren über die lokale GPO ein Backup von meinem
Rechner (bestimmte Verzeichnisse) angestoßen hat. Da ich das schon in Verdacht hatte, habe
ich die Konfiguration gelöscht. Das Problem besteht leider weiterhin. So konnte ich
das Script beim Herunterfahren als Ursache also ausschließen.

...
Bitte warten ..
Mitglied: Chonta
05.03.2014 um 15:41 Uhr
Hallo,

ich miente mit Strom nicht nur die selbe Steckdosenleiste sondern ob die beiden Rechner auch an der selben Sicherung hängen.
Gleiche Sicherung gleicher Stromkreis.

Den Server mal direkt an der FB anschließen.

Du kannst auch mal versuchen anstelle deinen PC immer neu zu starten (um sicher zu gehen richtig runterfahen kurz warten und einschalten). mal 20x das Netzwerkkabel ziehen und wieder reinstecken und schauen ob der Server noch da ist.

Wenn der Server durchlief, dann mal mit und ohne Netzwerk deinen PC neu starten und jedesmal den Server checken.

Gruß

Chonta
Bitte warten ..
Mitglied: TobiasNYC
05.03.2014 um 15:57 Uhr
Zitat von Jannis92:
Bis eben bestand das Problem auch "nur", wenn ich den Rechner heruntergefahren habe.
Vor ca. einer halben Stunde ist der Server sogar beim Hochfahren meines Rechners eingefroren.
(Die Zeit des einfrierens war wieder identisch mit dem Einschalten meines Rechners)

- Was war z.Zt. des Freez auf dem Bildschirm zu sehen, war er noch schwarz oder war die GUI schon geladen, angemeldet ...usw.?
- Welche HW befindet sich im/am Server?

Ich würde generell folgendes unternehmen:

- BIOS Update
- BIOS default settings (max. die Bootreihenfolge anpassen)
- Wen möglich auch Firmware auf den NIC´s updaten
- nicht zwingend benötigte HW entfernen oder deaktivieren, Audio, etc.
- Driverupdates, insbesondere VGA & NIC
- und noch die aktuellsten Windows Updates einspielen...
Bitte warten ..
Mitglied: schmitzi
LÖSUNG 06.03.2014, aktualisiert 21.07.2014
Hi,

welche Hardware hast Du denn so am Start ?
Schonmal über ein neues Netzteil für den Server nachgedacht ?
Evtl Probleme mit Strom/Potentialausgleich ?

Gruss RS
Bitte warten ..
Mitglied: Knorkator
06.03.2014, aktualisiert 17.03.2014
Hallo,

ich hatte mal ähnliche Probleme mit einem 2008R2,Hyper-V und einer Sophos UTM VM.
Nach Installation der Firewall ging nix mehr, Abstürze etc.
Habe für die Firewall eine zusätzliche Netzwerkkarte eingebaut (also insg. 3 Stück im Rechner).
Die 2008R2 Karte läuft nun unabhängig vom Hyper-V und die Sophos hat 2 Karten für sich alleine.

Scheinbar hat der Hyper-V mit dem "aufteilen" der Netzwerkkarten Probleme gehabt.

Das System läuft nun schon seit mehreren Jahren und es gab nie Probleme, obwohl teilweise 4 VMs liefen.

Nur mit der Sophos gab es Theater...


Gruß
Bitte warten ..
Mitglied: Jannis92
06.03.2014 um 22:31 Uhr
@Knorkator
Das klingt ja mal sehr interessant.
Wie hat sich das bei dir geäußert ?
War der Server einfach mal so weg oder auch, wenn zusätzliche Geräte im Netz
ein- bzw. Ausgeschaltet wurden?

Also an alle....
Ich bedanke mich für eure Tipps nur dauert es natürlich, bis das alles
Wieder getestet und beobachtet wurde :p

Ich werde meine Lösung aufjedenfall noch posten, sofern ich eine habe (: ;o
Bitte warten ..
Mitglied: Knorkator
07.03.2014, aktualisiert 17.03.2014
Nach der Installation der UTM war der Server auf einmal nicht erreichbar.
Bedienung am Terminal selber.. keine Chance.
Also: Neustart... sah soweit alles gut aus.
Aber per RDP... nix... also wieder zum Terminal.
Bedienung unmöglich.

Da die Probleme direkt mit der UTM zusammenhingen und ich das System quasi nicht mehr normal booten konnt, habe ich letztendlich die Hyper-V Rolle im abgesicherten Modus deinstalliert (um die Netzwerkkonfiguration zu "nullen") und eine 2. Netzwerkkarte für die UTM eingebaut.
Neukonfiguration vom Hyper-V -> Host-Nic nur für das Verwaltungssystem und die 2 anderen für die UTM... keine Fehler mehr.

Viel Erfolg!
Bitte warten ..
Mitglied: Jannis92
17.03.2014 um 19:20 Uhr
Moin Moin,
hier einmal ein kurzer Statusbericht....
Ich habe vor ca. zwei Wochen mein Script, welches ich über die lokale GPO beim Herunterfahren ausgeführt habe, deaktiviert.
(Das Script hat ein Backup von bestimmten Verzeichnissen erstellt). Bis zum Wochenende hatte ich kein
Systemabsturz mehr. Dann habe ich meine GPO wieder aktiviert und zack, wieder ein freeze.

Ich vermute, dass es an dem FreeFileSynch Tool liegt. Was genau dort nicht stimmt, kann ich mir leider nicht erklären. Ich habe sämtliche
Konfigurationen durchgespielt. Naja, da nur Verzeichnisse kopiert werden, wo eine Änderung vorgenommen wurde,
habe ich mir jetzt eine Batch- Datei erstellt, die die Aufgabe von FreeFileSynch übernimmt.
(xcopy /C /I /M /Y "SourceFolder" "DestinationFolder")

Werde das Script heute mal aktivieren und berichten, ob ich dann noch einen freeze hatte, wenn ja,
dann muss mit der GPO "Script beim herunterfahren" irgendetwas nicht stimmten (wäre meine logische Schlussfolgerung),
sollte kein freeze mehr zu verzeichnen sein, so hat mir FreeFileSynch so einige graue Haare bereitet -.- :D
Ich bin gespannt & werde mich noch einmal hier melden

Bis denn.
Bitte warten ..
Mitglied: Jannis92
21.07.2014 um 22:14 Uhr
Moin Moin,
hier ein letzter Statusbericht von meiner Seite.

Lösung des Problems:
Es lag tatsächlich an der "Steckdose" bzw. an einem Gerät, welches in der Mehrfachsteckdose
angeschlossen war/ist. Noch kann ich nicht genau sagen, um welches es sich handelt. Sobald
ich es herausgefunden habe, werde ich es hier noch einmal posten.

Ich bedanke mich bei euch allen
Beste Grüße ;p.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...