Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows-Task funktioniert nicht!

Frage Microsoft

Mitglied: F17130C

F17130C (Level 1) - Jetzt verbinden

05.03.2009, aktualisiert 15:34 Uhr, 3521 Aufrufe, 4 Kommentare

Ich würde gerne von der lokalen Festplatte eines Rechners, Daten auf ein freigegebenes Netzlaufwerk kopieren. Dies möchte ich aber nicht manuell tun, sondern ein Task soll das für mich übernehmen.

Ich habe eine Batch- oder auch eine CMD-Datei erstellt, die wie folgt aussieht:

net use x: /delete
net use x: "\\SERVER\d$\ORDNER\FREIGEGEBENER ORDNER\" (die Anführungszeichen deshalb, da ein Leerzeichen in einer Ordnerbezeichnung vorhanden ist)
xcopy c:\Temp\test\*.* "\\SERVER\d$\ORDNER\FREIGEGEBENER ORDNER\" /y

net use x: /delete

goto ende



:ende


Versucht habe ich es auch schon nur mit Laufwerksbuchstaben des freigegebenen Ordners. Führe ich die Datei manuell aus, funktioniert es einwandfrei. Sobald ich einen Task einrichte, funktioniert es nicht mehr.
Berechtigungen sind im Task eingetragen. Ich verstehe nicht wo der Fehler ist!

Könnt ihr mir helfen?
Mitglied: 76091
06.03.2009 um 13:03 Uhr
Hallo F17130C,

wird der Task als Administrator auf dem entsprechenden System ausgeführt? Wie sehen die Berechtigungen auf dem Netzlaufwerk aus? Befindet sich das System in einer Domäne?
Bitte warten ..
Mitglied: F17130C
09.03.2009 um 13:39 Uhr
Hi,

sorry für die späte Antwort. Ja, das System ist in einer Domäne!

Berechtigungen auf Netzlaufwerk:

Administratoren (von lokaler Maschine): Vollzugriff
System: Vollzugriff

Ich habe es auch schon mit dem lokalen Administrator, was eigentlich mit der Gruppe Administratoren abgedeckt wird, versucht. Dies funktioniert jedoch auch nicht.
Mit dem Domänen-Administrator ebenfalls nicht.
Normalerweise tragen wir einen "Taskadmin", welcher ein lokaler Administrator ist, ein.

Ich habe das Script schon auf jede erdenkliche Art umgeschrieben, welches sich auch jedes Mal erfolgreich manuell ausführen lässt, doch mit dem Task funktionierts nicht!
Bitte warten ..
Mitglied: F17130C
12.03.2009 um 08:55 Uhr
Hat denn keiner von euch eine Antwort parat?

Was ich noch dazu sagen könnte: Es sind knapp 500MB, die von A (Außenstelle, WAN-Anbindung) nach B (ins LAN) kopiert werden sollen. Vielleicht hakts daran..?

Edit: Selbstverständlich soll alles in ein und derselben Domäne geschehen.
Bitte warten ..
Mitglied: F17130C
12.03.2009 um 11:05 Uhr
Jetzt wirds kurios: Ich habe testweise mal ein Script geschrieben, welches die zu sichernden Dateien in einen eigenen Ordner auf dem selben Laufwerk (lokal) kopiert.

Der Code:

xcopy D:\Daten\Database\*.* D:\Daten\Sicherung_TO /y (habs auch nur mit "copy" versucht")


Manchmal steht nach Ausführen "Die Zieldatei konnte nicht gefunden werden.", dann mal dasselbe nur noch mit dem Anhängzel "Es wurden 0 Dateien kopiert." und dann aber auch manchmal "Es wurden 19 Dateien erfolgreich kopiert."

Das Problem: In dem Zielverzeichnis sind aber keine Dateien! Wie kann man sich das erklären? Das ist doch ein lokales Laufwerk...
Dass ich das alles mit PCAnywhere auf einem Computer einer Außenstelle mache, sollte kein Problem darstellen oder?
Bitte warten ..
Ähnliche Inhalte
Windows 10
Anmeldung im Windows Store funktioniert nicht mehr (2)

Frage von Desert-Igel zum Thema Windows 10 ...

Windows Update
WSUS Server 2016 mit Windows 10 funktioniert nicht (4)

Frage von netzi01 zum Thema Windows Update ...

Windows Server
gelöst Windows-Explorer funktioniert nicht mehr Windows Server 2008 R2 (4)

Frage von Zeus0815 zum Thema Windows Server ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Update
MS: Update-Server-Adressen OHNE Wildcards (16)

Frage von mrserious73 zum Thema Windows Update ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (10)

Frage von Matsushita zum Thema Microsoft Office ...

Router & Routing
gelöst Netzwerk am einfachsten trennen (8)

Frage von geheimagent zum Thema Router & Routing ...