Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows verwechselt Shares auf ALLNET6600 (Thecus5200)

Frage Hardware SAN, NAS, DAS

Mitglied: Cougar77

Cougar77 (Level 1) - Jetzt verbinden

26.04.2007, aktualisiert 31.05.2007, 4671 Aufrufe, 7 Kommentare

Hallo

wie schon in einem anderen Beitrag geschrieben, haben wir uns einen ALLNET6600 (Baugleich zu Thecus5200) als Netzspeicher angeschafft.

Meistens funktioniert das auch ganz gut.

Leider tritt bei einigen Rechnern das Problem auf, dass in automatisierten Abläufen Dateien nicht gefunden werden.

Als Ursache habe ich folgendes Phänomen erkannt:

Nehmen wir an, auf dem ALLNET existiert Share1 mit den Unterordnern UO1, UO2, UO3 sowie Share2 mit UO4, UO5, UO6.
Nun kommt es vor, dass bei Zugriff auf Share1 (z.B. per Explorer) aber die UOs 4,5 und 6 erscheinen.

Leider habe ich keine Ahnung, an welchem Ende das Problem auftritt.

Hat jemand schon mal soetwas gehabt?
Mitglied: Logoff
30.04.2007 um 11:54 Uhr
Hallo,

nutzt Ihr Server- Gespeicherte Profile?
Da kann das Problem schon sein.
Ist ähnlich, wenn ein User mit seinen Profil z.b den Standort wechselt, und somit auf einen
anderen Server kommt.

Ich händel dass damit, das ich das Profil neu anlege, und mit dem Reg.-Editor die WKS, nach den alten verbindungen suche und lösche, bzw. den Reg.-Eintrag auf dem neuen Standort anpasse.

Ein Lösung habe ich auch noch nicht, das dass Problem sehr selten vorkommt.

VG
Logoff
Bitte warten ..
Mitglied: Cougar77
30.04.2007 um 12:04 Uhr
Hi!

Wir arbeiten (noch) nicht mit servergespeicherten Profilen.
Hauptsächlich tritt das Problem bei einem User auf, den wir für Batch-Verarbeitungen nutzen.

Das große Problem dabei ist, dass es sowohl unmittelbare UNC-Zugriffe (direkte Dateiaufrufe) als auch Windows-Netzlaufwerke betrifft.

Manchmal reicht zum Beheben ein einfaches F5, manchmal muß ein Ab-/Anmelden her.

Interessant ist, dass sich das Ganze scheinbar beliebig ändert...
Mal ist der Ordner falsch, dann ein anderer, dann wieder beide...

Gruß
Marco
Bitte warten ..
Mitglied: Logoff
30.04.2007 um 12:34 Uhr
Wenn es nur bei Usern mit Batches sind könnte es auch daran liegen dass es alte
Verbindungen behält.

Einfach mal im DOS Fenster mit
net use * /D /Y
alle Netzverbindungen trennen.
Dann mit
net use /P:no

Nun die Batch wieder starten.

PS.: NET USE /P =
Steuert die Verwendung ständiger Netzwerkverbindungen. Die Standardeinstellung sieht die zuletzt verwendete Einstellung vor. Verbindungen ohne Gerätenamen können nicht als ständige Gerätenamen fungieren. Yes speichert alle hergestellten Verbindungen und stellt sie bei der nächsten Anmeldung wieder her. No speichert die aktuelle Verbindung und nachfolgende Verbindungen nicht. Bereits bestehende Verbindungen werden bei der nächsten Anmeldung wiederhergestellt

VG
Logoff
Bitte warten ..
Mitglied: Cougar77
30.04.2007 um 13:04 Uhr
Hi!

Ne, an den Batches selbst liegt es nicht (verschiedene Typen, reine Batch, Access/VBA...).
Und an den Netzlaufwerken auch nicht, da der direkte UNC-Zugriff (//Server/Share/Datei.txt) auch nicht geht...

Er nimmt keine "alten" Verbindungen, sondern würfelt die Shares auf dem NAS beliebig.
Heißt, man hat bei Shares, die man an diesem Rechner noch nie genutzt hat auch mal ein anderes (falsches) Share, das man auch noch nie benutzt hat.

Passiert aber auch bei "normalen" Usern, fällt nur bei dem Batch-User am meisten auf, da er viele Zugriffe macht und auch entsprechend viele Fehlermeldungen produziert.
Bitte warten ..
Mitglied: Cougar77
03.05.2007 um 08:34 Uhr
Noch ein bisschen Input

Interessanterweise scheint das Problem nicht mehr aufzutreten, wenn man die Verbindung zur AD trennt und damit die Rechteverwaltung effektiv ausschaltet und alle Ordner "public" sind.
Das ist allerdings nicht wirklich eine Lösung...
Bitte warten ..
Mitglied: Eisfuchs
07.05.2007 um 10:20 Uhr
Wir haben bei uns dasselbe Problem mit dem ALL6600. Neueste Firmware ist drauf, und trotzdem verwürfelt das Teil die Shares in nicht vorhersagbarer Weise. Ein zweites Problem: Wenn man eine Weile nicht auf den NAS zugegriffen hat, bekommt man beim ersten Versuch, eine Datei zu öffnen, ein "Access Denied" zurück. Der zweite Zugriff funktioniert dann. Das NAS steht in einer AD Domäne mit allen Ordern auf Public (wie bei dir oben beschrieben tritt die Verwürfelung dann nicht mehr auf, die Zugriffssperre aber leider immer noch).

Eine Untersuchung mit Ethereal brachte auch noch kein Ergebnis, außer, daß der zugreifende Win2000-Rechner zuerst als Gast, und dann als Domäne\User einloggt. Beim ersten Versuch macht er beide Logins als Gast und es schlägt fehl. Beim 2. Versuch macht er den ersten Versuch als Gast, den zweiten dann aber als Domäne\User, und damit funktioniert es.

Ich hoffe, es hat jemand eine Lösung für das Problem ... Ich werde auf jeden Fall nochmal Allnet am Telefon nerven und sehen, was die zu sagen haben.

Danke für eure Zeit und einen schönen Tag,
Eisfuchs
Bitte warten ..
Mitglied: Cougar77
31.05.2007 um 15:19 Uhr
Das Ganze setzte sich dann doch auch ohne AD-Zugriffkontrolle fort.

Das Problem mit "Access denied" scheint sich aus einem Fehler im smb zu ergeben. Scheinbar scheint es so zu sein, dass bei wechselndem Masterbrowser einige Shares diesem nicht bekannt sind.
Umgangen haben wir dieses Problem (bisher scheinbar gut) damit, dass wir einen Linux-Server permanent zum Masterbrowser gemacht haben.

Allerdings tritt das Problem mit den "verwechselten" shares weiterhin auf, leider...

Edit:
Scheinbar nur ein Problem unter Win 2000, tritt weder unter WinXP noch Vista auf, jedenfalls der Verwechslungsteil.
Die "Access denied"-Meldung jedoch kommt auch unter XP und Vista vor.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung!

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows 10
Official Blog: Every Windows 10 in-place Upgrade is a SEVERE Security risk (4)

Link von Lochkartenstanzer zum Thema Windows 10 ...

Monitoring
System Monitoring für Windows, Linux (4)

Frage von manuelw zum Thema Monitoring ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...