Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows XP führt exe und msi Dateien auf Netzlaufwerken nicht aus

Frage Microsoft Windows XP

Mitglied: cle1986

cle1986 (Level 1) - Jetzt verbinden

19.07.2007, aktualisiert 20.07.2007, 7073 Aufrufe, 4 Kommentare

Hallo!

Ich habe in einem netzwerkbasierten Startupskript msi und exe Dateien die ausgeführt werden sollten.
Allerdings funktioniert das nicht. Es liegt aber nicht an den Zugriffsrechten auf das Netzlaufwerk, denn
das Skript legt in einem Ordner log ein Logfile vom jeweiligen Client an und das ist nach dem Ausführen
vom Skript immer vorhanden gewesen nur eben bei den ausführbaren Datein hat er ein Problem.
Wenn ich eine ausführbare Datei auf einem Netzlaufwerk unter Windows direkt aufrufe, dann bekomme ich immer
folgende Fehlermeldung:

9923da63f36cb4803fb4519ace6caa80-fehler - Klicke auf das Bild, um es zu vergrößern

Kopiere ich die Datei dann auf die lokale Festplatte lässt sie sich ohne Probleme ausführen.

Woran kann das liegen bzw. habe ich irgendetwas falsch eingestellt?

cle
Mitglied: hakrehakre
19.07.2007 um 10:35 Uhr
1.) Prüfen Sie ob das Netzlaufwerk richtig angebunden ist.
2.) Prüfen Sie ob Sie das ServicePack 2 installiert haben
3.) Prüfen Sie in welcher Sicherheitszone (Internet Explorer) sich das Netzlaufwerk befindet

Windows markiert seit SP2 Dateien die nicht vom eigenen Rechner stammen als Fremd und verhindert die Ausführung. Dies kennen Sie warscheinlich wenn Sie eine .exe Datei aus dem Internet heruntergeladen haben und dies dann ausführen wollen: Es kommt eine Nachfrage.

Diese "Nachfrage" wird höchstwarscheinlich auch das Ausführen in Ihrem geschilderten Fall verhindern. Da dies nicht interaktiv geschieht erscheint keine Meldung sondern der Zugriff wird verweigert.

Ich habe mir so behelfen können das ich das ganze Netzwerk in die sichere Zone im IE packe. Es gibt aber vielleicht auch eine saubere Lösung die hier jemand anders kennt.
Bitte warten ..
Mitglied: cle1986
19.07.2007 um 10:55 Uhr
zu 1) Netzlaufwerk ist richtig eingebunden mit net use n: \\server [hat bis jetzt unter windows 2000 immer ohne problem geklappt]
zu 2) ist installiert auf 2 Rechnern am dritten nicht und trotzdem werden diese Dateien nicht ausgeführt, denn das Updateskript installiert dort keine Dateien. SP2 sollte via Skript installiert werden. Updateinstallation mit dem selben Skript haben unter Windows 2000 immer problemlos geklappt.
zu 3) Hab ich probiert. Das Intranet sowie das Netzwerk sind automatisch in der Zone Internet und somit als sicher eingestuft.

Kann mir sonst noch jemand helfen??
Bitte warten ..
Mitglied: hakrehakre
20.07.2007 um 09:13 Uhr
zu 3) Hab ich probiert. Das Intranet sowie
das Netzwerk sind automatisch in der Zone
Internet und somit als sicher eingestuft.


Es geht nicht um sicher sondern um die Zone. Füge diese bitte explizit der Zone "Intranet" zu. Dort können u.a. per Erweitert auch noch weitere IP Adressen und Hostnamen hinzugefügt werden. Hier lässt sich evtl. auch der Weg über die Registry gehen.

Ich weiss das dies selber nur eine Krücke ist. Ansonsten müsste doch in der Produktdokumentation vom SP2 mehr zu diesem Feature stehen und wie man es ausschalten kann.
Bitte warten ..
Mitglied: cle1986
20.07.2007 um 09:18 Uhr
Es geht ja nicht um das SP2, denn das Skript wird auch auf Rechnern mit SP1 nicht ausgeführt.
Und ich bin gestern drauf gekommen, dass es beim Ausführen von exe und msi Dateien nur dann zu der Fehlermeldung kommt, wenn ich sie mit der Option "Ausführen als..." starte.

Mir geht es insbesondere um mein Startup Skript, dass Software und Updates auf den Clients installieren soll, wenn ich dort etwas aktiviere. Das tut das Skript nicht. Es erstellt zwar am Netzlaufwerk im log ordner ein file mit dem Computernamen, aber es wird das Programm nicht installiert. Unter Windows 2000 funktionierte das Skript aber einwandfrei. Seither habe ich nur 2 Updates raus genommen und sonst nichts geändert.
Wenn ich es unter Windows XP Pro im Administrator Account aufrufe funktioniert es auch ohne Probleme und an Freigaben kann es nicht liegen, weil das Problem hatte ich schon unter 2000 und da ich einen Samba Server unter Linux laufen habe, habe ich dort die Rechte schon vor längerer Zeit gesetzt.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 10
gelöst Windows 10 Explorer.exe friert bei aufruf von Netzlaufwerken ein (6)

Frage von Hanuta zum Thema Windows 10 ...

Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...