Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows XP Professional und 2 Netzwerkkarten

Frage Microsoft Windows Netzwerk

Mitglied: klamsl

klamsl (Level 1) - Jetzt verbinden

02.01.2007, aktualisiert 03.01.2007, 5202 Aufrufe, 5 Kommentare

Ein PC in 2 Netzen

Hallo,

folgendes Problem


Ich habe einen PC mit 2 Netzwerkkarten, der in 2 Netzen laufen soll.

Netz1 ist eine Windows 2k Domäne (192.168.0.x) , hierbei soll es nur einem einzigen Rechner möglich sein auf dem lokalen PC über Port 80 auf den lokalen IIS zuzugreifen.

Netz2 ist eine Arbeitsgruppe aus diversen Windows-PCs (192.168.0.x). Hier ist der Rechner auch normal eingebunden, d.h. er soll normal mit Dateifreigaben und sonstigen zusammenarbeiten.

Netz1 und Netz2 sehen und kennen sich nicht sind auch ansonsten nicht physikalisch verbunden.

Problembeschreibung:

Das das ganze nicht so toll ist grad wegen den selben Subnetzen ist mir bewusst, lässt sich aber leider nicht ändern. Das ganze hat mit demselben Rechner unter Windows NT 4.0 bereits mehrere Jahre problemlos funktioniert. Auch mit XP hat es auch schon funktioniert.. Jetzt funktioniert, wenn beide Karten aktiv sind der zugriff von Netz2 nicht mehr, der Rechner kann allerdings auf eine Windowsfreigabe, die auf einem Rechner im Netz2 liegt noch schreiben. Allerdings kann er keinen Rechner in Netz2 pingen und wird auch von keinem Rechner gefunden. Sobald ich die Netzwerkverbindung zu Netz1 deaktiviere Funktioniert das ganze im Netz2 aber wieder.
Eine IP-Adressüberschneitung zwischen beiden Netzen habe ich schon ausschließen können.

Frage:

Wie kann ich beide Verbindungen in der oben beschrieben Konfiguration zum laufen bekommen?

Hier anbei erstmal die aktuelle Netzwerk-Konfiguration.:


Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Dokumente und Einstellungen\LMS>ipconfig /all

Windows-IP-Konfiguration

Hostname. . . . . . . . . . . . . : XYZ
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Unbekannt
IP-Routing aktiviert. . . . . . . : Ja
WINS-Proxy aktiviert. . . . . . . : Ja

PPP-Adapter RAS-Server-(Einwähl-)Schnittstelle:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Interne RAS-Serverschnittstelle des Einwahlclients
DHCP aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.50.1
Subnetzmaske. . . . . . . . . . . : 255.255.255.255
Standardgateway . . . . . . . . . :

Ethernetadapter Netz1:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Realtek RTL8139-Familie-PCI-Fast Ethernet-NIC
Physikalische Adresse . . . . . . : 00-E0-4D-24-35-9C
DHCP aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.0.221
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . :

Ethernetadapter Netz2:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) PRO/1000 CT Network Connection
Physikalische Adresse . . . . . . : 00-30-05-7D-CF-58
DHCP aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.0.191
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 19.168.0.2

C:\Dokumente und Einstellungen\LMS>

Gruß und Danke im Vorraus Marcel
Mitglied: aqui
02.01.2007 um 17:54 Uhr
Gar nicht !!!
Das ist so IP designtechnisch nicht möglich, da du 2 Mal das gleiche Class C Netzwerk am Server hast und damit eine eindeutige Wegewahl im IP Forwarding nicht mehr möglich ist.
Das wäre so als wenn du in dein Auto Brennspiritus kippst und fragst wie man trotzdem damit fahren kann.... keine Chance, jedenfalls wenn du Routing aktivierst auf dem Server !

Du musst eins der 192.168.0.0er Netzwerke auf einen neue eindeutige IP Adresse konfigurieren !!

Es gibt 2 Auswege falls das partout nicht gehen sollte. Sofern du Routest dann nur das du eins der 192.168.0.0er Netzwerke hinter einem NAT Router versteckst und die Adressen übersetzt.
Ein Design nur für das Segment sähe dann so aus:

(Netzwerk)---192.168.0.0---NAT-Router---192.168.99.0---(Server NIC)----(andere Netze)

Dann würde alles was aus dem 2ten .0.0er Netz kommt übersetzt werden auf eine .99.x Adresse und alles wäre IP technisch wieder sauber. Bei allen solchen "Quick and Dirty" Workarunds gibts aber ein "aber"....
Der Router kann ein einfacher 60 Euro Linksys WRT54 z.B. sein der aber genaugenommen PAT macht. Benötigst du in so einer Konstellation einen Any to Any Kommunikation bekommst du ein Problem, denn alles was rückwärts aktiv über das .99.0er Netz aufgebaut werden muss kannst du nur per IP Portforwarding über den Router übertragen und das geht pro Anwendung genau einmal
Wenn du einen höherwertigen Router (gebrauchter Cisco o.ä.) einsetzt, dann könntest du ein statisches Portforwarding von jeder im 192.168.0.0er Netz vorhandenen Host auf eine separate 192.168.99.0er Adresse machen. Das würde dann dein problem lösen, kostet dich aber mehr.
Die einfachste Lösung ist also ein IP Redesign. Wenn du DHCP benutzt in so einem Segment ist das eine Sache von 15 Minuten !

Die 2te Möglichkeit ist eine Netzwerk Brücke zwischen den beiden Adaptern mit dem 192.168.0.0er Netz einzurichten. Wie das geht kannst du in der Microsoft Knowledgebase nachlesen:
http://support.microsoft.com/kb/309640/de
Bitte warten ..
Mitglied: klamsl
02.01.2007 um 18:03 Uhr
Danke für die Info, aber der Rechner hat in beiden Netzen eine eindeutige Adresse unter NT4 hats ja auch noch einwandfrei funktioniert. Bzw. lief es auch mit XP noch bis vor ein paar Tagen.

Noch eine "Dummi-Frage": Heißt deine Aussage also das mein Rechner mit seinen beiden IP-Adressen in beiden Netzen vorhanden ist?
Bitte warten ..
Mitglied: aqui
02.01.2007 um 22:29 Uhr
Nein dein Rechner (Server) hat eben keine eindeutige Adresse mehr aus der Tatsache das du 2mal das gleiche IP Netzwerk an 2 unterschiedlichen NICs konfiguriert hast.
Eigentlich ein Unding das das überhaupt konfigurierbar ist aber MS hats da nicht so genau mit Netzwerken bekanntlich.....mit neueren OSes dieser Firma sollte es eigentlich nicht mehr gehen und es ist schlimm das es scheinbar immer noch nicht zu einem Fehler führt, wie man leider oben sieht !

Das Problem das dein Server nun hat der der interne TCP/IP Stack nicht mehr sicher erkennen kann hinter welchem Netzadapter sich ein Client mit einer 192.168.0.x Adresse befindet und damit nicht mehr genau weiss wie er diese Station erreichen kann. Meist droppen Ssyteme dann solche Packete wenn sie nicht wie gesagt über eine "Netzwerkbrücke" auf dem OSI Layer 2 verbunden sind.
192.168.0.0 ist ein Class C Netzwerk (24 Bit Maske) in dem die ersten 3 Bytes das Netzwerk beschreiben und die sind bei dir fälschlicherweise 2 mal vorhanden.
Stell dir das vor wie einen Postboten der in einer Stadt die 2 mal die Straße "Hauptstrasse" hat ein Packet in der Hand hält wo "Peter Müller, Hauptstrasse 7" draufsteht. Wo und in welche Hauptstrasse soll er jetzt gehen wenn er nicht alles einzeln durchsuchen kann. Genau vor dem Problem steht auch dein Server, nur das der das Packet gleich wegschmeisst, der Postbote erst nachdem der Nachforschungsantrag auch nichts gebracht hat.

Das ist ein klassischer IP Designfehler den zig Teilnehmer hier im Forum auch begangen haben. Schlimm ist nur das mit unsauber implementierten IP Stacks (wie scheinbar in NT4) sowas mehr schlecht als recht funktioniert und der eine oder andere dann denkt es wäre so richtig und fehlerfrei !
Wie gesagt die MS Krücke mit der Netzwerkbrücke würde dir helfen wird aber m.E. erst ab XP supportet ...und der NAT Kram ist Gefrickel und nur dann zu empfehlen wenn es gar nicht anders geht !
In jedem Falle besser ist aber ein sauberes und standardkonformes IP Design und das bedeutet schlicht und einfach für eins deiner Segmente eine neue IP Adresse !!
Bitte warten ..
Mitglied: hrm42
03.01.2007 um 08:52 Uhr
Aqui hat recht! Du musst die beiden Netze eindeutig trennen, d.h. das erste z.B. mit 192.168.0.x und das 2. mit 192.168.1.x definieren. Sonst klappts nie richtig.
Bitte warten ..
Mitglied: klamsl
03.01.2007 um 09:45 Uhr
Dann erstmal danke für die Infos. Habe dem Rechner aus dem Netz2 herausgenommen. Der eine PC aus Netz2 der mit meinem PC kommunizieren muss hat jetzt auch eine 2 Netzwerkkarte und beide sind mit Ihrer 2ten Netzwerkkarte im 192.168.2.x Bereich.

Jetzt funktionierts erstmal, danke nochmals für Eurer Antworten.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows XP
Kann man noch neue Notebooks für Windows XP kaufen ? (9)

Frage von DieterJansen zum Thema Windows XP ...

Windows Netzwerk
SMBv2 in Windows 7 - Windows XP - Windows Server 2003 Domäne deaktivieren (4)

Frage von Mario.Steinberg zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...