Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows XP Reparatur macht Probleme

Frage Microsoft Windows XP

Mitglied: coltseavers

coltseavers (Level 2) - Jetzt verbinden

17.12.2013, aktualisiert 16:37 Uhr, 4006 Aufrufe, 21 Kommentare

Hallo zusammen,

ich habe gerade einen XP-Rechner, den ich gerne reparieren möchte.
Das System hatte einen Conficker-Wurm, welcher über ein Live-Linux-Virenscan erkannt und entfernt wurde.
Danach startete Windows nicht mehr und hing in einer Bootschleife fest.
Ein chkdsk /f /r konnte eine gefühlte Million an Fehlern reparieren (Die waren vermutlich aber auch teilweise schon vorher da)
Nun startet Windows zwar wieder, aber die ganzen Dienste laufen nicht usw.
Deshalb würde ich gerne eine Windows-Reparatur durchführen.

Die Windows-CD findet zwar die NTFS-Partition, aber wohl nicht so wirklich das darauf bereits installierte Windows.
Statt diesem Bild (1) (da möchte ich hin!):
http://www.pcwelt.de/ratgeber/Das-kommt-vor-einer-Reparatur-Installatio ...

wird dieses Bild (2) angezeigt:
http://www.pcwelt.de/ratgeber/Das-kommt-vor-einer-Reparatur-Installatio ...

Wie in diesem Artikel erklärt (http://www.pcwelt.de/ratgeber/Windows-XP-Verlustfreie-Reparaturinstalla ...) habe ich deshalb mit Hilfe der Wiederherstellungskonsole "fixmbr", "fixboot" und "bootcfg /rebuild" durchgeführt (in der Wiederherstellungskonsole wurde die Windows-Installation also problemlos gefunden - Windows fährt ja auch beim Bootvorgang hoch), nur leider hatte das keinen Effekt. Im Windows-Setup komme ich trotzdem nicht zu dem Bildschirm(1), wo ich die vorhandene Windows-Installation reparieren kann.

Hat irgendjemand eine Idee, wie ich dorthin kommen kann?
(Jaja, mir ist schon klar, dass eine Neuinstallation empfehlenswert wäre etc. - Ich würde das vorhandene Windows aber trotzdem lieber retten).
Mich wundert halt, dass das Windows zwar hochfährt (wenn auch mit Fehlern), aber im Windows-Setup dann doch nicht erkannt wird.
Also die Booteinträge müssten demnach schon vorhanden sein. Aber wenn die Booteinträge vorhanden sind, warum erkennt Windows-Setup nicht die vorhandene Installation?

Vielen Dank vorab!
Mitglied: kontext
17.12.2013, aktualisiert um 12:08 Uhr
Hallo coltseavers,

erstens einmal sind deine beiden Links identisch.
Daher bitte nochmals anschauen und anpassen..
.. am besten wäre doch gleich die Bilder hier einzubinden

Bzgl. deinem Problem - du redest zwar von Windows XP aber nicht von welcher Version bzw. SP-Stand.
Hat die CD einen ähnlichen bzw. gleichen SP-Stand oder versuchst du mit einer Uralt-CD eine Reparatur?

Wenn ich dich wäre, würde ich mal eine Windows XP CD mit aktuellem SP3 erstellen.
Dann nochmals von der starten und schauen ob sich was ändert ...
... denn: Windows Setups machen sehr gerne Probleme mit untersch. Versionsständen

Gruß
kontext
Bitte warten ..
Mitglied: coltseavers
17.12.2013 um 12:10 Uhr
Zitat von kontext:

Hallo coltseavers,

erstens einmal sind deine beiden Links identisch.
Sorry - habs korrigiert!
Bitte warten ..
Mitglied: coltseavers
17.12.2013 um 12:12 Uhr
Zitat von kontext:

Wenn ich dich wäre, würde ich mal eine Windows XP CD mit aktuellem SP3 erstellen.
Dann nochmals von der starten und schauen ob sich was ändert ...
... denn: Windows Setups machen sehr gerne Probleme mit untersch. Versionsständen

Danke für den Tip. Installiert ist ein XP Prof SP3.
Habe es mit einer XP-CD SP2 und SP3 probiert - machte aber keinen Unterschied.
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 17.12.2013, aktualisiert um 16:42 Uhr
Zitat von coltseavers:

Im Windows-Setup komme ich trotzdem nicht zu dem
Bildschirm(1), wo ich die vorhandene Windows-Installation reparieren kann.

Das kann mehrere Ursachen haben:

  • Das Windows ist so kaputt, daß es nicht mehr als installiertes windows erkannt wird. (Hatte ich auch schon öfter)
  • Du hast die falsche windows-XP-CD. Pro/Home/Mediacenter reparieren sich nciht gegenseitig.
  • Du hast die falsche Produktversion. Von XP gibt es mehrere verschiedene Produktversionen selbst innerhalb der gleichen Produktlinie. Da kann es sein, daß Du ein XP-Pro refurbisched nicht mit eienr XP-Pro OEM von einem Hersteller X reparieren kannst.
  • Du hast eine OEM-CD, die einfach keine Reparatur vorsieht, sondern nur die "Recovery", auch wenn die wie eine normale Installation aussieht.

Hat irgendjemand eine Idee, wie ich dorthin kommen kann?

Schau mal, ob Du die "Original-CD" die zu diese Installation gehört irgendwo herbekommst. Ansonsten sehe ich schwarz.

lks

PS: Ich habe es einmal geschafft, eine XP-installation dadurch zu reparieren, daß ich eine frische Instalaltion gemacht habe und dann diese üebr die kaputte Installation draufkopiert habe. Alelrdings soltlen man die Dateien für die Registry der "kaputten" Installation vorher sichern und dann hinterher zurückkopieren. das ist aber nur ein "Zeitvertreib" und keine sinnvolle Lösung für dieses Problem.

lks
Bitte warten ..
Mitglied: coltseavers
17.12.2013 um 12:50 Uhr
Zitat von Lochkartenstanzer:

> Zitat von coltseavers:
>
> Im Windows-Setup komme ich trotzdem nicht zu dem
> Bildschirm(1), wo ich die vorhandene Windows-Installation reparieren kann.

Das kann mehrere Ursachen haben:

  • Das Windows ist so kaputt, daß es nicht mehr als installiertes windows erkannt wird. (Hatte ich auch schon öfter)

Hmm - aber es bootet ja noch komplett! Stellt sich die Frage, was vorhanden sein muss, damit das installierte Windows erkannt wird.
Wie gesagt: bootrecord und mbr und boot.ini sind vorhanden und funktionieren. Was fehlt noch?


* Du hast die falsche windows-XP-CD. Pro/Home/Mediacenter reparieren sich nciht gegenseitig.
  • Du hast die falsche Produktversion. Von XP gibt es mehrere verschiedene Produktversionen selbst innerhalb der gleichen
Produktlinie. Da kann es sein, daß Du ein XP-Pro refurbisched nicht mit eienr XP-Pro OEM von einem Hersteller X reparieren
kannst.
  • Du hast eine OEM-CD, die einfach keine Reparatur vorsieht, sondern nur die "Recovery", auch wenn die wie eine normale
Installation aussieht.

> Hat irgendjemand eine Idee, wie ich dorthin kommen kann?

Schau mal, ob Du die "Original-CD" die zu diese Installation gehört irgendwo herbekommst. Ansonsten sehe ich
schwarz.

Ich meine es mit der CD zu versuchen, mit der das Windows damals installiert wurde.



lks

PS: Ich habe es einmal geschafft, eine XP-installation dadurch zu reparieren, daß ich eine frische Instalaltion gemacht habe
und dann diese üebr die kaputte Installation draufkopiert habe. Alelrdings soltlen man die Dateien für die Registry der
"kaputten" Installation vorher sichern und dann hinterher zurückkopieren. das ist aber nur ein
"Zeitvertreib" und keine sinnvolle Lösung für dieses Problem.

Hmm - wäre vielleicht ne Option, da das System als Raid1 läuft - da kann ich wohl eine der Platten rausnehmen und es mit der verbleibenden versuchen..
Bitte warten ..
Mitglied: Lochkartenstanzer
17.12.2013 um 13:54 Uhr
Zitat von coltseavers:

Wie gesagt: bootrecord und mbr und boot.ini sind vorhanden und funktionieren. Was fehlt noch?

Viele Dateien im Windows-Verzeichnis. Ich weiß nicht genau, was das setup alles aus dem windows-verzeichnis erwartet, um ein korrekt installiertes Windows zu erkennen, aber die Registry-dateien gehören dazu, in denen die Informatione drinsteht, welches windows da installiert ist. das ein System ganz hochstartet korreliert leider nciht damit, daß das setup das auch als zu reparierende Installation erkennt. Dazu reicht es, wenn aus irgendeinem Grund die Product-ID (nicht zu verwechseln mit der Lizenznummer) geändert wurde.


Ich meine es mit der CD zu versuchen, mit der das Windows damals installiert wurde.

Das ist schon mal positiv. Allerdings kann es sein, daß diese CD, sofern es eine OEM-CD ist, gar keine Reparatur-Option hat. Das habe ich insbesondere bei Medion-CDs schon mehrmals erlebt.

Hmm - wäre vielleicht ne Option, da das System als Raid1 läuft - da kann ich wohl eine der Platten rausnehmen und es mit
der verbleibenden versuchen..

Wie gesagt, das ist eine "Zeitvertreiboption". Das kann man machen, wenn man zuviel Zeit hat und diese nichts kostet Ich wollte es damals einfach nur wissen, ob man damit das System wieder auf die Beine bekommt, d.h. meine Erfahrungsschatz erweitern. Das entstehende System ist aber ziemlich instabil und man stößt immer wieder auf Probleme, die zwar behebbar sind, aber trotzdem Zeit und Aufwand kosten.

Sofern da wirklich nichts "lebenswichtiges" ist, solltest Du wirklich eine Neuinstallation erwägen.
Bitte warten ..
Mitglied: Pjordorf
17.12.2013 um 14:37 Uhr
Hallo,

Zitat von coltseavers:
Ich meine es mit der CD zu versuchen, mit der das Windows damals installiert wurde.
Und? kann die deine geforderte Reparatur? Es gibt unterschiedlichste CD's für XP. Da hilft nur ausprobieren

Habe es mit einer XP-CD ...und SP3 probiert
Eine XP-CD mit installiertem SP3 oder eine CD mit SP3 für XP? Erstes musst du dir ja selbst gebaut haben (Slip Streaming). Auch, es hängt von der Version ab die auf der CD drauf ist. Es gibt dort wirklich sehr viele unterschiedlichste Versionen bei XP.


Gruß,
Peter
Bitte warten ..
Mitglied: Lochkartenstanzer
17.12.2013 um 14:46 Uhr
Zitat von Pjordorf:

Es gibt dort wirklich sehr viele unterschiedlichste Versionen bei XP.

Deswegen muß auch die Product-ID des Mediums zu der Product-ID des installierten Windows XP passen, um diese reparieren zu können. Sonst wird das Windows nicht richtig erkannt.
Bitte warten ..
Mitglied: colinardo
LÖSUNG 17.12.2013, aktualisiert um 16:37 Uhr
Hallo coltseavers,
Zitat von coltseavers:
Hmm - wäre vielleicht ne Option, da das System als Raid1 läuft - da kann ich wohl eine der Platten rausnehmen und
Da du hier von "Raid" sprichst, hast du den überhaupt beim Laden des XP-Setups den Raid-Treiber für den Controller mit eingebunden (F2), oder den Treiber bereits in die CD geslipstreamed? Ansonsten erkennt das XP-Setup die Partitionen auf dem Raid erst garnicht ! Du brauchst dazu einen Treiber bei dem eine txtsetup.oem mit dabei ist.

Grüße Uwe
Bitte warten ..
Mitglied: Lochkartenstanzer
17.12.2013 um 15:44 Uhr
Zitat von colinardo:

Hallo coltseavers,
> Zitat von coltseavers:
> Hmm - wäre vielleicht ne Option, da das System als Raid1 läuft - da kann ich wohl eine der Platten rausnehmen und
Da du hier von "Raid" sprichst, hast du den überhaupt beim Laden des XP-Setups den Raid-Treiber für den
Controller mit eingebunden (F2), oder den Treiber bereits in die CD geslipstreamed?

Nachdem der TO schreibt, , daß Die Windows-CD findet zwar die NTFS-Partition, aber wohl nicht so wirklich das darauf bereits installierte Windows, ging ich davon aus, daß die RAID-Treiber drin sind. weil er ansonsten auch die Platten nicht finden würde. Kann aber nciht schaden, diesen Punkt nochmal zu prüfen.

lks
Bitte warten ..
Mitglied: coltseavers
17.12.2013 um 16:41 Uhr
Hi ho,

aaalso: es war vermutlich wirklich so, dass die CD, mit der ich das System ursprünglich installiert hatte keine Reparatur-Funktion besitzt.

Deshalb hab ich mal ein paar CDs durchprobiert - und, siehe da: mit einer XP Prof inkl SP3-CD aus Microsoft Dreamspark liess sich Windows reparieren.
Ich musste dann zwar noch den dazugehörigen Product-Key eingeben und Windows neu aktivieren, aber das macht nix.

Jetzt habe ich aber natürlich das nächste Problem, welches hier beschrieben ist:
http://www.administrator.de/forum/probleme-nach-installation-windows-xp ...

Angeblich gibt es einen Patch dafür, aber die Links in den verlinkten Beiträgen sind leider schon tot.
Kennt jemand den Patch? Ich hoffe, dass ich dann Ruhe geben kann

Vielen Dank schonmal!!!
Bitte warten ..
Mitglied: colinardo
17.12.2013, aktualisiert um 16:53 Uhr
Zitat von coltseavers:
Jetzt habe ich aber natürlich das nächste Problem, welches hier beschrieben ist:
http://www.administrator.de/forum/probleme-nach-installation-windows-xp ...
schon sämtliche Updates nach SP3 nachinstalliert ?? das System wird ja auf den Stand vom Original SP3 zurückgesetzt.
Bitte warten ..
Mitglied: Lochkartenstanzer
17.12.2013 um 17:04 Uhr
Zitat von colinardo:

> Zitat von coltseavers:
> Jetzt habe ich aber natürlich das nächste Problem, welches hier beschrieben ist:
> http://www.administrator.de/forum/probleme-nach-installation-windows-xp ...
schon sämtliche Updates nach SP3 nachinstalliert ?? das System wird ja auf den Stand vom Original SP3 zurückgesetzt.

Eventuell mit wsusoffline alles draufbügeln und dann nochmal schauen. Ganz wichtig ist auch, den IE wieder auf den Stand vor der "Reparatur" zu bringen, weil ansonsten vieles im System knirscht.

lks

PS: Darf ich fragen, warum Du Dir die Mühe machst, die Kiste reparieren zu wollen, obwohl es schneller und sicherer ist, eine frische Installation draufzubügeln?
Bitte warten ..
Mitglied: coltseavers
17.12.2013 um 17:09 Uhr
jo, lädt schon runter. Ohne wsusoffline wär man aber auch echt gekniffen. Weil Netzwerverbindung is ja nich...
Bin gespannt! Melde mich wieder...
Bitte warten ..
Mitglied: Lochkartenstanzer
17.12.2013 um 17:11 Uhr
Zitat von coltseavers:

jo, lädt schon runter. Ohne wsusoffline wär man aber auch echt gekniffen. Weil Netzwerverbindung is ja nich...

Deswegen heißt es ja wsusoffline. Weil man es auch offline benutzen kann. Man muß nur eine andere Kiste zur verfügung haben, mit der man es runterziehen kann.

lks
Bitte warten ..
Mitglied: coltseavers
17.12.2013 um 17:39 Uhr
schon klar, aber wsusoffline ist ja kein Microsoft-Produkt. Von daher: gut, dass es das gibt!
Bitte warten ..
Mitglied: coltseavers
17.12.2013, aktualisiert um 23:34 Uhr
Arrrgh! Die Offline-Updates liessen sich (natürlich) nicht installieren.
Fehlermeldung war: "Unsupported Operating System language"
Daran lags aber natürlich nicht. Die Sprache war schon die richtige, also begann mal wieder eine stundenlange Suche...

Des Rätsels Lösung waren die zuvor schon beschriebenen Probleme - die hatten ja schliesslich auch eine Ursache.
Und diese Ursache war.... *Trommelwirbel*: die Zugriffsrechte auf das Verzeichnis c:\windows\registration.
Die waren nicht korrekt gesetzt.

Die Erklärung dazu gibts hier:
http://support.microsoft.com/kb/909444/en-us

Ich bin schon kurz davor irre zu werden, aber nach ca 2 Arbeitstagen, die ich dareingesteckt habe, wird jetzt auch nicht mehr aufgegeben.
Aktuell laufen die Offline-Updates. Danach werd ich noch versuchen online Updates zu ziehen. Und dann bin ich mal gespannt...
Ob dies nun wirklich das letzte Problem gewesen ist, erfahrt ihr nach der nächsten Maus...
Bitte warten ..
Mitglied: Lochkartenstanzer
18.12.2013 um 08:03 Uhr
Zitat von coltseavers:

Ich bin schon kurz davor irre zu werden, aber nach ca 2 Arbeitstagen, die ich dareingesteckt habe, wird jetzt auch nicht mehr
aufgegeben.

Dann hast Du wenigstens die Erfahrung gemacht udn das nächsrte Mal wird gleich frisch instaliert.

lks
Bitte warten ..
Mitglied: coltseavers
19.12.2013 um 00:42 Uhr
Dann hast Du wenigstens die Erfahrung gemacht udn das nächsrte Mal wird gleich frisch instaliert.

lks

Neja, dass es generell sinnvoller gewesen wäre sofort neu zu installieren, ist mir durchaus klar, aber erstens wollte ich das System unbedingt wieder flott kriegen, denn bei XP kann man ja noch wenigstens selber hardcore auf Systemebene rumfrickeln, ausserdem wäre es sehr aufwendig für den Kunden gewesen die einzelnen Programme wieder zusammenzutragen und zu installieren, samt Datenrücksicherung und Konfiguration des Systems etc. - wie das halt so ist, wenn es kein Backup gibt... (Folgeauftrag wurde bereits erteilt - der Kunde war plötzlich höchst einsichtig).
Bitte warten ..
Mitglied: coltseavers
19.12.2013 um 00:52 Uhr
FAZIT:
Die Mühle läuft wieder, wenn auch noch nicht zu 100% rund.
An einigen weiteren Stellen waren die Zugriffsrechte nicht korrekt gesetzt (z.B. stellte sich heraus, dass im Temp-Ordner des Benutzers nur Lese- und Ausführungsrechte hatten, aber keine Schreibrechte, was natürlich viele Programme und Setup- und Deinstallationsroutinen davon abhielt sauber zu laufen).
Aber nach Korrektur auch dieser Dinge ist es immerhin wieder möglich den Rechner fehlerfrei zu starten und normal am Rechner zu arbeiten.
Ob diese Lösung nun von Dauer ist werden die nächsten Tage zeigen.

Ich möchte mich an dieser Stelle herzlich für die zahlreichen Beiträge und Tipps bedanken!
Bitte warten ..
Mitglied: Lochkartenstanzer
19.12.2013 um 06:18 Uhr
Zitat von coltseavers:

Aber nach Korrektur auch dieser Dinge ist es immerhin wieder möglich den Rechner fehlerfrei zu starten und normal am Rechner
zu arbeiten.
Ob diese Lösung nun von Dauer ist werden die nächsten Tage zeigen.

Ich wette meine 2¢, daß spätesttens 1 Monat neu aufgesezt wird.
Ich hatte bisher noch keinen Kunden, der auf eien Reparatur statt Neuinstalation bestand, der hinterher keine Probleme hatte. Es wäre sicher mit genug Zeitaufwand möglich all diese probleme zu beseitigen, aber letztendlich will es doch kein Kunde bezahlen udn wird irgendwann einsichtig.

Ich möchte mich an dieser Stelle herzlich für die zahlreichen Beiträge und Tipps bedanken!

Gern geschehen Leidensgenosse.

lks
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Windows Installation
gelöst Probleme mit SATA Treibern unter Windows XP (5)

Frage von bestelitt zum Thema Windows Installation ...

Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows Installation
gelöst Custom-ISO mit integr. Treibern macht Probleme als VM, kann das sein, kennt das jemand? (2)

Frage von departure69 zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...