Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows XP Setup Abbruch bei Komponenten werden registriert

Frage Microsoft Windows Installation

Mitglied: Roemello

Roemello (Level 1) - Jetzt verbinden

12.12.2007, aktualisiert 13.12.2007, 12749 Aufrufe, 4 Kommentare

Hallo zusammen!

Da der interne SATA-Controller eines unserer 2 Faet V3 Notebooks defekt ist wollte ich Win XP Pro SP2 auf eine externe SATA-Festplatte installieren.
Dazu habe ich eine PCMCIA-SATA Controller mit Silicon Image SIL3512 Chipsatz verbaut und den entsprechenden Treiber per F6 und Diskette eingebunden. Die SATA-Platte läßt sich im Windows-Setup problemlos partitionieren und formatieren (40GB NTFS fürs System und ca. 120GB NTFS für Daten).
Die SATA-Controllerkarte bindet sich nicht ins Bios ein, durch zusätzliche Verwendung eines USB-Kabels (und setzen von "USB-HDD" als primäres Bootlaufwerk im Bios) bootet er jedoch und schaltet dann (zu erkennen an den entsprechenden LEDs des SATA-Controllers) auf den SATA Strang um. Name, Seriennummer, Adminkennwort und Netzwerkeinstellungen verlaufen noch absolut normal (inklusive Performance). Dann allerdings bleibt das Setup kurz vor Ende der Installation (angezeigte 15 Minuten) während des Schrittes "Komponenten werden registriert") hängen.

Habe schon Windows 2000 und eine andere XP Pro SP2 CD probiert - ohne Erfolg.

Hat jemand eine Idee woran kann das liegen könnte.
Mitglied: 58502
12.12.2007 um 16:14 Uhr
Windows unterstützt keine Booten von externen USB-Geräten und auch keine Installation auf ein externes USB-Device. Wenn ich das richtig verstehe, wird durch die Umstellung ein USB-Laufwerk emuliert?
Entweder du schaffst es, von der externen SATA-Platte direkt zu booten bzw. sie als eSATA zu betreiben, oder du besorgst dir die c't aus 02/2006 und nimmst die dort empfohlenen Anpassungen vor.
Bitte warten ..
Mitglied: brammer
12.12.2007 um 17:24 Uhr
Hallo,

wenn du die Festplatte nur neu aufsetzen willst mach es besser über das 2.te laptop.
WinXP auf einer externen Platte auf zu setzen und diese dann später intern zu verwenden schafft nur Probleme!
Erfahrungswerte!

brammer
Bitte warten ..
Mitglied: Roemello
13.12.2007 um 07:00 Uhr
Hallo und erstmal danke für eure schnellen Antwort.

@ siebenstein: Ich versuche gar nicht ein USB-Laufwerk zu emulieren (zumindest nicht bewusst) und glaub auch nicht das Windows das versucht. Vermute eher das er nach dem Booten über USB einen Eintrag in der Boot.ini verarbeitet der dann XP (bzw. in diesem Stadium dessen nicht abgeschlossenes Setup) mit den SATA Treibern startet. Nach dem "Umschalten" auf SATA kann das USB Kabel nämlich problemlos entfernt werden... Ich werde mal zusehen das ich den Inhalt der Boot.ini hier poste...

@brammer: Mein Problem ist dass ich die Festplatte (3,5") neu aufsetzen muss weil, wie oben beschrieben, der interne, nicht wechselbare Festplattencontroller (für 2,5") defekt ist, dass Notebook aber als Bürorechner genutzt werden soll. Würde ich jetzt das XP auf dem 2. Baugleichen Notebook aufsetzen hätte ich immernoch 2 Probleme: Erstens sind interner (bei einem der defekte) und der PCMCIA SATA-Controller mit verschienden Chipsätzen ausgerüstet und brauchen demnach verschiedene Treiber, zweitens müsste die Boot.ini sicherlich angepasst werden; wobei hier schon wieder fraglich ist ob das dann auch geht...

Der eigentliche Bootvorgang scheint ja generell zu funktionieren, sonst käme ich warscheinlich gar nicht erst ins erweiterte Setup... die Frage ist wohl eher was passiert zum Abschluss der Installation (wenn die Komponenten registriert werden)...?
Bitte warten ..
Mitglied: Roemello
13.12.2007 um 07:54 Uhr
Bin gerade einen Schritt weiter gekommen, habe gesehen dass im Bios noch der interne, defekte SATA-Controller in der Bootliste stand, nachdem er ausgeschlossen wurde lief das Setup durch.

Bei anschließenden Neustart bleibt er (momentan) kurz vor der Anpassung auf 800x640 px stehen, der Mauszeiger ist schon zu sehen...

Hier trotzdem mal die aktuelle Boot.ini bzw. der Inhalt:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Update: Nach ändern der Boot.ini (DEP war durch "noexecute=optin" aktiv - geändert in "execute" -> DEP damit ausgeschaltet) startet das System nun vollständig. Bin gerade dabei die Treiber zu installieren. Die Performance scheint der einer internen Lösung zu entsprechen.

Die aktuelle Boot.ini sieht also wie folgt aus:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /execute /fastdetect

Vielleicht hilft das ja mal jemandem.
Nochmals danke für eure Posts, hab mir dadurch nochmal die richtigen Sachen durch den Kopf gehen lassen.
Bitte warten ..
Ähnliche Inhalte
Firewall
Checkpoint R76 VPN-Abbrüche (2)

Frage von Leo-le zum Thema Firewall ...

LAN, WAN, Wireless
gelöst WLAN - Abbrüche auf Windows Clients und unbekannte WLAN-Netze in der Übersicht (6)

Frage von Xelsar zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
gelöst Intel ESRT2 Treiber beim Windows Setup (2)

Frage von Maffi zum Thema Festplatten, SSD, Raid ...

CPU, RAM, Mainboards
PC Komponenten Kompatibel? (8)

Frage von lacki196 zum Thema CPU, RAM, Mainboards ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (56)

Frage von pjrtvly zum Thema Internet ...

Server-Hardware
HP DL380 G7: Booten vom USB via USB 3.1-PCI-e Karte möglich? (24)

Frage von Paderman zum Thema Server-Hardware ...

LAN, WAN, Wireless
gelöst IP Adressen - Modem - Switch - Accesspoint (22)

Frage von teuferl82 zum Thema LAN, WAN, Wireless ...

Windows 7
Bluesreens unternehmensweit (22)

Frage von SYS64738 zum Thema Windows 7 ...