Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows XP System wieder startbar machen

Frage Microsoft Windows XP

Mitglied: meto

meto (Level 2) - Jetzt verbinden

13.06.2005, aktualisiert 14.06.2005, 18496 Aufrufe, 10 Kommentare

Hallo Leute!

Nach dem ich gestern meinen Laptop etwas aufgeräumt habe und dabei feststellen musste, dass die Systempartition doch etwas zu klein gewählt ist, hab ich mich entschlossen eine Partition am Anfang des Datenträgers einzufügen, die die Auslagerungsdatei aufnimmt.

Ich hab mir dann den Partitions Manager genommen und aus der Primären Partition C (am Anfang der FP) eine logische Partition gemacht die jetzt zur bereits vorahadnen Erweiterten Partition gehört, um noch Speicher von den anderen zwei logischen Partitionen zuweisen zu können. Anschließend hab ich dieser Partition am Anfang wieder Speicherplatz genommen um ihn dann der neuen Auslagerungspart. zuzuweisen. (Ich hab jetzt also eine Erweiterete Partition mit 4 logischen Part.)

Wie erwartet startet das System jetzt nicht mehr. Bis dahin hat mich das auch nicht überrascht. Ich habe jetzt also die WinXP CD eingelegt und von dort die Reparaturkonsole gestartet. Mit FixMBR hab ich den Bootsector neu schreiben lassen und auch FixBoot ausgeführt.

Anschließen habe ich Bootcfg /add benutzt, wobei am Ende die Fehlermeldung erscheint, dass die Konfiguration nicht geschrieben werden kann.

Beim Neustart des Rechners erscheint dann immer wieder eine Fehlermeldung nach der kein System auf dem Bootmedium (FP) vorhanden währe. Bei der Partitionierung ist nichts falsch gelaufe. Mit einer Knoppix -CD lässt sich das System starten und alle Datein und Partitionen sind da wo sie seien sollten.

Das Betriebssystem ist noch vorhanden und wird auch als solches mit Bootcfg /scan erkannt. Wie bekomme ich den Rechner jetzt dazu dieses wieder zu Booten? Was mache ich falsch oder wie sollte ich sonst noch vorgehen?

Danke schon mal im Voraus!
Gruß
Meto
Mitglied: Helene
13.06.2005 um 07:42 Uhr
Hast Du C:\ wieder Primär gesetzt? Microsofgt besteht immer auf primäre Partition für Bootsystem.
Gruße Helene
Bitte warten ..
Mitglied: mathe57
13.06.2005 um 08:01 Uhr
Hallo Meto!

Dein Problem sieht ganz nach BOOT.INI aus. Da Du aus der primären Partition (unter Windows = Nr.1) eine logische gemacht hast, hat die jetzt eine Nummer >4. Wenn ich richtig mitgezählt habe, dann sind jetzt folgende Partitions-Nummern zugeordnet:

1 = ursprünglich Primäre Bootpartition --> gibts nicht mehr
2 = erweiterte Partition
3 = frei
4 = frei
5 = vorhandene 1. log. Part.
6 = vorhandene 2. log. Part.
7 = NEUE 3. log. Part. mit XP
8 = NEUE 4. log. Part. (Auslagerung)

Du müßtest also mit der Knoppix-CD die BOOT.INI editierten und aus partition(1) partition(7) machen. Dann sollte Dein XP wieder gebootet werden!

Laß mich hören, wenn's klappt.

Gruß
mathe57
Bitte warten ..
Mitglied: meto
13.06.2005 um 08:20 Uhr
Also wenn ich ohne primäre Partition nicht auskomme hab ich glaub ich ein Problem. Hier mal der aktuelle Stand:

- Erweiterte Partition
-1. log. Part. für Auslagerung (am Anfang wegen der Geschwindigkeit)
-2. log. Part. mit System (Windows XP)
-3. log. Part. Software (Programme)
-4. log. Part. Daten (Eigene Dateien, Email)

Die Boot.ini habe ich auch schon mal versucht anzupassen. Dumm ist, dass ich irgendwie mit Knoppix keine Rechte auf das Laufwerk hat. Selbst wenn ich es mit rw Mounte.

Sollte das mit der Primären Partition tatsächlich so sein, kennt dann irgendjemand ein freies Programm mit dem ich die Partitionstabelle anpassen kann ohne Daten zu verlieren und das auch ohne XP läuft. Vielleicht auf der Basis Knoppix. Oder lässt sich das so bewerkstelligen, dass ich die 1. u. 2. log. Part. irgendwie auf Primär setze? Vielleicht über die Reparaturkonsole von XP?
Bitte warten ..
Mitglied: 13100
13.06.2005 um 16:49 Uhr
benütz eine bootfähige dos diskette. mit
edit boot.ini kannst du sie dann bearbeiten.
Bitte warten ..
Mitglied: meto
14.06.2005 um 07:02 Uhr
Ich hab jetzt folgendes gemacht:

Daten gesichert (System und Software mittels Ghost auf usb FP, Daten auf SMB-Server)

1. alle Partitionen gelöscht
2. zwei Prim. Partitionen und zwei logische Partitionen erstelt
3. Daten zurück geschrieben

Der Stand sieht jetzt so aus

- Prim. Part. 1 (für Page File - NTFS - Lw. C)
- Prim. Part. 2 (WinXP Home System - NTFS - Lw. G)
- Erweiterte Part.
- logische Part. 1 (Software / Programme - NTFS - Lw. D)
- logische Part. 2 (Daten - Fat32 - Lw. E)

Ich hab versucht das System wieder Bootfähig zu machen, indem ich Fixmbr und dann Fixboot ausgeführt habe. Anschließen habe ich mit bootcfg die boot.ini erstellenlassen (auf Lw. C). Alles funktionierte ohne Fehlermeldung, nur der Neustart nicht. Wie jetzt weiter - neu installieren?
Bitte warten ..
Mitglied: mathe57
14.06.2005 um 07:41 Uhr
1. Frage:
Kann es sein, dass Du die primäre Partition 2 noch nicht auf AKTIV gesetzt hast?!

2. Frage:
Welchen logischen Laufwerksbezeichner hatte Dein XP-Systemlaufwerk, bevor Du die Partitionen verändert hast? War es C: oder D: oder ein ganz anderer Buchstabe?

Wenn es ursprünglich C: war und neuerdings G: ist, dann klappt das nicht mit dem Booten. Ich bin der Meinung, dass Du die erste primäre Partition nochmal löschen, aber den Plattenplatz frei lassen solltest. Damit sollte Deine dann einzige primäre Systempartition als C: erkannt werden. Die Partition für das pagefile kannst Du dann später im laufenden System anlegen und einrichten. Poste doch bitte auch mal die Meldung, die Dir jetzt beim Bootversuch ausgegeben wird.

Gruß
mathe57
Bitte warten ..
Mitglied: meto
14.06.2005 um 08:04 Uhr
Vorher war es Lw. C. Die Partition ist aktiv. Ich habe die Partitionierung mit QParted (Linux) machen müssen, weil Diskpart immer aus der erten Partition die primäre macht und aus dem Reste eine Erweiterte.

Die Variante, die erste primäre Partition zu löschen hört sich gut an. Sollte ich dann noch einmal fixmbr oder fixboot benutzen oder sollte es auch ohne gehen?

An der Stelle muss ich mal wieder Linux ein Lob aussprechen. Da ist das nicht so ein Akt.
Bitte warten ..
Mitglied: mathe57
14.06.2005 um 08:45 Uhr
Es müßte auch ohne fixmbr / fixboot gehen. Nur die BOOT.INI muß natürlich übereinstimmen mit der Partitions-Nummer Deiner Systempartition!

Auch wenn Du die 1. Partition erstmal löschst, bleibt die Systempartition von Windows immer noch die Nummer 2 .

Damit sollte in der BOOT.INI folgender Verweis zum Bootloader stehen:

[boot loader]
timeout=10
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Home" /noexecute=optin /fastdetect

Nun sollte es aber endlich mit dem Systemstart funktionieren.

Gruß
mathe57
Bitte warten ..
Mitglied: meto
14.06.2005 um 09:04 Uhr
Danke schon mal für den Anstoß. Ich werd das heute Abend mal testen.
Bitte warten ..
Mitglied: meto
14.06.2005 um 21:33 Uhr
Perfekt! Geht wieder!! ) Bin jetzt folgender Maßen vorgegangen:

Zunächst hab ich die erste Partition gelöscht und neu geboote. Das brachte nicht den Erfolg. Auch das Anpassen der Boot.ini sowie das ausführen von fixmbr und fixboot half nicht.

Hab mir dann einfach eine WinXP CD geschnappt und die Installation bis zur Lizenzvereinbarung durchlaufen lassen (OEM-Version). Die hab ich dann abgelehnt, weil er an dem Punkt bereits einmal von der FP gebootet hat. Jetzt hab ich mein Ghost-Image vom System zurück gesichert. Bootvorgang mit dem alten System funktionierte ).

Hab dann noch mit der Datenträgerverwaltung die 1. Partition für die Auslagerungsdatei erstellt. Dadurch blieb mir das Problem mit den geänderten Laufwerksbuchstaben erspart. Jetzt ist alles besten.

Danke an alle !!
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Windows XP
gelöst Windows XP SP 3 System Clonen (19)

Frage von zeroblue2005 zum Thema Windows XP ...

Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows XP
Kann man noch neue Notebooks für Windows XP kaufen ? (9)

Frage von DieterJansen zum Thema Windows XP ...

Windows Systemdateien
gelöst Wer legt Windows und System ordner ins Basisverzeichniss oder ins Benuterprofil (5)

Frage von keksprinz zum Thema Windows Systemdateien ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...