Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows XP TAPI - Probleme beim Erkennen bzw. Benutzung von Endgeräten

Frage Microsoft Windows Tools

Mitglied: jaklassen

jaklassen (Level 1) - Jetzt verbinden

18.05.2010, aktualisiert 19.05.2010, 10838 Aufrufe

Probleme beim Erkennen von Geräten u.A. bei der Windows Wählhilfe.
Endgerät: Elmeg CS410.
Fehlercode: LINEERR_RESOURCEUNAVAIL [8000004B]

Hallo Community!

Nach mehrmaligen Neu-Installieren der TAPI- und Gerätetreiber habe ich immernoch Probleme, mit dem Telefon über die TAPI-Schnittstelle des PC's zu telefonieren.
Das manuelle Wählen, sprich Höhrer abheben -> Telefonnummer wählen -> Durchstellen und das Gespräch führen funktioniert einwandfrei.

Ich habe keine Ahnung woran es liegen kann.
Entweder handelt es sich um fehlerhafte TAPI-Treiber (was ich aber nicht denke, da ich die aktuellsten Treiber vom Hersteller bezogen und installiert habe) oder evtl. an irgendwelchen Einstellungen in der TK-Anlage an sich, z.B. eine Inbound-Line festlegen o. Ä..
Das Telefon wird via USB an den PC angeschlossen, das funktioniert auch ohne Probleme, selbst das Auslesen der Daten vom Telefon mit Hilfe von WINTools funktioniert einwandfrei.

Hier mal ein Trace von dem Tool: Tapi Trace:

//Tapi Trace
...Please select Tapi Line and press Start!

LineOpen: elmeg C3x0
PermanentLineID: 000B0000
Provider: elmeg C3x0 Series Telephony Service Provider
LineOpen returned: LINEERR_RESOURCEUNAVAIL

Wie man erkennen kann, ist die Ressource nicht verfügbar, aber hat jemand eine Ahnung wie und wo ich dieses Problem beheben kann, oder warum die Ressource überhaupt nicht verfügbar ist?

EDIT #1:
Ich habe mal das "TAPI Diagnose-Tool" ExceleTel Teletools drüberlaufen lassen und folgendes kam zum Vorschein:


ExceleTel TeleTools v3.7.1.2

Create etLine
Address.ID := 0
Address.Count = 1
Address.Name = 'PPPoE VPN'
TeleScope.Visible := True
DevEnv := deDelphi
Device.ID := 4
Device.Count = 5
Address.ID := 0
Address.Count = 1
Address.Name = '147'
Device.Name = 'elmeg C3x0'
Device.Active := True
Device.Count = 5
Device.ID = 4
Device.Name = 'elmeg C3x0'
lineOpen returned LINEERR_RESOURCEUNAVAIL

<< Error >> LINEERR_RESOURCEUNAVAIL [8000004B]

Ich habe mal nach dem genauen Fehlercode gegoogelt und folgendes gefunden:

LINEERR_RESOURCEUNAVAIL [8000004B]
Insufficient resources to complete the operation. For example, a line cannot be opened due to a dynamic resource over-commitment.

Meine Übersetzung:
Nicht genügend Ressourcen zur Vollendung der Operation vorhanden, z.B. kann keine (Telefon)-Leitung aufgrund eines dynamischen
Ressourcenkonflikts (?) geöffnet werden.

Daraus schließe ich, dass es wohl nur an den Einstellungen der TK-Anlage liegen kann, oder liege ich da falsch?

EDIT #2:
So, ich habe mich mal mit einem meiner Mitarbeiter kurzgeschlossen, und er meinte, dass es nichts mit der TK-Anlage zu tun hat.
Das einzige was jetzt noch bleibt ist, dass evtl. irgendein anderes Programm den TAPI-Dienst schon benutzt und somit die "Leitung" blockiert.
Der Telefondienst wird komischer beim Systemstart mitgestartet, jedoch manuell. (also startet wohl irgendein Dienst bzw. Programm den Telefondienst)

Dann wollen wa mal nachgucken, wie und was das verursacht.

EDIT #3:
So, ich habe das alles mal unter einem anderen Betriebssystem getestet.
Hierbei habe ich Windows 7 Enterprise verwendet, die Geräte- und TAPI-Treiber von der Herstellerseite bezogen, alles installiert und konfiguriert.
Komischerweise funktioniert es! Die Telefonie über Outlook klappt ohne Probleme und die Telefonie über das Wählprogramm "JustDial" funktioniert auch 100%ig!
Es kann wohl nur an dem TAPI-Treiber für Windows XP liegen. (SP3 installiert) Es gibt auf der Seite www.tapicall.de einen modifizierten TAPI-Treiber für Windows XP,
mit dem es wohl funktionieren sollte.
Der hat bei mir aber auch nicht funktioniert.

Mal nachschauen, wo genau es jetzt unter Windows XP hackt. Sobald ich eine Lösung gefunden habe, werde ich diese natürlich hier hinterlegen!


Falls sich aber dennoch jemand damit auskennt, bitte melden!

Gruß,
Jakob
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Installation
gelöst Probleme mit SATA Treibern unter Windows XP (5)

Frage von bestelitt zum Thema Windows Installation ...

Windows 10
Windows 10 Start-Probleme - Hilfe (9)

Frage von clragon zum Thema Windows 10 ...

Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows XP
Kann man noch neue Notebooks für Windows XP kaufen ? (9)

Frage von DieterJansen zum Thema Windows XP ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...