Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows7 mit Login Scripts in Verwendung mit UAC

Frage Microsoft Windows 7

Mitglied: Crisi1977

Crisi1977 (Level 1) - Jetzt verbinden

10.11.2010 um 08:35 Uhr, 5051 Aufrufe, 2 Kommentare

Hallo ich habe ein Problem mit den Login Scripts von Windows 7. Wir haben einen Win 2003 64Bit Standard Server im Einsatz und dieser ist der DC mit AD usw. Auf einem anderen Server Win2003 Standard 32Bit läuft das Netlogon mit normalen Loginscripts (net use Befehle) als Batchdateien. Diese sind im AD auch für den einzelnen User auch eingetragen. Folgendes Problem besteht nun seid wir 3 Rechner mit Win7 haben.

Die Rechner bekommen ihr Login und auch die Laufwerke. Allerdings verschwinden diese dann nach einiger Zeit bzw. werden als nicht verbunden angezeigt. Bei dem Versuch sie wiederzuverbinden kommt die Meldung dass Laufwerk nicht verfügbar bzw. noch in Verwendung sei. Bei den XP Rechnern geht alles wie gewohnt.

Nach einigen Recherchen im Netz und auch hier habe ich einige Tipps bekommen und folgendes schon probiert:

1. UAC deaktivert
2. Den Registrykey "EnableLinkedConnections" eingestellt ?
3. Das Launchapp.wsf Script eingebunden
4 Befehle wie ifmember usw. gehen nicht da keine Gruppen gewünscht sind daher auch keine GPO Verteilung.

Leider hat keins der eingestellen Dinge den gewünschten Erfolg. Die Laufwerke verschwinden immer noch. Wenn ich die Laufwerke per Hand mappe dann geht alles ohne Probleme. Allerdings habe ich das Gefühl das der Key nich greift.. wenn ich als Admin angemeldet bin, Ich öffne die Registry gebe den DWORD "EnableLinkedConnections" Dezimal 1" ein und schließe die Reg. Danach Rechner neu starten. Danach erneute Anmeldung und Kontrolle. Er hat den Wert auf Hex 1 umgestellt. Ist das normal?

Was kann denn da noch das Problem sein? Wir wollen bald die kompletten Rechner umstellen und dann sollten die Loginscripts laufen. Die Benutzer haben alle unterschiedliche Loginscripte und das soll auch so bleiben.

Was habe ich denn da noch für Möglichkeiten das Problem zu lösen? Hoffe ihr könnt mir helfen... Danke schon mal

Gruß Chris
Mitglied: cyclon
10.11.2010 um 14:23 Uhr
Hallo Chris,

wie sieht denn dein Skript aus? Ich kenne das auch, dass Win7 manchmal Probleme mit Netzlaufwerken macht.
Ich mache das so:
1) erst alle Netzlaufwerke löschen
2) Netzlaufwerke verbinden mit /persistent: no

Das könnte dann so aussehen:
@echo off

rem Netzlaufwerke loeschen
net use * /delete /yes

net use l: \\dc01\Freigabe /persistent:no
net use z: \\dc01\Freigabe1 /persistent:no
Bitte warten ..
Mitglied: Crisi1977
11.11.2010 um 08:49 Uhr
Hi so sieht das Script aus

rem @echo off
cls

rem
rem Connect the user devices
rem
rem Version 1.0
rem Name
rem



echo
*
echo * Welcome
echo
*

rem

rem Map the user specific devices and a temporary network device
rem



net use n: \\Domänencontroller\netlogon /persistent:no
goto ende

:ende

rem

rem Map the group specific devices
rem
**



call n:\alluser.bat
call n:\product.bat
call n:\prodsupp.bat
call n:\family.bat

net use n: /delete
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows 10
Nonstop Login im Sperrbildschirm (4)

Frage von TiCar zum Thema Windows 10 ...

Server
gelöst Amazon-IP, Googlebot und wp-login (12)

Frage von NoWoPr zum Thema Server ...

PHP
PHP MySQL Login (7)

Frage von Yanmai zum Thema PHP ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...