Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WinXP Gbit Lan - schreiben langsam lesen schnell - von beiden Rechnern

Frage Microsoft Windows Netzwerk

Mitglied: zax-v12

zax-v12 (Level 1) - Jetzt verbinden

25.01.2009, aktualisiert 12:16 Uhr, 7199 Aufrufe, 12 Kommentare

Hallo erstmal an alle!

Ich habe folgendes Problem:

Ich habe zwei WinXP (ein Home, ein Pro) Rechner per Corssover Kabel verbunden. Beides recht neue Rechner Core2Duo und ein Intel Pentium Duo (oder so ähnlich).
Beide mit Asus Boards und Onboard GBit NIC.

Wenn ich Dateien vom entfernten Rechner zu mir her kopiere geht das mit ~35.000 kByte/s
Wenn ich Dateien auf den entfernten Rechner hin kopiere geht das mit ~20.000 kByte/s

Und das egal an welchen Rechner ich mich setze. Schreiben geht also langsam, lesen schnell.
An den Platten kann es ja nicht liegen, da es ja auf beide Platten schreibend schnell geht (muss mich nur an den entsprechenden Rechner setzen).

Auf beiden Rechnern ist SP3 installiert und es laufen keine Firewalls oder Virenscanner.

Der mit iperf gemessene Durchsatz liegt bei 800-900 Mbits/s in beide Richtungen.


Leider habe ich keine Ahnung was ich tun kann, damit ich auch mit wenigstens 35.000 kByte/s ins Netz schreiben.


Vielen Dank an jeden der das liest.
Gruß Zax


a.j.: Ich habe irgendwo gelesen, dass 300-400 Mbits/s eine durchaus normale Übertragunsrate im Gbit Lan sind. Stimmt das oder wäre da theoretisch mehr drin?
Mitglied: Ironie
25.01.2009 um 12:34 Uhr
Hallo Zax,

stört da evtl. eine Virenschutzsoftware oder ein Indexierungsprogramm?

Gruß
Bitte warten ..
Mitglied: zax-v12
25.01.2009 um 15:37 Uhr
Hey,
nein Virenscanner läuft keiner, bzw. ich habe bei AntiVir den Haken bei AntiVir aktivieren weggemacht. Jetzt ist der Regenschirm geschlossen. Das deute ich mal als inaktiv.

Das mit dem Indexprogramm muss ich mal testen. Vielen Dank für den Tipp.

Du meinst diesen Haken, irgendwo bei den Eigenschaften vom Laufwerk "Laufwerk für schnelle Suche indizieren" wegmachen?
Weiß leider grade nicht wie das genau heißt, weil ich grade nicht an meinem Rechner sitze. Gucke aber später danach.
Bitte warten ..
Mitglied: DerWoWusste
25.01.2009 um 17:42 Uhr
Iperf benutzt die Festplatte nicht, schätze ich - es lässt nur die Netzwerkkarten miteinander reden. Somit ist es kein Realtest zum Vergleich mit dem tatsächlichen Schreiben von Daten via Netzwerk. Deinstalliere zunächst Antivir und starte neu, ich würde einem Deaktivieren nie ausreichend trauen, um den Scanner als Ursache auszuschließen.
Dann: Was schreibst Du? Nimm riesige Dateien (mehrere Hundert MB), bei kleinen kann die Zugriffszeit auf die Dateien die Rate in den Keller reißen. Miss auch die Plattenlese- und Schreibgeschwindigkeiten mit einem Benchmarktool.
Außerdem lohnt es sich eventuell, ein paar Treiberversionen für die NICs durchzuprobieren.
Bitte warten ..
Mitglied: zax-v12
26.01.2009 um 10:22 Uhr
Ich kopiere zwischen den Rechnern zwei 550MB große Dateien.

Die Virenscanner sind deinstalliert, die Laufwerksindizierung abgeschaltet.

Das mit iperf hatte ich nur geschrieben um Tipps wie "Evtl. hat das Kabel einen Bruch" vorzubeugen.
Dass das keine Realwerte ergibt ist klar.

Ich habe mit dem hd2bench oder wie das heißt (von der ct) die Lesegeschwindigkeit der Platten gemessen.
Zum Schreib-test braucht man wohl eine leere PArtition die ich grade nicht habe.

Aber daran kann es ja wie gesagt eigentlich nicht liegen, da ich ja von beiden Rechnern aus jeweils aus dem Netz lesend auf die eigene Platte schnell schreiben kann.

Klar schnell ist relativ. Aber wenn es in beide Richtungen mit 40.000 kBytes/s geht, kann ich mir über weiteres Tuning Gedanken machen.


Danke schonmal aber ich bräuchte noch weiter eure Hilfe.


a.j.: An den Treibern rumzuspielen habe ich mich noch nicht "getraut". Bei dem einen Rechner ist eine Realtek Karte bei dem andere eine Attansic verbaut. Es sind also auch unterschiedliche Treiber geladen. Denke nicht, dass beide Hersteller just in der von mir eingesetzten Version den Fehler ham, dass schnell gelesen aber nur langsam geschrieben werden kann.
Bitte warten ..
Mitglied: DerWoWusste
26.01.2009 um 18:55 Uhr
Denke nicht, dass beide Hersteller just in der von mir eingesetzten Version den Fehler ham
Dir ist klar, das bei allen Aktionen beide Karten beteiligt sind? Da reicht es, wenn ein Hersteller den Fehler hat, also ist es nicht auszuschließen. Date sie up, geht doch fix.
Außerdem:
es laufen keine Firewalls oder Virenscanner
Später kam dann raus, dass Antivir deaktiviert lief. Gilt das selbe für eine Dritthersteller-Firewall? Schmeiß diese ggf. runter und starte neu.
Bitte warten ..
Mitglied: zax-v12
28.01.2009 um 13:16 Uhr
Hallo,
up to date sind die Treiber natürlich. Mit älteren Versionen hatte ich keine Lust rumzuspielen.


Und ich denke schon, dass beide Karten den Fehler haben müssten. Evtl. habe ich mich oben etwas unklar ausgedrückt:

Wenn ich am Rechner A eine Datei von Rechner B lese und auf Rechner A kopiere geht das mit 40.000 kBytes/s.
Wenn ich am Rechner B sitze und eine Datei auf den Rechner A kopiere, geht das mit 20.000 kBytes/s.

Im Grunde wandern die Daten also in die gleiche Richtung durchs Netz, aber je nachdem von wo ich den Kopiervorgang starte ist der Durchsatz unterschiedlich hoch.

Und das gleiche gilt wenn man A mit B vertauscht.

Ich denke eher dass das ein Problem von Windows ist. Der wartet beim Schreiben länger auf irgendwelche Bestätigungen als beim lesen oder sowas vermute ich.

Wäre immer noch für Hilfe sehr dankbar, da ich bisher nicht weiter gekommen bin.
Bitte warten ..
Mitglied: Ironie
28.01.2009 um 14:42 Uhr
Schwierig schwierig....

Hast Du mal einen anderen computer/Notebook angeklemmt?
Wäre interresant, wie es sich da verhält. So käme man evtl. einen Schritt weiter....

Gruß
Bitte warten ..
Mitglied: zax-v12
28.01.2009 um 16:12 Uhr
Ok, ich bitte mal einen Freun mir seinen Laptop mitzubringen.

Aber den Reaktionen entnehme ich, dass das bei euch nicht so ist. Lesen und schreiben sollte also (wenn die Platte das kann) in etwa gleich schnell sein?

Evtl. ist das ja auch bei Windows einfach so...
Bitte warten ..
Mitglied: zax-v12
06.02.2009 um 08:58 Uhr
Mit dem Laptop war alles noch langsamer. Denke aber das liegt an der langsamen kleinen Platte im Laptop.
Ich darf am WE mal in die Firma und da zwischen den Rechnern hin und her kopieren.

Mal sehen wie schnell das da geht.
Schreibe dann meine Messungen nochmal.
Bitte warten ..
Mitglied: Ironie
06.02.2009 um 09:01 Uhr
Konnte bei mir in der Firma so einen Unterschied nicht feststellen...
Bitte warten ..
Mitglied: zax-v12
19.02.2009 um 19:55 Uhr
Komme jetzt nicht weiter und wollte mich aber trotzdem mal allen bedanken.
Danke
Bitte warten ..
Mitglied: Chefffuscher
22.11.2009 um 04:39 Uhr
Hallo ich hänge nun vor demselben Problem.
Ich habe einen Server erstellt mit Raid 5 System 4 SAS Platten (eigener Raid Controller mit 256MB Arbeitsspeicher) ( PCI-E).
Server hat auch eine Separate Netzwerkkarte (Intel® PRO/1000 PT Server-Adapter (PCI-E)
Chipsatz = Intel MCH X48
CPU = 2x 3GHZ
Arbeitspeicher = 2x2GB 1600 DDR3

So das Problem ist wie oben beschreiben wen ich was vom Server Lese habe ich ca. 500MBit/s ( 50% Auslastung )
Aber wenn ich was auf den Server Drauf schieben will komme ich nur auf 190MBit/s (19% Auslastung)

Dieses Problem tritt nur dann auf wenn beide Teilnehmer XP Rechner sind.
Sobald z.B. der Server das Betriebssystem Windows Server 2003 hat habe ich in beiden Richtung 500MBit/s (50% Auslastung)

Wenn ich mit einen Vista Rechner drauf zugreife habe ich vollen Datendurchsatz (1000MBit/s 120MB/s 100%) ( egal ob Server XP Betriebssystem hat oder Windows Server 2003 )

Getestet wurde immer mit einer 10GB Image Datei.

Mit NetIO kommt immer dasselbe heraus egal welches Betriebssystem an dem Spielchen teilnimmt.

Versucht habe ich mittlerweile:

1.QoS-Paketplaner:
versucht einzustellen und nachher komplett Deaktiviert.

2.Programm:
tcp optimizer

3.Regestry :
Hkey_Local_Machine/Software/Microsoft/Windows/CurrentVersion/Explorer/RemoteComputer/NameSpace/{D6277990-4C6A-11 CF-8D87-00AA0060F5BF}
gelöscht

4.Hkey_Local_Machine/System/CurrentControlSet/Services/Tcpip/Parameters/TcpWindowSize
wert Dezimal geändert auf =4000000

5. Klicken Sie unter Systemsteuerung auf die "Verwaltung" und gehen Sie unter "lokale Sicherheitsrichtlinie". Wählen Sie hier "lokale Richtlinie/Sicherheitsoptionen".

Hier deaktivieren Sie folgende Einstellungen:

Microsoft-Netzwerk (Client): Kommunikation digital signieren
Domänenmitglied : Daten des sicheren Kanals digital verschlüsseln oder signieren
Domänenmitglied : Starker Sitzungsschlüssel erforderlich
Domänenmitglied : Daten des sicheren Kanals digital signieren (wenn möglich)
Domänenmitglied : Daten des sicheren Kanals digital verschlüsseln (wenn möglich)

Also Ziel ist es mit dem Betriebssystem XP auf dem Server zu XP / Vista /Windows 7 guten Datenduchsatz zu erreichen.
Netzwerkleitung ist Cat6 Direkt Verbindung zum testen.
Und die Oben Genannten Test zeigen ja das Die Festplatten sowie die Netzwerkkarte die Bandbreite ausnutzen können.
Das es irgendwie am XP Betriebssystem liegt nur ich habe die richtigen Einstellungen noch nicht gefunden
Vor allem das Schreiben auf dem Server Stört sehr das es so langsam ist.

Bin gespannt ob irgendwer ne gute Idee hat ich probiere sie gerne aus.
Es würde mich interessieren ob ihr das selbe Problem habt oder seit ihr schon alle auf andere Betriebssystem umgestiegen?
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Update
gelöst WSUS-Downloads im LAN extrem langsam seit Win-10-Anniversary-Update 1607 (1)

Frage von departure69 zum Thema Windows Update ...

LAN, WAN, Wireless
gelöst LAN Plötzlich langsam (12)

Frage von KodaCH zum Thema LAN, WAN, Wireless ...

Notebook & Zubehör
HP 8770W - LAN Netzwerkproblem (Aufbau, Geschwindigkeit) (5)

Frage von RiceManu zum Thema Notebook & Zubehör ...

Notebook & Zubehör
Kaufempfehlung Netboook - mit LAN-Anschluss! (5)

Frage von SarekHL zum Thema Notebook & Zubehör ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...