Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wireshark - VLAN Tag wird im Ethernetpake nicht angezeigt

Frage Linux Linux Netzwerk

Mitglied: zulius

zulius (Level 1) - Jetzt verbinden

09.12.2011, aktualisiert 15:28 Uhr, 10766 Aufrufe, 5 Kommentare

Hallo sicher wisst ihr mehr.

Ich nutze Wireshark v1.6.4 und möchte gerne aus dem Datenverkehr zwischen meinem VLAN das Ethernetpaket näher betrachten.
154747f2090cb4a9a07339b854ed7e62 - Klicke auf das Bild, um es zu vergrößern
VLAN2 und VLAN3 können kommunizieren. Der Switch ist ein Cisco SG 200-08
1a567dfe9055a586b50dc01470fc4023 - Klicke auf das Bild, um es zu vergrößern

Ich bin der Meinng, dass wenn ich von VLAN 3 ein Ping gesendet wird, die VLAN ID im Fram ist und über das Trunkkabel zum Router geht. Dabei kommt es ja am HUB vorbei. Hub darum, weil ja an alle seine Ports das Signal gegeben wird.

Kann mir jemand weiterhelfen, warum ich nix sniffen kann
Mitglied: Anton28
09.12.2011 um 15:44 Uhr
Hallo Zuluis,

zeichnet Wireshark gar nichts auf, oder siehst Du nur keine VLAN-IDs ?

Also ich würde am Cisco-Switch eine Port(Sniffer-Port) als trunked definieren und ihn in beide VLANs geben.
Dann würde ich einen Portspiegel einrichten von Ports 8 nach dem Port(Sniffer-Port) an dem Du sniffen willst.
Dann müsstest Du in Trace die VLAN-IDs sehen.

Welches OS hast Du auf dem Wireshark Rechner ?
Welche Netzwerkkarte hast Du in diesem Rechner ?
Unterstützt die Netzwerkkarte VLANs ?

Gruß

Anton
Bitte warten ..
Mitglied: MrNetman
10.12.2011 um 19:55 Uhr
Hallo Zulius,

Trunk heißt nicht zwingend, dass das VLAN3 auch auf dem Port anliegt.
Funktioniert das das Inter-VLAN-Routing?
Wohin geht der Ping? Ist dem Port überhaupt das VLAN zugeordnet? Welches VLAN-Protokoll wird benutzt.
VLAN1 ist das default VLAN und kann oft nicht ausgeschaltet werden - oft aus guten Grund. Ein Ersatzgerät könnte sonst oft nur schwer angeschlossen werden. Die Weboberfläche von den switchen benutze ich nicht. Oft sind nur Teile der Konfiguration sichtbar.
In jedem Falle sollte das CDP Protokoll gesehen werden. Darin steht auch die Portkonfiguration und das VLAN.

Gruß
Netman
Bitte warten ..
Mitglied: zulius
12.12.2011 um 08:26 Uhr
Danke dass ihr auf meinem Aufruf reagiert habt.

Ich möchte es noch mal etwas genauer beschreiben. Meine Karte ist eine :
Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
und diese unterstütz auch VLANs. Das ganze läuft auf einem Windows7 PC. Das Netzwerk ansich funktioniert auch mit den VLANs und läuft. Wie gesagt nun wollte ich mal schauen wie die Pakete genau aussehn mit dem Hub. Ich werde es mit dem Portspiegel ma versuchen, aber warum geht es nicht mit dem Hub. Ich kann kann mit Wireshark ein Ethernet Paket empfangen dort und kann es auch untersuchen - nur die VLAN Option wird nicht angezeigt.
Der Portspiegel geht und ich kann sniffen. Hier das Ergebniss eines Pings.
5174d490feec14fc87855a4c509bf6df - Klicke auf das Bild, um es zu vergrößern
Meine Wireshark Version müsste es auch können, dies habe ich schon im Internet raus bekommen.
Das Protokoll was du meinst habe ich auch gefunden. Dort sehe ich auch den Port vom Mikrotik Router. Nur keine VLAN ID und den Port vpm Cisco Switch sehe ich auch nich.
783b1c75e02de462dbe1e16da11d5a5c - Klicke auf das Bild, um es zu vergrößern

Kann es sein dass die VLAN IDs raus genonnem werden durch eine Fehleisntellung von mir am Cisco
Bitte warten ..
Mitglied: MrNetman
12.12.2011 um 19:32 Uhr
Hallo Zulius,

Diese Art von Fehleinstellungen gibt es immer. Einer meiner Wireshark's trägt Version 1.4.4.
Ich habe Wireshark mit einem ISL-getaggten Stream getestet. Er zeichnet sauber auf. man kann dazu auch "PlayCap is a GUI tool for playing back pcap/Wireshark captures (GPL, Linux/Windows). " Wireshark Webseite verwenden. Selbst auf dem eigenen Interface und auch an jedem anderen geswitchten Interface kann man einen Trace, der nicht zum Netzwerk gehört abhören und aufzeichnen.
Es besteht die Möglichkeit, das keine VLAN-IDs übetragen werden. Beim Spiegeln muss man da oft gut aufpassen und die VLAN-IDs am Spiegelport drin lassen oder besser wieder aktivieren.
Die Switche unterstützen auch das Spiegeln eines VLANs. Das ist ein gute Test um zu sehen, ob in dem VLAN überhaupt etwas ist. Der Port an dem die Daten aus dem Switch kommen ist typischer weise ohne VLAN-ID. Wenn es denn die VLANs so gibt. Dann müssten auch deutlich weniger Pakete ankommen.

Die Daten im Wireshark zeigen ja, dass geroutet wird, also kommen alle Pakete vorbei. Aber diese Konstellation würde eben auch ohne VLANs so funktionieren.
Über die Konfiguration des Routers wure aber noch nichts gesagt. Der muss natürlich das selbe VLAN-Protokoll unterstützen 802.1q.
Bitte warten ..
Mitglied: zulius
13.12.2011 um 15:58 Uhr
Hallo Mr Hetman
schön dass du soviel Nerven mit mir hast

Diese Art von Fehleinstellungen gibt es immer. Einer meiner Wireshark's trägt Version 1.4.4.
Ich habe eine Fehleinstellung? Welche ist es denn und wie kann ich sie beheben?

Es besteht die Möglichkeit, das keine VLAN-IDs übetragen werden. Beim Spiegeln muss man da oft gut aufpassen und die
VLAN-IDs am Spiegelport drin lassen oder besser wieder aktivieren.
Es kann gut sein, dass sie nciht drin sind, aber wie bekomme ich sie wieder rein? Irgentwo müssen sie ja sein, weil wenn sie über den Trunk gehn - müssen sie ja wissen wo sie landen sollen

Die Switche unterstützen auch das Spiegeln eines VLANs. Das ist ein gute Test um zu sehen, ob in dem VLAN überhaupt
etwas ist. Der Port an dem die Daten aus dem Switch kommen ist typischer weise ohne VLAN-ID. Wenn es denn die VLANs so gibt.
Du meinst jetzt einen normalen Port des VLANs oder? Ich aber bin ja von dem Trunk Port ausgegangen und der müsste die doch führen.

Über die Konfiguration des Routers wure aber noch nichts gesagt. Der muss natürlich das selbe VLAN-Protokoll
unterstützen 802.1q.

9d9252e1a3127d04a1eea4268893842d - Klicke auf das Bild, um es zu vergrößern
BTTE denk dir mal die SPI Regeln weg und meine Firewall Regeln sehn so aus. Aber an sich denke ich, dass ich einfunktonierendes VLAN gebaut habe.

01.
/ip firewall filter  
02.
add action=accept chain=forward comment="Traffic von VLAN2 nach VLAN3 erlauben" disabled=no in-interface=vlan2 out-interface=vlan1  
03.
add action=accept chain=forward comment="Traffic von VLAN3 nach VLAN2 erlauben" disabled=no in-interface=vlan1 out-interface=vlan2  
04.
add action=drop chain=forward comment="Alles andere verbieten" disabled=no
Möchte noch mal sagen, es ist nur ein Versuchsmodel. Also nicht wundern, warum ich plötzlich VLAN2 und VLAN3 verbinden möchte.
Bitte warten ..
Ähnliche Inhalte
Monitoring
Wireshark: Anzeige von VLAN-Tags
gelöst Frage von honeybeeMonitoring2 Kommentare

Hallo, wo finde ich die VLAN-Tags in Wireshark? Ich versuche gerade, eine Station von einer Hyper-V-VM aus anzupingen. Ping ...

LAN, WAN, Wireless
Vlan-Tags Mikrotik
gelöst Frage von BoomBoomBenLAN, WAN, Wireless13 Kommentare

Dank aqui ´s Empfehlung habe ich mir nun einen kleinen Mikrotik RB750GL zum warm werden zugelegt. Nach ein paar ...

DSL, VDSL
VDSL Modem welches das VLAN Tag entfernt
gelöst Frage von goschoDSL, VDSL14 Kommentare

Hi Leute, an einem Standort werden aktuell 3 ADSL-Anschlüsse auf einem Netgear SRX-5308 im Loadbalancing-Modus genutzt. Aus diesen sollen ...

LAN, WAN, Wireless
VLAN tag handling auf Switches bei Weiterleitung
Frage von d3s7ruc70rLAN, WAN, Wireless4 Kommentare

Hallo, wie werden VLAN tags im Switch gehandhabt? Werden diese bei der Weiterleitung an "normale" Ports (d.h. kein trunk ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 18 StundenMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 20 StundenDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 21 StundenSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke14 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Server-Hardware
Veeam Backup Server stürzt alle paar Tage ab
Frage von Leo-leServer-Hardware12 Kommentare

Hallo Forum, ich habe momentan folgendes Problem. Veeam Backup and Replication 9.5 u2 auf voll gepatchten DL 380 G7 ...

Windows 10
Windows10-Schnellzugriff per Kommandozeile bearbeiten
Frage von SarekHLWindows 1010 Kommentare

Hallo zusammen, weiß jemand, wie ich per Kommandozeile (in einem Logon-Script) den persönlichen Dokumentenordner aus dem Schnellzugriff entferne den ...