Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Mit WLan zum Router und mit LAN zum Receiver gleichzeitig geht nicht.

Frage Netzwerke

Mitglied: starfox2000

starfox2000 (Level 1) - Jetzt verbinden

30.08.2009, aktualisiert 18.10.2012, 8370 Aufrufe, 8 Kommentare

Hallo,

ich habe da ein hoffentlich kleines Problem mit dem ich nicht klar komme.
Mein Netzwerkaufbau sieht folgendermaßen aus:

5084c2da621dae660d612c717f42908e-netzwerkaufbau_20090830 - Klicke auf das Bild, um es zu vergrößern

Erklärung zu dem Bild:
Router 1 ist von meinem Internet Service Provider (ISP) dieser hat eine Router-IP 192.168.1.1.
Daran hängt per LAN der Router 2 (FritzBox 7050) und hat eine Router-IP 192.168.178.1.
Der Router 2 ist für den Internetzugang über LAN A eingestellt und hat als IP 192.168.1.2 mit Gateway IP 192.168.1.1.
Mein PC 1 ist mit Router 2 per WLan eingerichtet.
An meinem PC 1 habe ich noch einen Receiver (DBox II) per LAN verbunden und diese sind in dem Netz 192.168.5.xxx

So, nun zu meinem Problem.
Es klappt ja eigentlich soweit alles, nur wenn ich beides gleichzeitig nutzen will, dann geht das Internet nicht mehr, oder nur kurzzeitig.
Also wenn ich im Internet sein will, dann habe ich die LAN-Karte deaktiviert und wenn ich per FTP auf den Receiver zugreifen will, dann aktiviere ich die LAN-Karte wieder.
Nur ist dann die Verbindung von Router 1 zu Router 2 manchmal unterbrochen.

Kann mir hier jemand helfen, dass ich beides gleichzeitig machen kann.

Falls ihr nicht mit meiner Beschreibung klar kommt, dann meldet euch.

Danke!

Grüße
Mitglied: masterofdisaster09
30.08.2009 um 14:13 Uhr
Wenn auf der LAN-Verbindung des PCs kein Standardgateway und keine DNS-Server konfiguriert sind, sollte dein Setup eigentlich problemlos laufen.
Bitte warten ..
Mitglied: SamvanRatt
30.08.2009 um 14:27 Uhr
Hi
Gratulation: endlich mal eine Doku beim Problem dabei
wieso trennst du die Netze auf? Sicher das dein AVM Routing wirklich macht? Die Teile sind ja für was anderes gebaut. Mit wrt würde ich sagen klar geht, da dort die Box wirkliche Routen eintragen kannst. Bei sog Dual Homing (du hast zwei gleichzeitig aktive NICs) darf nur ein Gateway/DNS existieren, da sonst dein OS die Daten (gerade Thema surfen) ans falsche Netz sendet. Routing arbeitet nach einem sehr simplen Mechanismus wie es das passende Ausgangsgateway ermittelt. Wir hatten hier erst vor kurzem so einen Fall bei dem zwei Netze parallel gefahren wurden. Die Routingtabelle in einem deiner "geht nicht" Rechnern kannst du ermitteln via "route print" dann siehst du wie ein Paket normal gehandhabt wird. Wenn das falsche Netz zuerst kommt wird auch alles dorthin gesandt egal ob Ausgang oder Falsch. Wichtig ist auch das dein Gateway alle internen Netze kennen muß; wie gesagt ist Routing eine stinke Dumme Sache und damit verdienen sich (mit den Fehlern die dort gemacht werden) einen Haufen Geld, da dort viele Kleinigkeiten (primärnetz, Gatway, Routing, Netzmasken, ...) zu kleinen Fehlern führen die schwer trackbar sind. Gibt es einen Grund für das Routing? wernn du bei der DBOX neutrino drauf hast, einfach alle IPs umstellen auf eine Range+Netzmaske fertig. Bei deinem PC1 muß dann nur IP forwarding drinnen sein wenn die DBOX Daten vom Internet braucht.
Gruß
Sam


EDIT: ich gehe davon aus das die DBOX ins INet sehen soll (sonst versteh ich deinen Aufbau nicht), ansonsten nimm das sog KISS Prinzip:
a) alle haben die selbe IP Range, z.b. 192.168.1.x/255.255.255.0/GW: Deine ISP Box
b) Nimm nur einen ISP Router, gib dem AVM eine IP, der verteilt die Daten dann auch ans WLAN (obwohl die AVM wie alle anderen auch alle drei Netze getrennt sehen, also WAN/WLAN/LAN, sind WLAN/LAN häufig nicht logisch getrennt, sprich was auf LAN broadcastet geht auch ans WLAN weiter, damit kann bereits jeder der am LAN dranhängt auch mit den über WLAN angesprochenen reden.
c)deinen PC1 nimmst du als LAN1: 192.168.1.x/255.255.255.0/GW: Deine ISP Box; und als LAN2: 192.168.2.1/255.255.255.0/GW: NICHTS!; deine DBOX dann 192.168.2.2/255.255.255.0/GW: keines[wenn doch eines sein muß (entwickle seit 2002 nur noch Boxen auf VDR Basis): nimm das vom PC1: 192.168.1.1]; solltest du softCAM nutzen dann muß halt IPforwarding ran (heißt bei MS nun SharedAccess), ist aber in der Konstellation dann einfach zuschaltbar.
d) DNS sollte dann immer die ISP Box sein oder halt ein dir zugewiesener DNS, ansonsten spricht an den meisten stellen nichts gegen DHCP
so läuft alles online und bis auf die DBOX darf jeder mit jedem reden.
Bitte warten ..
Mitglied: mrtux
30.08.2009 um 16:08 Uhr
Hi !

Du könntest es ja auch noch komplizierter aufbauen. Ich hab hier noch ein paar alte Router, kannst Du gerne haben und auch noch draufhängen.

Ich würde die DBox nicht über das WLAN versorgen, verbinde die direkt per LAN oder kauf Dir ein paar Powerline-Adapter und gut ist. Wenn dir die deutschen Markengeräte zu teuer sind, es gibt sie mittlerweile auch schon günstiger von anderen Herstellern oder auch als Noname.

mrtux
Bitte warten ..
Mitglied: starfox2000
30.08.2009 um 16:44 Uhr
Hallo Sam,

also dein Text musste ich dreimal durchlesen, bis ich diesen so einigermaßen verstanden habe.
Ich bin kein Netzwerkexperte, hab mir das selbst angeeignet.

Es gibt keinen Grund für das Routing, dachte nur das ich getrennte Ranges brauche, damit das funktioniert.
Ja, ich hab da Neutrino drauf.

Kannst Du mir das mal genauer erklären?

Hier meine Einstellungen der Geräte:

D-Box

IP-Adr.: 192.168.5.10
Netzmaske: 255.255.255.0
Broadcast: 192.168.5.1
Standard Gateway: 192.168.5.1
Nameserver: 192.168.5.1

PC Netzwerkkarte für D-Box (LAN)

IP-Adresse: 192.168.5.11
Subnetzmaske: 255.255.255.0
Standardgateway: 192.168.5.1
DNS-Server: 192.168.5.1
WINS-Server:

PC Netzwerkkarte für Router 2 (WLAN)

IP-Adresse: 192.168.178.24
Subnetzmaske: 255.255.255.0
Standardgateway: 192.168.178.1
DHCP-Server: 192.168.178.1
DNS-Server: 192.168.178.1
WINS-Server:

Soll ich also bei der D-Box wie PC (LAN-Karte) auf die IP Range 192.168.178.xxx wechseln?
Und wo stelle ich das IP-Forwarding ein?
Bitte warten ..
Mitglied: starfox2000
30.08.2009 um 16:47 Uhr
@mrtux

die DBox wird doch gar nicht über WLAN versorgt, oder wie meinst du das?

DBox mit LAN an PC1 und dann mit PC1 an WLAN-Router.

Gruß
Star
Bitte warten ..
Mitglied: SamvanRatt
30.08.2009 um 22:01 Uhr
Hi
mrtux meint damit das du PC1 als Bridge nutzt um die DBOX nicht direkt ans LAN zu hängen; nicht das eine solche Konstellation nicht sinnvoll/notwendig sein kann, aber nicht bei einem vier Geräte Park. Selbst bei 100 würde ich mir das grob überlegen; bei WAN Geschichten ist sowas notwendig, aber die große Wumme brauchen wir dafür sicher nicht rausholen.
Routing ist ein Minenfeld; gerade wenn man da nicht Erfahrung sammeln will (ich habe meinen ersten Cisco Schein auf IOS11.2 gemacht und dafür drei Router benutzt um Tod-Teufel dumme Sachen damit anzustellen; vor allem das Split Horizon dauerte einige Zeiten das kein Router Tod oder Vollläuft und Reverse Poisoning auch richtig funktioniert; in 95% aller Fälle mußte ich mich via Console wieder freirouten so klein können die Fehler sein) sondern einfach nur eine Konstellation zum laufen bringen will.
Gruß
Sam
Bitte warten ..
Mitglied: aqui
31.08.2009, aktualisiert 18.10.2012
Dein Problempunkt ist der PC 1, denn der muss zwangsweise routen.
Jetzt stellt sich hier die Frage ob du am PC 1 NAT/ICS machst oder einfach ein sauberes transparentes Routing.

Wenn du NAT/ICS dort machst kannst du niemals das IP Netz 192.168.178.0 /24 verwenden, denn Microsoft erzwingt hier das IP Netz 192.168.0.0 /24.

Lies dir dieses Tutorial genau durch:

http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Dort wird ganz genau erklärt wie beide Szenarien funktionieren und wo Vor- und Nachteile sind.
Damit sollte eine Inbetriebnahme dann kinderleicht sein und natürlich Internet UND D-Box problemlos funktionieren !!
Bitte warten ..
Mitglied: starfox2000
31.08.2009 um 20:34 Uhr
Hallo,

also ich habe es endlich geschafft.
Vielen Dank schon mal für eure Hilfe.

Hier noch zum Verlauf, wie oder welche Änderungen ich gemacht habe.

Ich habe in der Registry einen Wert geändert, damit Windows XP auch als Router fungiert.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
Dort den Wert "IPEnableRouter" auf 1 gesetzt.
PC neu gestartet.

Netzwerkarte 1 (LAN) hat

IP-Adresse: 192.168.5.1
Subnetzmaske: 255.255.255.0
Standardgateway:
DNS-Server:
WINS-Server:

diese Einstellungen bekommen.

D-Box folgend geändert:

IP-Adresse: 192.168.5.10
Subnetzmaske: 255.255.255.0
Broadcast: 192.168.5.255
Standardgateway: 192.168.5.1
Nameserver: 192.168.5.1

Netzwerkkarte 2 (WLAN)

IP-Adresse: 192.168.178.24
Subnetzmaske: 255.255.255.0
Standardgateway: 192.168.178.1
DHCP-Server: 192.168.178.1
DNS-Server: 192.168.178.1
WINS-Server:

So in dieser Konstellation funktioniert beides.
An den zwei Router habe ich nichts geändert.

Das einzige was jetzt noch nicht geht ist, dass die D-Box keine Daten aus dem Internet bekommt.
Das ist aber nicht weiter schlimm, da ich das eh noch nicht genutzt habe und glaube auch net genau weiß für was ich dies brauchen sollte.

Aber falls einer auf die Schnelle weiß warum das nicht geht, kann mir das auch gerne schreiben.

Also noch mal Danke für die kompetente Hilfe.

Schönen Abend noch und

Grüße

Star

Edit 31.08.2009 22:17 Uhr

Hab es mit der D-Box doch hin bekommen.

Ich habe die Netzwerkarte 2 (WLAN) für "Anderen Benutzern im Netzwerk gestatten, die Internetverbindung dieses Computers zu verwenden" das Internetsharing angehakt.

Änderung bei der D-Box

IP-Adresse: 192.168.0.10
Subnetzmaske: 255.255.255.0
Broadcast: 192.168.0.255
Standardgateway: 192.168.0.1
Nameserver: 192.168.0.1

So jetzt kann die D-Box auch ins Internet schauen.

Grüße
Star
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Rasperry als LAN UND WLAN Router
gelöst Frage von 117455Router & Routing12 Kommentare

Hallo, Ich möchte gerne meinen RPi (Rasbian) als LAN und WLan Router nutzen. Das heißt folgender Aufbau momentan: LAN ...

Multimedia & Zubehör
Router, Receiver, Switch, DECT in einem?
Frage von DediggefeddeMultimedia & Zubehör12 Kommentare

Hallo Zusammen! Ich bin vor kurzem zu Unitymedia gewechselt und habe nun erstmal ein KabelChaos angerichtet. Ich nutze: Internet ...

Windows 10
Xbox360 Wireless Receiver geht nicht mehr
Frage von uridium69Windows 103 Kommentare

Gestern habe ich Windows 10 aktualisiert (Das grosse Update), seither geht der Xbox360 Wireless Receiver nicht mehr, kann auch ...

LAN, WAN, Wireless
Router mit 5xGBit-LAN ohne WLAN-Funktion
gelöst Frage von rabo63LAN, WAN, Wireless14 Kommentare

Liebe Leute Ich suche einen Router ohne WLAN-Funktionalität, der mit fünf Gigabit-LAN-Anschlüssen ausgestattet ist und der einfach zu konfigurieren ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 18 StundenMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 20 StundenDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 21 StundenSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke21 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS14 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Server-Hardware
Veeam Backup Server stürzt alle paar Tage ab
Frage von Leo-leServer-Hardware12 Kommentare

Hallo Forum, ich habe momentan folgendes Problem. Veeam Backup and Replication 9.5 u2 auf voll gepatchten DL 380 G7 ...