Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wmi Abfrage für den Prozessor

Frage Entwicklung Batch & Shell

Mitglied: HerrTaler

HerrTaler (Level 1) - Jetzt verbinden

15.06.2012 um 09:48 Uhr, 4586 Aufrufe, 2 Kommentare

Hallo zusammen,

ich versuche gerade in einer Powershell Abfrage die Prozssoren auszulesen (über wmi).

$ergebnis = get-wmiobject Win32_Processor -computername xyz
Write-Host $ergebnis.Name

Bei der Abfrage bekomme ich aber scheinbar nur ein Ergebnis, wenn nur ein Prozssor vorhanden ist. Wie lese ich das aus wenn mehrere Prozssoren vorhanden sind?

Danke für eure Hilfe.
Mitglied: MCITPSA
15.06.2012 um 10:42 Uhr
Du könntest das ganze Dir so in etwa ausgeben lassen.
01.
$property = "systemname","maxclockspeed","addressWidth", 
02.
            "numberOfCores", "NumberOfLogicalProcessors" 
03.
 
04.
 
05.
Get-WmiObject -class win32_processor -Property  $property | 
06.
   Select-Object -Property $property
Die ausgabe sieht dan in etwa so aus.
01.
systemname                : COMPUTERNAME 
02.
maxclockspeed             : 3301 
03.
addressWidth              : 64 
04.
numberOfCores             : 4 
05.
NumberOfLogicalProcessors : 4
Bitte warten ..
Mitglied: HerrTaler
15.06.2012 um 12:36 Uhr
Danke für diese Lösung.... so sieht das bei mir aus:

Get-WmiObject -class win32_processor -property Name -computer server01| select-Object -Property Name
Bitte warten ..
Ähnliche Inhalte
Windows Server
LDAP Abfrage einrichten (4)

Frage von hscheip zum Thema Windows Server ...

Datenbanken
ORACLE DB Abfrage (5)

Frage von Marabunta zum Thema Datenbanken ...

Batch & Shell
gelöst Powershell - WMI Return Codes unterdrücken, WIE? (3)

Frage von instinctless zum Thema Batch & Shell ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
gelöst NTFS und die Defragmentierung (29)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

Server-Hardware
Treiber für Server gesucht (15)

Frage von MeisterFuchs zum Thema Server-Hardware ...