Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WMI Filter funktioniert nicht

Frage Microsoft Windows Server

Mitglied: Phraccy

Phraccy (Level 1) - Jetzt verbinden

14.04.2014 um 10:30 Uhr, 1465 Aufrufe, 2 Kommentare

Guten Morgen,

ich hätte da gerne mal ein Problem ;)

Bei uns in der Firma hat sich im Zuge erster Tests zur Windows 7 Umstellung folgendes Problem eröfnet. Ein kurze Erläuterung der Umstände, damit jeder ein klareres Bild hat und so hoffentlich besser helfen kann.

Unsere komplette Umgebung basiert auf Thin Clients und VM's auf denen derzeit noch Windows XP läuft. In einer Testumgebung (ebenfalls VM's) testen wir derzeit die Umstellung auf Windows 7 mitsamt neuen GPO's etc.

Nun das eigentliche Thema: Die Policies die wir für Windows 7 erstellt haben möchten wir per WMI Filter den VM's zuteilen, so dass Maschinen mit Windows XP diese eben nicht bekommen. Die Abfrage hierfür ist wie folgt:
select * from Win32_OperatingSystem where Version like “6.1%” and ProductType = “1″

Leider funktioniert der Filter auf den XP "Kisten" nicht so lange ein User angmeldet ist, unter Adminkontext läufts. Es ist also entweder eine Berechtigungssache oder eine Policyeinstellung die das Funktionieren des Filters verhindert.
Dazu noch einige Informationen: Abfrage wmic für das OS im Userkontext funktioniert, ebenso die gleiche Abfrage vom Server aus auf eine XP Maschine mit angemeldetem User.

Kann mir jemand einen Tipp geben was ich überprüfen könnte? Gibt es eine Berechtigung auf bestimmte Ordner die dem User nicht zur Verfügung stehen (ich habe in anderen Foren was von localserver\apps gelesen, kann damit jedoch nichts anfangen....was sind das für Ordner?)? Oder sind es bestimmte Policy Einstellungen die das greifen des Filter verhindern?

Vielen Dank vorab!

Phraccy
Mitglied: mayho33
14.04.2014 um 16:20 Uhr
Hi!
Eigentlich hast du auch als Standard-User lesende Rechte auf die WMI. Es sollte auch egal sein ob ein user angemeldet ist oder nicht.
Das einzige was ich mir vorstellen kann ist ein Fehler in der Syntax bei der Abfrage:

Meine Abfrage: select * from Win32_OperatingSystem where Version like '6.1%' and ProductType = '1' (Zieht)
Deine Abfrage: select * from Win32_OperatingSystem where Version like “6.1%” and ProductType = “1″ (SyntaxFehler, flascher Verb)

Eventuell lieg's an den Anführungszeichen?? Nimm einfache.

lg
Bitte warten ..
Mitglied: Phraccy
15.04.2014 um 08:04 Uhr
Hi Mayho33,

Danke Dir, aber ich befürchte daran liegt es nicht, denn wenn ein Adminuser sich auf einer XP Kiste anmeldet greift der WMI Filter ja. Nur bei einem User nicht Trotzdem Danke!
Bitte warten ..
Ähnliche Inhalte
Windows Server
WMI-Filter funktioniert nicht richtig
gelöst Frage von elPadrino1010Windows Server2 Kommentare

Guten morgen liebe Experten, ich habe folgendes Problem. Ich habe einen Windows SBS Server 2008 als DC im Einsatz. ...

Windows Server
WMI-Filter kombinieren
gelöst Frage von Winfried-HHWindows Server1 Kommentar

Hallo Experten! Wenn ich einen WMI-Filter wie auf der folgenden Abbildung erstelle, ist das dann eine UND-Verknüpfung der beiden ...

Windows Netzwerk
WMI Filter mit Oder Bedingung
Frage von ChrisDynamiteWindows Netzwerk2 Kommentare

Guten Tag, kann mir jemand sagen, wie ich (siehe Bild) erreiche, dass ein WMI Filter aus mehreren Bedingungen besteht? ...

Windows Server
WMI Filter für Standortabhängige GPO
Frage von PhelanKellWindows Server2 Kommentare

Hallo, ich suche einen WMI Filter mit dem ich den Standort eines RDS-Users abfragen kann. Alle Filter die ich ...

Neue Wissensbeiträge
Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 8 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 10 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...