Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WMI Filter für Office 2010 Gruppenrichtlinie

Frage Microsoft Microsoft Office

Mitglied: caschopl

caschopl (Level 1) - Jetzt verbinden

13.07.2012, aktualisiert 16:11 Uhr, 5377 Aufrufe, 5 Kommentare

Hallo,
Unsere WS haben Office 2003 installiert, jetzt lasse ich per GPO Office 2010 installieren. Dazu wird eine Batch ausgeführt die die Setup.exe von Office 2010 startet. Die Installation funktioniert soweit ganz gut. Allerdings wenn ich den PC wieder starte kommt wieder die Installationsroutine.

Jetzt habe ich versucht den WMI Filter zusetzen, allerdings ohne Erfolg:

ich habe es mit folgenden Einträgen versucht:

SELECT path,filename,extension,version FROM CIM_DataFile WHERE (path='\\Program Files\\Microsoft Office\\Office14\\' OR path='\\Program Files (x86)\\Microsoft Office\\Office14\\' OR path='\\Programme\\Microsoft Office\\Office14\\' OR path='\\Programme (x86)\\Microsoft Office\\Office14\\') AND filename='winword' AND extension='exe' AND version > '14.0'

oder

SELECT * FROM Win32_Product WHERE NOT Name = 'Microsoft Office Professional Plus 2010'

oder

Select * From Win32_Product WHERE Caption != 'Microsoft Office Professional Plus 2010'

Aber irgendwie funktioniert das nicht......

Im Einsatz sind Windows 2008 R2 und Win7 / XP-Clients.

Danke schon mal für Eure Tipps.

Carsten
Mitglied: Onitnarat
13.07.2012 um 16:09 Uhr
Hi, kennst Du das Tool schon: http://www.gpoguy.com/tabid/67/agentType/View/PropertyID/93/Default.asp ...

Deine "Folter" sehen auf den schnellen Blick ja ganz gut aus...
Bitte warten ..
Mitglied: 76109
13.07.2012, aktualisiert um 16:28 Uhr
Hallo Carsten!

Versuchs mal in dieser Art:
"SELECT * FROM Win32_Product WHERE Name Like 'Microsoft Office...%'"

Gruß Dieter
Bitte warten ..
Mitglied: caschopl
13.07.2012 um 16:46 Uhr
Ja, kenne das Tool zum Überprüfen und ich bekomme auch ein "TRUE". Aber das ist auch nicht das Problem. Mein Problem ist, dass die GPO ausgeführt wird. Wenn die Ordner vorhanden sind. Aber es soll ja nur ausgeführt werden, wenn die Ordner (Office 2010) nicht vorhanden ist.

Gruß
Carsten
Bitte warten ..
Mitglied: Onitnarat
13.07.2012 um 16:53 Uhr
Liegts am Freitag, aber es ist doch klar, dass die GPO ausgeführt wird, wenn der WMI-Filter "True" ist. Du musst den Filter so setzen, dass er "False" ist. Oder bin ich jetzt gedanklich schon im Wochenende?
Bitte warten ..
Mitglied: caschopl
13.07.2012 um 17:01 Uhr
Richtig, aber mit

WHERE NOT
oder !=
oder <>

gehts irgendwie nicht......
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst WMI-Filter Syntax (10)

Frage von DasWombat1993 zum Thema Windows Server ...

Datenbanken
gelöst Access 2010 Filter zurücksetzen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Microsoft Office
Gruppenrichtlinien Office 2016 werden nicht verteilt (2)

Frage von sammy65 zum Thema Microsoft Office ...

Neue Wissensbeiträge
Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(3)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
MSA 2050 RAID Konfig (27)

Frage von Leo-le zum Thema SAN, NAS, DAS ...

Microsoft Office
Office Druck fehler (12)

Frage von DaistwasimBusch zum Thema Microsoft Office ...

Festplatten, SSD, Raid
Uninitialisierte Festplatte - Daten retten (11)

Frage von peterla zum Thema Festplatten, SSD, Raid ...

Netzwerkmanagement
Windows Server 2008 R2: "netsh reset" nicht verfügbar? (11)

Frage von RickTucker zum Thema Netzwerkmanagement ...