Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wmic abfrage soll autoit den wert übergeben

Frage Entwicklung Batch & Shell

Mitglied: ChrisDynamite

ChrisDynamite (Level 2) - Jetzt verbinden

17.01.2014 um 15:36 Uhr, 3112 Aufrufe, 1 Kommentar

hallo!

nach gefühlt 3 stunden google bin ich leider keinen schritt weiter. wie erreiche ich es, dass ich in autoit einen wmic aufrufe und genau den text, welcher ich sonst in der eingabeaufforderung erhalten würde als variable in autoit abspeichern kann?

ich bekomme immer nur blödsinnige meldungen. das scheint mir mehr wie errorcodes als was vernünftiges zu sein.

danke für die hilfe
Mitglied: colinardo
17.01.2014, aktualisiert um 15:58 Uhr
Hello again Chris,
nach gefühlt 3 stunden google
deine Zeit möchte ich haben

Guckst du hier wie man WMI-Abfragen mit AutoIT macht:
01.
$sWMIService = "winmgmts:\\.\root\CIMV2" 
02.
$objWMIService = ObjGet($sWMIService) 
03.
If IsObj($objWMIService) Then 
04.
    $colItems = $objWMIService.ExecQuery("SELECT * FROM Win32_Computersystem") 
05.
    If IsObj($colItems) Then 
06.
        For $oItem In $colItems 
07.
            $rechnername = $oItem.Caption 
08.
	    msgbox(0,"",$rechnername) 
09.
        Next 
10.
    Else 
11.
        MsgBox(16, "Error", "Failed to get collection.") 
12.
    EndIf 
13.
Else 
14.
    MsgBox(4096, "ERROR", "Failed to connect to WMI at: " & $sWMIService) 
15.
EndIf
Als Beispiel wird hier der Rechnername aus der WMI-Klasse Win32_ComputerSystem ausgegeben, ist zwar Blödsinn weil AutoIT ja das Makro @ComputerName bereitstellt, aber es soll ja nur die Methode verdeutlichen..

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Windows Server
GPO - UAC: "Als Administrator ausführen" soll Abfrage bringen (4)

Frage von MissJones zum Thema Windows Server ...

Batch & Shell
gelöst Abfrage ERRORLEVEL springt aus der FOR Schleife (8)

Frage von Galindiesel zum Thema Batch & Shell ...

Datenbanken
gelöst MySQL Abfrage für demographische Zwecke (3)

Frage von morphil zum Thema Datenbanken ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (51)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...