Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wndows 2003, iis und Citrix PS 4.5 Webinterface Login geht nicht

Frage Netzwerke

Mitglied: 70866

70866 (Level 1)

16.06.2010, aktualisiert 01:34 Uhr, 6150 Aufrufe, 2 Kommentare

hab einen Testserver installiert, Windows 2003, iis, Citrix ps 4.5
Im Lan geht alles prima, im Internet nicht

Ich hab also über dyndns meine IP reserviert, einen W2k3 samt Citrix auf einem ESX 3.5 installiert. Alles was in dem esx an vms drin ist, funktioniert -anmelden, Applikationen in der Farm starten u.s.w.

Auf dem Client ist ein Citrix Client in der Version 11 drauf.

Als Portweiterleitungen an meinem router zuhause hab ich 80 (www), 443 (ssl), 1494 (Citrix ICA) und 3389 Remotedeskotop installiert.

Meine schöne Infrastruktur kann ich nun mittels einem UMTS-USB-Stick schön von remote anschauen, allerdings hört nach dem RDP der Spaß auf.

Auf das Webinterface von Citrix komm ich von meinem Lan aus drauf, übers Internet auch.
Der Remotedesktop geht einwandfrei, samt Zugriff auf Clientlaufwerke.

Was aber nicht geht, ist die Anmeldung am Citrix (die geht nur wenn der Zugriff aus dem LAN kommt)- es kommt immer wieder die Meldung Benutzername oder Kennwort falsch, oder Probleme mit der Authentifizierung. Ich vermute mal letzteres, aber was und wo?

Am Webserver wirds wohl nicht liegen, da hatte ich mal "integrated windows authentification" aktiviert und den Gast-Account deaktiviert, das zauberte aber lediglich einen weiteren Loginprompt auf den Bildschirm. Hier hat aber domäne\username und das Kennwort noch funktioniert, danach sah ich das Loginfenster vom webinterface.

Ich hab dann die integrierte Authentifizierung wieder abgestellt,und den gastaccount wieder aktiviert der im IIS eingetragen ist. Trotzdem: kein citrix login.

Was tun? Ich weiß, das kann eigentlich nur ne Kleinigkeit sein....

update:
ich hatte im IIS den dyndns Hostnamen eingetragen. Ich hab ihn gelöscht.
Auf dem Client hab ich die aktuelle WAN IP eingetragen mit dem Hostenamen den der Citrix-Server eigentlich im Lan hat.

Danach ging zumindestens das Login übers Webinterface, und ich sah meine Applikation.
Beim Versuch diese zu starten, kam die meldung "cannot connect to the Citrix xenapp server. There is no Citrix xenapp server configured on the specified address".

Wie gesagt, das webinterface im LAN startet das Programm das ich da freigegeben hab. I
Mitglied: 70866
25.06.2010 um 13:23 Uhr
ok, nun die Lösung, wird heut abend ausprobiert:

Citrix bietet ne Software an, die ist ab PS 4.5 standardmäßig im Lieferumfang und heit secure access gateway. Das Webinterface vom Citrix 4.5 liefert irgendwelche hardcodierte Links aus die der Client dann irgendwie nicht auflösen kann wenn man nicht im LAN ist. Der Access Gateway soll das entsprechend umbiegen und ist über Port 443 (SSL) erreichbar.
Bitte warten ..
Mitglied: citrixler
02.02.2011 um 16:16 Uhr
haettest Du da nicht einfach den Port am IIS auf 443 aendern muessen?
Mit welchen zertifikaten hast Du gearbeitet?

bissl spaet ... aber vorhin mal durchgeschaut...


greets,
citrixler
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Netzwerk
IIS - anderes Netz zulassen (3)

Frage von survial555 zum Thema Windows Netzwerk ...

Exchange Server
gelöst Kontaktliste in Userpostfach importieren via PS (17)

Frage von atk691 zum Thema Exchange Server ...

Microsoft Office
gelöst Visio 2003 auf aktuellem System (6)

Frage von ratzla zum Thema Microsoft Office ...

Windows Server
gelöst Gruppenrichtlinien-Vorlage Office 2013 auf einem DC 2003 (5)

Frage von bluepython zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...