Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WoL via dyndns?

Frage Netzwerke LAN, WAN, Wireless

Mitglied: patrickrie

patrickrie (Level 1) - Jetzt verbinden

25.06.2013 um 09:50 Uhr, 4589 Aufrufe, 13 Kommentare

Hallo liebes Forum,

das hier ist mein erster Beitrag. Bin noch ein ziemlicher Newbie in Sachen Netzwerktechnik, es interessiert mich jedoch sehr und möchte mich auch deshalb fortbilden.

Da ich mit Hilfe eueres Forum auch meinen Client Router konfiguriert habe, stellt sich nun die Frage, ob WoL prinzipiell möglich ist.

Also mein privates Netzwerk zu Hause sieht wie folgt aus:

Über den Router Thomson TG585 v7 (ein Router mit abgespeckter Firmware der österreichischen Telekom/A1) erreiche ich das WAN.
Der Wireless Router hat den Standardgateway 10.0.0.138/24, Subnet 255.255.255.0
Die Telekom vergibt übrigens öffentlich IP der A-Klasse.

Der Wireless-Router Thomson TG585 v7 steht im Erdgeschoss, DHCP ist an im Pool 10.0.0.100 - 10.0.0.254.
Im ersten Stock unseres Hauses steht ein TP-Link TL-WR1043ND Router. Verwendet wird dieser im Client Mode mit einer dd-wrt Firmware.
Ich habe diesem eine statische IP außerhalb des DHCP Pools des Thomson Routers vergeben, nämlich die 10.0.0.1. Subnet ist ebenfalls 255.255.255.0, Gateway und DNS 10.0.0.138, also der Thomson Router.
Verbindung beider Router mit Wifi.
Am TP-Link Router habe ich mittels Ethernet Kabel am LAN-Port1 meinen PC angesteckt. Netzwerkadapter des PCs ist eine Intel PRO 1000GT.

Dem TP-Link habe ich also WAN-mäßig (da er als Client arbeitet) die 10.0.0.1 IP vergeben und LAN-mäßig 192.168.1.1, Subnet 255.255.255.0, Gateway die "WAN-IP" des TP-Link-Routers 10.0.0.1 und DNS vom Thomson 10.0.0.138. Beim TP-Link habe ich DHCP deaktiviert.
Meinem Netzwerkadapter habe ich die statische IP 192.168.1.10, Subnet 255.255.255.0, Gateway 192.168.1.1, DNS 10.0.0.138 gegeben.

Falls eventuell wissenswert:
Advanced Routing beim TP-Link in der dd-wrt Firmware ist "Gateway", nicht "Router"

Die Internetverbindung Thomson TG585 v7 <--WIRELESS--> TP-Link TL-WR1043ND <--Ethernetkabel--> Intel PRO 1000GT/mein PC funktioniert.

Nun stellt sich die Frage, ob es über das WAN möglich ist meinen PC hochzufahren, wenn ich in einem anderen Netzwerk arbeite (beispielsweise vom Arbeitsplatz aus). Ist es möglich, dass ich Magic Pakets an den Thomson sende, dieser mittels UDP-Portforwarding (Port 9) an die MAC-Adresse des TP-Link sendet, dieser ebenfalls mittels UDP-Portforwarding (Port 9) an die MAC-Adresse meines Netzwerkadapters sendet und ihn dann einschaltet. In den BIOS Einstellung meines PC scheint dies möglich zu sein ("Power on PCI/PCIE Devices = ENABLED"), auch die Magic Pakets können im Gerätemanager/Netzwerkadapter aktiviert werden.

Um die öffentliche IP des Thomson zu ermitteln habe ich dyndns aktiviert und am Thomson auch die erforderlichen Einstellungen angewendet, sprich mein dyndns.org-Account erhält die IP vom Thomson. So wie ich WoL über "das Internet" verstehe, kann ich z.B. "patfor.dyndns.org" als Hostnamen angeben, dieser wird in meine öffentliche IP aufgelöst und dann meinem Thomson Router zugeordnet...ist das so?

Ich muss ehrlich zugeben, dass dies für mich ziemlich komplex ist und ich hoffe, dass ich als Neuling euch genug Informationen gegeben habe und ihr hoffenltich nicht nur den Kopf schütteln müsst. Falls etwas zu ungenau beschrieben, bitte um Info

Schöne Grüße
Patrick
Mitglied: killtec
25.06.2013 um 10:01 Uhr
Hi,
WoL geht nicht über WLAN und auch nicht über das Internet.
Du müsstest das MagicPacket vom TP aus senden. Der ddwrt müsste das eigentlich haben.

Also so ohne weiteres funktioniert das nicht.

Mein Tipp: VPN Einwahl in dein Netz(hierfür brauchst du dann die dyndns), dann kannst du den vom tp-link aus starten (wenn ddwrt das unterstützt).

Das funktioniert dann auch.
Bitte warten ..
Mitglied: patrickrie
25.06.2013 um 10:53 Uhr
Hallo killtec,

danke für die Antwort!

Hm, das ist jedoch schade!

Da habe ich diesbezüglich noch eine Frage:
das Thema meiner Frage lautet ja "WoL via dyndns?", doch wie sieht dies mit Wake on Wlan aus? Im Internet liest man doch so einiges, doch schlau wird man daraus nicht wirklich...

Ist das Sendeproblem der Magic Pakets die nicht vorhandene physische Verbindung mittels Kabel oder dass der Thomson Router den TP-Link nicht findet im WLAN?
Da beide Router ständig "am Netz" hängen und niemals ausgeschaltet werden, müsste doch das Senden vom Thomson auf den TP-Link funktionieren oder verstehe ich da etwas falsch?

Schöne Grüße
Patrick
Bitte warten ..
Mitglied: killtec
25.06.2013 um 11:41 Uhr
Hi,
also ich habe die Erfahrung gemacht, dass WOL Pakete im WLAN Probleme machen. D.H. es kann einmal funktionieren, aber das nächste mal nicht. Ich musste z.b. WOL Pakete mehrfach über das WLAN senden, damit es einmal klappt. Beim gleichen Host, direkt am LAN angeklemmt, gibg es sofort. Sprich, wenn du das WOL vom ddwrt sendest geht es.

Die Verbindung vom Thomson zum TP-Link steht, das ist klar. aber wie oben geschrieben gibt es bei den WOL Paketen Probleme. (Eigene erfahrung).
Bei mir war es eine Fritzbox und ein Linksys AP.

Gruß
Bitte warten ..
Mitglied: Chrisre
25.06.2013 um 12:25 Uhr
Hallo,

klar funktioniert das siehe: http://www.et.uni-magdeburg.de/wol/

Der Router muss lediglich dementsprechend konfiguriert sein. Bei einer Fritz!Box wäre es einfacher denn die ünterstütz selbst WoL und nur der Remotezugriff muss freigegeben werden. Vllt. hat dein Router ja auch solch eine Funktion.

Grüße,
Chris
Bitte warten ..
Mitglied: killtec
25.06.2013 um 12:43 Uhr
Hi @Chrisre,
das war mir bis dato unbekannt. Prinzipiell ist es jedoch so, dass Router Broadcastgrenzen sind. Hier wird mittels speziell preparierten Ports gearbeitet, so macht es mir den Anschein.

Gruß
Bitte warten ..
Mitglied: patrickrie
25.06.2013 um 13:16 Uhr
Hallo Chrisre,

vielen Dank für die Anleitung. Ich probier mal das Senden des Pakets über diese Seite.
Grundsätzlich läuft das Senden immer über UDP Port 9, oder?
Also müsste das Weiterleiten vom Thomson auf den TP-Link mittels Portforwarding und MAC-Zuweisung und danach TP-Link auf meinen PC ebenfalls mit Portforwarding UDP 9 mit der MAC des Netzwerkadapters funktionieren?

@killtec
vielen Dank. Ich hoffe mal, dass es bei mir nicht zu solchen Problemen kommt. Ich werde die Anleitung von Chrisres Link mal testen.

Ich werde euch am Laufenden halten.

Schöne Grüße
Patrick
Bitte warten ..
Mitglied: Chrisre
25.06.2013 um 13:46 Uhr
Hi,
Richtig auf beiden das forwarding auf die nächste MAC konfigurieren dann sollte das normalerweise laufen Ports 7 oder 9 soweit ich mich erinnern kann habs schon lange nicht mehr gemacht da mein Rechner zuhause mittlerweile 24/7 in Betrieb ist. Einfach austesten ;)

Grüße,
Chris
Bitte warten ..
Mitglied: patrickrie
25.06.2013 um 14:18 Uhr
Hallo,

ich habs jetzt mal laut der Anleitung unter dem Link probiert, doch leider will das nicht ganz klappen.

Das sind die Angaben auf der Seite: http://www.et.uni-magdeburg.de/wol/
IP-Adresse oder DNS-Name des Routers: patfor.dyndns.org
Port Nummer für "Directed Broadcasting": 9
MAC-Adresse des PC's: 86:E6:G7:A7:86:23

Leider ohne erwünschtem Ergebnis. Mein Motherboard Asus P5QL Pro unterstützt ACPI 2.0a und dies wurd in den BIOS-Einstellungen dementsprechend aktiviert. Unter der Windows-Energieverwaltung habe ich "Gerät kann den Computer aus dem Standbymodus aktivieren" eingestellt und wie bereits erwähnt wurden die Magic Paket aktiviert unter der Netzwerkadapter-Konfiguration.

Vor dem Testen hatte ich beim Thomson den Port:9 mit Protokoll UDP geforwarded auf die IP des TP-Links (10.0.0.1). Von dort habe ich den Port:9 mit UDP auf die IP meines PCs (192.168.1.10) geforwarded.

Bei der dd-wrt-Firmware gibt es bekanntlich die Einstellung "WoL". Dort habe ich folgende Einstellungen:
MAC-Adresse: 86:E6:G7:A7:86:23
Hostname: Patrick-PC
Net Broadcast:10.0.0.1

Bei der Net Broadcast-Adresse bin ich mir nicht sicher...ist das die 10.0.0.138 oder 10.0.0.1 oder die 192.168.1.1???

Und beim "Pingen"/Wegsenden der MAC-Adresse http://www.et.uni-magdeburg.de/wol/ bin ich mir nicht sicher, ob ich nun die des TP-Link Routers Angeben soll oder die des Netzwerkadapters meines PCs???
Ich denke mal, dass dies die vom PC ist, jedoch findet der Thomson die MAC-Adresse in seinem LAN nicht, weil diese ja in dem 192.-Netz ist. Er findet doch nur die, die im WLAN-Netz sind...Oder wird dem mittels Portforwarding getrotzt?

Bitte um eure Hilfe.

Schöne Grüße
Patrick
Bitte warten ..
Mitglied: killtec
25.06.2013 um 14:40 Uhr
Hi,
versuch mal den PC direkt anden Thomson Router zu hängen.
Bitte warten ..
Mitglied: Chrisre
25.06.2013 um 14:40 Uhr
Hallo Patrick,

also beim Wegsenden auf der Seite musst du die MAC Addresse deines Rechners eingeben. Beim Thomson leitest du auf den TPL weiter der die Verbindng dann auf IP "192.168.1.255" weiterleiten muss. 255 ist der Platz für die Broadcasts die an alle verteilt werden und da soll das Signal ja im endeffekt hin. Die MAC Adresse von der Seite wird im Magic Paket als Adresse des Empfängers hinterlegt daher weiss der dann das er gemeint ist und macht hoffentlich die Äuglein auf ;)

Also:
Thomson: Eingehend WAN Port 9 auf 10.0.0.1 Port 9
TP-Link: Eingehend Port 9 auf 192.168.1.255 Port 7 oder 9

Grüsse,
Chris
Bitte warten ..
Mitglied: Chrisre
25.06.2013 um 14:46 Uhr
Zitat von killtec:
Hi,
versuch mal den PC direkt anden Thomson Router zu hängen.

Das wäre natürllich am besten. Würd eh auf das WLAN verzichten und durch DLAN ersetzen schnellere und stabilere Verbindung.
Bitte warten ..
Mitglied: patrickrie
28.06.2013 um 16:39 Uhr
Hallo Chrisre,

leider funktioniert es mit den oben angeführten Einstellungen auch nicht. Jetzt frage ich mich nur, woran der Fehler liegen kann.
Wenn ich nun auf der Seite den DNS-Namen, Port Nummer 9 und MAC-Adresse des Netzwerkadapters angebe funktioniert dies nicht.

Ich sehe zwar, dass am TP-Link die Lampe "WLAN" 3x kurz blinkt, was im Standby laut meinen Beobachtungen sonst nicht der Fall ist, jedoch schaltet er sich nicht ein. Da die Lampe blinkt, vermute ich mal, dass der Router etwas empfängt, jedoch nicht weiterverarbeiten kann...ist meine Vermutung wahr oder sehr weit hergeholt?

Wenn dies stimmt, müsste es doch heißen, dass das Portforwarding-/MAC-Adresse-/IP-Problem erst ab dem TP-Link auftritt, also muss in den dd-wrt-Einstellungen der Fehler liegen, nicht wahr?

Noch eine Frage:
Wenn diese Einstellungen stimmen sollten, dann vermute ich mal, dass das Problem an der Hardware liegt.
Ich habe im Geräte-Manager es mal mit dem onboard Controller Atheros AR8121 probiert. Unter den Einstellungen gibt es unter "Erweitert" viele Einstellungs-Punkte, aber nur einen, der explizit "Wake Up" beinhaltet --> "Wake Up Eigenschaften"
Kann es sein, dass der Adapter die Wake on Lan Funktion einfach nicht unterstütz oder noch windowsseitige Einstellungen berücksichtigt werden müssen?
Im BIOS ist jedenfalls alles aktiviert, was aktiviert gehört.

Schöne Grüße
Patrick
Bitte warten ..
Mitglied: Chrisre
01.07.2013 um 08:09 Uhr
Hallo,

im Windoows muss bei den Netzwerkadapter einstellungen auch das WoL und die Option dass, das Gerät den Computer aus dem Standby holen kann aktiviert sein. Aber das hilft dir nur im Standby Modus soweit ich weiss. Probier ersteinmal das Gerät direkt an den Thomson zu hängen so kan man überhaupt sicher sein das es funktioniert. Danach kann man sich dann um das übermittlungsproblem im WLAN kümmern.

Grüße
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
gelöst Zwei DSL Leitungen, Zwei Fritzboxen, Zwei Dyndns Accounts - Portweiterleitung klappt nicht (4)

Frage von caravandriver zum Thema Router & Routing ...

Internet
gelöst Strato MX eintrag DYNDNS (5)

Frage von bootloader zum Thema Internet ...

Internet Domänen
gelöst Dyndns mit Strato und DrayTek Vigor2925 (6)

Frage von itsk-robert zum Thema Internet Domänen ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...