Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WOL über Internet an NAS senden

Frage Netzwerke Netzwerkgrundlagen

Mitglied: FireEmerald

FireEmerald (Level 1) - Jetzt verbinden

13.03.2014, aktualisiert 09:05 Uhr, 11245 Aufrufe, 10 Kommentare, 3 Danke

Hallo Zusammen,

in meinem Netzwerk befindet sich ein NAS von Synology (DS414), welches über eine FRITZ!Box 7270 an das Internet angebunden ist.

Die FritzBox ist aktuell so konfiguriert, dass Port 9 UDP (WOL Port) und Port 80 TCP (WebServer) an das NAS weitergeleitet werden.

Jetzt gibt es in den Optionen der FritzBox "Diesen Computer automatisch starten, sobald aus dem Internet darauf zugegriffen wird".
Wenn ich diese Funktion aktiviere wird das NAS bei jeder Anfrage auf Port 9 ODER Port 80 gestartet - jene Ports wo halt an das NAS weitergeleitet werden.

Genau dies möchte ich aber nicht. Das NAS soll nur durch einen "autorisierten Benutzer" gestartet werden können.

Ich möchte dazu aber nicht die Fernwartung der FritzBox verwenden, da mit dem Login an der FritzBox auch alles andere geändert werden könnte.

Meine Idee war ein WOL Package über das Internet per DynDns auf Port 9 an das NAS zu senden.

Das Problem ist nur, ich habe beim recherchieren rausgefunden das die FritzBox wohl über sogenannte "ARP-Einträge" die MAC Adresse des NAS der internen IP Adressen zuordnet. Dieser ARP-Eintrag soll den Kommentaren zufolge nicht statisch sein und somit die FritzBox nach ausschalten des NAS nicht mehr wissen wohin mit dem WOL Package.

Es soll wohl je nach verwendetem DSL-Router möglich sein den Broadcast, was ja glaub ich die WOL Message ist, an :255 weiterzuleiten - da gibt's bei mir aber noch ein paar Verständnisprobleme wie und was das genau bewirken würde.

Stimmt das und gibt es eine Möglichkeit es so einzurichten wie oben beschrieben?

Gruß, FireEmerald
Mitglied: colinardo
13.03.2014, aktualisiert um 10:30 Uhr
Hallo FireEmerald,
dieser Artikel beschreibt das ganze ziemlich gut: http://www.heise.de/netze/artikel/Wake-on-WAN-221718.html
Der Trick besteht darin deinen Port 9 an die Broadcast-Adresse deines Netzes weiterzuleiten z.B. 192.168.178.255.
So erhalten alle Rechner im internen LAN das Magic Paket und nur der Rechner dessen MAC-Adresse mit der im Magic Packet übermittelten MAC übereinstimmt wacht dann auf.
Ich meine aber das die Fritte Umleitungen an die Broadcast-Adresse nicht zulässt.

Du könntest aber in der Fritzbox unter Heimnetz > Netzwerk ein neues Gerät hinzufügen und anhand der MAC Adresse dem NAS eine feste IP zuweisen. Dies sollte dann einen statischen Eintrag in der Fritte erzeugen, dann müsste die IP-Weiterleitung auch nach einem Neustart weiterhin funktionieren.

Grüße Uwe
Bitte warten ..
Mitglied: FireEmerald
13.03.2014, aktualisiert um 12:40 Uhr
Ob eine Weiterleitung an die Broadcast-Adresse (.255 - wenn dies denn die Broadcast-Adresse bei mir wäre) bei der FritzBox möglich ist, müsste man ausprobieren. Ich würde aber fast schätzen das dies unterbunden wird.

Dann bleibt eigentlich nur noch die Möglichkeit über eine statische IP - nur hier stelle ich mir halt die Frage ob sich dies wirklich auch auf den ARP-Eintrag auswirkt. Nachschauen kann man sowas ja nicht.
Bitte warten ..
Mitglied: colinardo
13.03.2014, aktualisiert um 12:51 Uhr
Zitat von FireEmerald:

Ob eine Weiterleitung an die Broadcast-Adresse (.255 - wenn dies denn die Broadcast-Adresse bei mir wäre) bei der FritzBox
möglich ist, müsste man ausprobieren. Ich würde aber fast schätzen das dies unterbunden wird.
greade gecheckt, erlaubt sie nicht ...
Dann bleibt eigentlich nur noch die Möglichkeit über eine statische IP - nur hier stelle ich mir halt die Frage ob sich dies wirklich auch auf den ARP-Eintrag auswirkt. Nachschauen kann man sowas ja nicht.
Doch kannst du, an einem an die Fritzbox angeschlossenen Telefon #96*7* eingeben um Telnet zu aktivieren. Dann mit telnet fritz.box auf die Fritzbox verbinden und Password eingeben. Dann gibst du arp -a ein und kannst dir den ARP-Cache anzeigen lassen. Geht zumindest hier mit einer 7390 ob die Busybox der 7270 arp kennt weiß ich nicht.

Siehe hierzu auch mal : http://www.ip-phone-forum.de/showthread.php?t=217502

Grüße Uwe
Bitte warten ..
Mitglied: FireEmerald
13.03.2014 um 13:02 Uhr
Geht das auch ohne Telefon mit Telnet?
Bitte warten ..
Mitglied: FireEmerald
13.03.2014 um 18:53 Uhr
Bei mir scheint sich die FritzBox an etwas zu stören. Ich kann weder ein neues Telefonbuch anlegen, noch kann ich einen Telefonbucheintrag hinzufügen.

Fehler (Telefonbuch erstellen): http://puu.sh/7tVpN/8a862f7330.png

Fehler (Eintrag erstellen):
http://puu.sh/7tVIk/5092ee4922.png
http://puu.sh/7tVJV/530c3ca70a.png

Lua Run Runtime ERROR in /usr/www/avm//fon_num/fonbook_entry.lua:999: [string "/usr/www/avm//fon_num/fonbook_entry.lua:1"]:522: attempt to concatenate field 'id' (a nil value) 
Lua stack traceback: 
	[C]: ? 
	[string "/usr/www/avm//fon_num/fonbook_entry.lua:1"]:522: in function 'number_input_html' 
	[string "/usr/www/avm//fon_num/fonbook_entry.lua:1"]:548: in function 'write_numbers' 
	[string "/usr/www/avm//fon_num/fonbook_entry.lua:999"]:1: in main chunk
Lua Run Runtime ERROR in /usr/www/avm//fon_num/fonbook_entry.lua:1004: [string "/usr/www/avm//fon_num/fonbook_entry.lua:1"]:377: attempt to concatenate field 'id' (a nil value) 
Lua stack traceback: 
	[C]: ? 
	[string "/usr/www/avm//fon_num/fonbook_entry.lua:1"]:377: in function 'write_numberplus' 
	[string "/usr/www/avm//fon_num/fonbook_entry.lua:100..."]:1: in main chunk
Bitte warten ..
Mitglied: colinardo
13.03.2014, aktualisiert um 18:59 Uhr
Firmware-Update schon gemacht ? Das ist nicht normal...
Mal ein Reset gemacht ?
Bitte warten ..
Mitglied: FireEmerald
13.03.2014 um 19:08 Uhr
Ok, ich hab gesehen das es eine neue Firmware Version gibt, jedoch unterscheidet sich diese nur um einen Zähler von der bisherigen.

Das witzige ist die Fehlermeldung wo ich bekomme wenn ich die Firmware aktualisieren möchte.
firmwarecfg: ERROR 
Error: opening page ../html/index.html
Bitte warten ..
Mitglied: colinardo
13.03.2014, aktualisiert um 19:23 Uhr
Da stimmt aber so einiges nicht mit deiner Box => werkseinstellungen setzen und alles von Hand konfigurieren (kein Backup zurückspielen) .... und Stecker ziehen, und auch mal zur Sicherheit einen anderen Browser benutzen.

Oder sie hat sich schon durch die Sicherheitslücke was eingefangen ....
Bitte warten ..
Mitglied: FireEmerald
13.03.2014, aktualisiert um 20:37 Uhr
Scheint was im Cache gehangen zu haben, nach einem Neustart der Fritzbox konnte ich ohne Probleme die neue Firmware installieren und die Telefonbucheinträge hinzufügen.

Was sagen mir jetzt die Einträge wo ich dort finde?
http://puu.sh/7u0PV/12d9d5f21d.png

Das NAS hab ich vor mindestens einer Stunde ausgeschaltet und nach dem Neustart der FritzBox auch noch nicht gestartet. So wie ich das sehe hat er zwar das NAS noch im Table, jedoch fehlen die MAC Adressen...

Habs gerade mal probiert, am NAS regt sich nichts. (http://ifatwww.et.uni-magdeburg.de/wol/)

Könnte man den ARP-Eintrag nicht über Telnet statisch setzen? Hab hier etwas in die Richtung gefunden:
# die Datei, die wohl zum Starten genutzt werden wird kopieren 
cp /etc/init.d/rc.wlan /var/tmp/ 
#  ans Ende: 10 Sec. warten, dann den Eintrag setzen 
echo '(sleep 10 ; arp -s <IP> <MAC>) &' >> /var/tmp/rc.wlan 
# die originale Datei durch die neue "ersetzen"  
mount -o bind /var/tmp/rc.wlan /etc/init.d/rc.wlan
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Datenschutz
NAS aufräumen (1)

Frage von Kizuko zum Thema Datenschutz ...

Erkennung und -Abwehr
Port 7547 SOAP Remote Code Execution Attack Against DSL Modems Internet Storm Center (5)

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...