Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

WOL Wake on Lan bei SME Server mit ethtool - ethtool erkennt Netzwerkkarte nicht.

Frage Linux Linux Netzwerk

Mitglied: raws17

raws17 (Level 1) - Jetzt verbinden

09.09.2008, aktualisiert 10.09.2008, 9276 Aufrufe, 13 Kommentare

ethtool erkennt die Onboard Netzwerkkarte des AsRock k7s41 nicht.

Hallo,

habe ein Möglichkeit gesucht meinen Server per WOL zu starten, gefunden habe ich ethtool.
Alles wunderbar, nur leider findet es meine Netzwerkkarte nicht

Ich habe folgendes System:

Board: ASRock k7s41
Lan: onBoard
B.System: SME Server auf der Basis von CentOS

habe schon viel geguckt aber immer wenn ich "ethtool eth0" eingebe kommt eine Fehlermeldung: No datas found

Kann ich ethtool irgendwo updaten oder suchen lassen das er nochmal versucht die Netzwerkkarte zu erkennen?


Hoff jemand kann mir helfen,

Gruß raws17
Mitglied: schleusenBRATZE
09.09.2008 um 18:56 Uhr
ist denn im bios die WOL funktion aktiviert und mit welchem tool probierst du denn den server zu starten ?
Bitte warten ..
Mitglied: raws17
09.09.2008 um 19:09 Uhr
Hallo, ja ist aktiviert(lief auch vorher mit einem Windows System auf dem Rechner) habe es mit folgender Homepage probiert:
http://stephan.mestrona.net/wol/

Und dem WinXP Tool: Wake on Lan von www.pc-adviser.de

Beides geht nicht. MAC Adresse stimmt daran liegt es nicht, es liegt an Linux, vorher lief es ja


gruß
Bitte warten ..
Mitglied: schleusenBRATZE
09.09.2008 um 19:22 Uhr
hast du mal probiert mit einer anderen distribution zu starten und das tool auszuführen ?
wird das tool als root ausgeführt ?
Bitte warten ..
Mitglied: raws17
09.09.2008 um 20:14 Uhr
andere distribution geht leider nicht, da der pc kein cd laufwek hat.
Ja es wird unter root ausgeführt.
Bitte warten ..
Mitglied: schleusenBRATZE
10.09.2008 um 18:09 Uhr
und die netzwerkkarte ist im system auch richtig konfiguriert und kannst sonst bis auf das WOL tool genutzt werden..

schon sehr merkwürdig
Bitte warten ..
Mitglied: raws17
10.09.2008 um 18:17 Uhr
Alles funktioniert. Außer halt ethtool

Gibt es eine Alternative?
Bitte warten ..
Mitglied: schleusenBRATZE
10.09.2008 um 19:12 Uhr
guck mal hier http://www.vdr-wiki.de/wiki/index.php/WAKE_ON_LAN
und dann unter "Probleme"
Bitte warten ..
Mitglied: raws17
10.09.2008 um 19:40 Uhr
Danke! Das klingt schonmal vielversprechend, der PCläd grad ein Linux Image 12GB ich muss erstmal warten bis er fertig ist.

Melde mich bei Erfolg/Misserfolg
Bitte warten ..
Mitglied: raws17
10.09.2008 um 20:37 Uhr
So!
Ist getestet, habe wie erklärt "Lan" und "PCI0" auf "enable" gestellt,Befehl:
echo -n PCI0 > /proc/acpi/wakeup

ethtool konnte ich nicht zum laufen bringen, habs dann mal so probiert, aber er fährt nicht hoch.(was sehr ärgerlich ist, weil er im Keller steht und ich im 2. Stock sitze )

Gruß
Bitte warten ..
Mitglied: schleusenBRATZE
10.09.2008 um 21:09 Uhr
hier sind noch ein paar tools, aber ausprobiert habe ich diese nicht ;)
http://gsd.di.uminho.pt/jpo/software/wakeonlan/mini-howto/wol-mini-howt ...

https://sourceforge.net/projects/wake-on-lan/

wozu das 12 GB System ? zum testen mit einem anderen linux würde doch eine live cd reichen - z.B. GRML1.1
Bitte warten ..
Mitglied: raws17
10.09.2008 um 21:26 Uhr
Ist für nen Freund ;)

Die Tools sind alle um ein Wake on Lan zu schicken, nicht um es auf dem PC zu aktivieren.

Trotzdem Danke.
Bitte warten ..
Mitglied: schleusenBRATZE
10.09.2008 um 23:24 Uhr
welche version von ethtool benutzt du eigentlich, diese auch schon mal auf den neusten stand gebracht ?
war die die version schon bei OS dabei oder hast du es dir manuell runtergeladen ?
Bitte warten ..
Mitglied: raws17
10.09.2008 um 23:59 Uhr
Laut System benutze ich 6.1 - war schon dabei (SME-Server)

[code]
[root@smeserver ~]# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (rev 03)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
[root@smeserver ~]# mii-tool -v
eth0: negotiated 100baseTx-FD, link ok
product info: vendor 00:00:20, model 32 rev 1
basic mode: autonegotiation enabled
basic status: autonegotiation complete, link ok
capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
advertising: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
[root@smeserver ~]# ethtool -i eth0
driver: sis900
version: v1.08.07 11/02/2003
firmware-version:
bus-info: 0000:00:04.0
[/code]
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
gelöst Wake-on-LAN - benutzergesteuert (4)

Frage von donnyS73lb zum Thema Netzwerkmanagement ...

Windows 10
gelöst Wake on LAN mit Win10x64 funktioniert nicht (16)

Frage von Rene1976 zum Thema Windows 10 ...

LAN, WAN, Wireless
gelöst WoL - Netzwerkkarte die das Aufwecken aus dem S5-Mode unterstuetzt? (8)

Frage von RUDI-TERROR zum Thema LAN, WAN, Wireless ...

SAN, NAS, DAS
gelöst Mischbetrieb HP MSA30 Storage an SME Server UND Windows Server 2012R2 (3)

Frage von schaui84 zum Thema SAN, NAS, DAS ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (20)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (13)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...