Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Word kann Seriendruck-Hauptdatei nicht verbinden

Frage Microsoft Microsoft Office

Mitglied: boulder02

boulder02 (Level 1) - Jetzt verbinden

18.03.2010 um 00:35 Uhr, 10763 Aufrufe, 13 Kommentare

Hallo,

wir haben office 2003 auf einem TerminalServer (winServer2003) laufen. Wir starten word mit bestimmten Vorlagen aus einer anderen Anwendung heraus und speichern die Datei unter individuellem Namen ab. Einige dieser Vorlagen sind als Serienbriefe angelegt, deren Steuerdatei von der Hauptanwendung generiert wird (.txt-Datei). Die Steuerdatei liegt immer an einem definierten Speicherort (L:\) und eigentlich funktioniert alles sehr gut.

Jetzt hat ein neu angelegter Benutzer folgendes Problem:
Der Benutzer kann neue Serienbriefe mit den Vorlagen anlegen, bearbeiten und speichern. Soweit, so gut.
Wenn er die Datei aber erneut öffnen will, erscheint die Meldung, dass word die Seriendruck-Hauptdatei nicht finden kann. Ich kann dann den Suchen-Dialog aufrufen, suche mir Laufwerk L: raus und sehe die Steuerdatei msword.txt. Wenn ich diese auswähle und verbinden will passiert: nichts! Ich habe wieder die Fehlermeldung vor mir, dass die Steuerdatei fehlt und kann erneut das Dialogfenster öffnen und dann geht es immer so weiter, bis ich abbreche.
Gehe ich über den Dateimanager, kann ich die Hauptdatei sehen, öffnen und bearbeiten.
Ich habe trotzdem bei den Admins nachgefragt, ob alle Berechtigungen auf Laufwerke erteilt werden. Der neue Benutzer ist in den gleichen Scripts, wie die anderen und ansonsten haben wir auch noch keine Fehlfunktionen festgestellt.

Andere Benutzer können die Dateien öffnen, auch solche, die von unserem Neuling angelegt wurden.

Hat jemand eine Idee, woran das liegen kann?


Viele Grüße
Mitglied: boulder02
22.03.2010 um 11:29 Uhr
Hi,
wie ich sehe, hat keiner eine zündende Idee.
Ich werde einfach mal anweisen, dass der Benutzer nochmal neu angelegt wird.

LG
Bitte warten ..
Mitglied: boulder02
23.03.2010 um 15:51 Uhr
Hi,

neuer Stand der Dinge: auch der neu angelegte Benutzer hat das gleiche Problem.

Ich habe jetzt nochmal ein wenig rumprobiert:
Wenn ich die Steuerdatei msword.txt auf den Desktop lege, kann ich sie verwenden. Also ist es kein Problem der Datei an sich.
Wenn ich eine andere Datei verwende (ich hatte eine xls ausprobiert), kann ich die auch verbinden. Und wenn ich die auf das eigentlich vorgesehene Netzlaufwerk L: schiebe auch! Dann ist es also auch kein genereeles Problem mit dem Laufwerk (auf das ich über den Dateimanager vollen Zugriff habe).
Scheinbar ist die Kombination .txt auf Laufwerk L: nicht gefällig. Aber wieso. Hat jemand von euch schon mal ein solches Problem gehabt oder davon gehört?
Bei den anderen Benutzern funktioniert es (ausser bei der zuletzt angelegten Kollegin, wie ich vorhin erfahren habe).
Die Benutzer sind Standorten zugewiesen und die durchlaufen jeweils identische Anmeldescripte. Die Voraussetzungen sind also eigentlich gleich. Aber warum haben die neuen dieses Problem? Und was ist das eigentlich für ein Problem?

Wer hat Ideen?

LG
Bitte warten ..
Mitglied: boulder02
24.03.2010 um 00:57 Uhr
Nochmal ich,

ich hatte heute einen admin als Kunden, den ich direkt mit meinem Problem behelligt habe. Er hat sich die System- und Umgebungsvariablen und die Berechtigungen nochmal angeschaut und ist auch der Meinung, dass es kein Rechteproblem ist.
Er meinte sich erinnern zu können, dass in irgendeiner früheren Version (wir nutzen jetzt 2003) mal was war mit der Indizierung der Dateien, mit denen word nicht zurechtkam und mit dem journaling. Kann damit jemand was anfangen? Er kennt sich mit office nicht aus, meinte aber, es gäbe wohl eine solche Funktion (ist aber nicht das Journal von outlook), aber er könne sich nicht erinnern, was das damals genau war.
Hat jemand von euch sowas schon mal gehört? Ich habe auf die Schnelle bei Goolge nix gefunden, hatte aber heute nachmittag auch noch keine Zeit dazu.
Wäre schön, wenn jemand eine Idee hat.

LG
Bitte warten ..
Mitglied: boulder02
29.03.2010 um 15:57 Uhr
Hi,
kann es sein, dass das irgendwie mit dem dem Benutzer zugewiesenen Zeichensatz zu tun hat?
Ich habe nochmals rumprobiert und eine Steuerdatei händisch erstellt. Dabei hatte ich Namen mit Umlauten in die Feldwerte eingegeben. Wenn ich dann diese Datei verknüpfe (wenn sie nicht auf Netzlaufwerk L: liegt geht das ja) dann werden mir statt der Umlaute chinesische (oder japanische?) Zeichen angezeigt. Als ich die .txt mitt dem win Editor erstellt habe, sah man (und sieht) das ö und ü. Im verknüpften Zustand nicht.
Sagt dieses Verhalten jemandem was?
Kann es sein, dass irgend ein office-patch reinfunkt? Ich hatte andere Probleme mit einem Knoverter, der nach den automatischen updates nicht mehr funkionierte. Vielleicht gibt es da was mit den Zeichen?
Unser IT-hoster hat sich noch nicht ausführlich dazu gemeldet. Nach ersten Überprüfungen ist aber abgeblich alles wie bei den funktionierenden alten Benutzern.


LG Jörg
Bitte warten ..
Mitglied: Tokocomp
12.10.2010 um 13:34 Uhr
Hoi Jörg
das Problem mit der Steudatei nicht finden habe ich genau gleich, manchmal hilft es, wenn diese als Word-Dokument erstellt ist, unter Office2010 ist das Problem jetzt aber trotzdem wieder aufgetreten. Vielleicht hast inzwischen etwas rausgefunden?
Was ich gelöst habe, ist das Problem mit den Umlauten: gemäss Microsoft kann Word bei einer Steuerdatei im txt-Format die Codepage nicht bestimmen und nimmt dann eine asiatische Codepage (wieso dann nicht einfach diejenige, welche als Windows-Stanard definiert ist, wurde nicht beantwortet...). Ich schreibe also jetzt die Steuerdatei auch als Word-Dokument, dann tritt das Problem mit den Sonderzeichen nicht mehr auf.

Gruss
Thomas
Bitte warten ..
Mitglied: boulder02
12.10.2010 um 22:27 Uhr
Hallo Thomas,
vielen Dank für deine Rückmeldung.
Das Problem hat sich bei mir noch nicht erledigt, wenngleich sich alle Betroffenen arrangiert haben und so die unmittelbare Dringlichkeit raus war. Ich werde das in den nächsten Wochen wieder neu angehen.
Das Problem bei uns wird sein, dass die Anwendung, aus der heraus wir die Funktion brauchen nur txt erstellt. Aber ich kann mal beim support nachfragen; vielleicht kriegen die es ja doch irgendwie hin.
Wie hattest Du das Problem denn vor office 2010 gelöst? Immer als doc gespeichert? Wir nutzen noch (und wahrscheinlich noch eine ganze Weile) office 2003.
Ich halte dich über das forum auf dem laufenden, ob und was sich die nächsten Tage/Wochen ergibt.
Viele Grüße Jörg
Bitte warten ..
Mitglied: Tokocomp
14.10.2010 um 09:30 Uhr
Hoi Jörg
als die Sonderzeichen-Probleme auftauchten (ich glaub, das war ab Office XP), hab ich die Steuerdatei-Erstellung umprogrammiert auf Word-Dokument. Vorher war es auch txt.
Gruss
Thomas
Bitte warten ..
Mitglied: Tokocomp
14.10.2010 um 10:03 Uhr
wenn der Support das nicht kann, kannst Du es mit einem Makro probieren:

Sub Makro1()
'
' Makro1 Makro
'
'
ChangeFileOpenDirectory "C:\Test\"
Documents.Open FileName:="Steuerdatei.txt", ConfirmConversions:=False, _
ReadOnly:=False, AddToRecentFiles:=False, PasswordDocument:="", _
PasswordTemplate:="", Revert:=False, WritePasswordDocument:="", _
WritePasswordTemplate:="", Format:=wdOpenFormatAuto, XMLTransform:="", _
Encoding:=1252
ActiveDocument.SaveAs FileName:="Steuerdatei.docx", FileFormat:= _
wdFormatXMLDocument, LockComments:=False, Password:="", AddToRecentFiles _
:=True, WritePassword:="", ReadOnlyRecommended:=False, EmbedTrueTypeFonts _
:=False, SaveNativePictureFormat:=False, SaveFormsData:=False, _
SaveAsAOCELetter:=False
Application.Quit
End Sub

Word kannst Du ab CMD laufen lassen: c:\program files\microsoft office\office12\winword.exe /mMakro1
das erstellt dann aus dem steuerdatei.txt ein steuerdatei.docx.

Könnte auch sein, dass das Makro bei Dir nicht läuft, weil ich es mit Office2007 aufgezeichnet habe. Dann musst Du selber nochmal aufzeichnen.
Bitte warten ..
Mitglied: Tokocomp
14.10.2010 um 10:06 Uhr
hab noch vergessen: der Parameter Encoding:=1252 beim Documents.Open darf nicht fehlen, sonst kommen die Sonderzeichen ev. trotzdem wieder falsch. Ich hoffe, dass Office2003 den Parameter schon unterstützt...
Bitte warten ..
Mitglied: boulder02
14.10.2010 um 21:55 Uhr
Hallo Thomas,
das ist eine gute Idee, mit einem auto_open-Makro zu konvertieren. Wenn der support das nicht umsetzen kann, werde ich das auf alle Fälle mal ausprobieren. Wird zwar einen Ticken länger dauern, bis das Dokument auf dem Bildschirm ist, aber immer noch besser, als garnicht!
Ich halte dich auf dem Laufenden. Ich nehme mal an, dass ich morgen oder spätestens montag Rückmeldung vom Supprt bekommen habe.

Viel Grüße Jörg
Bitte warten ..
Mitglied: boulder02
17.11.2010 um 17:50 Uhr
Hey Thomas,
jetzt hat das doch ziemlich lange gedauert, bis ich mich weiter drum kümmern konnte.
Also , die Muttersoftware kann nur .txt auswerfen. Ich werde am WE mal ausprobieren, den Pfad umzuverlegen; die Verknüpfung hat beim Probieren ja nur in der Kombination .txt auf dem Netzlaufwerk L: nicht funktioniert. Ich weiss eigentlich nicht, warum ich das noch nicht versucht habe - peinlich; das wäre ja ziemlich simpel.
Wenn das klappt, ist es am einfachsten; dann dürfen nur die Mitarbeiter nicht jedesmal einen Herzinfarkt bekommen, wenn bei Öffnen der früheren Dokumente die .txt nicht gefunden wird.
Wenn das aber nicht geht, versuche ich dein Makro.

Bis dann und LG Jörg
Bitte warten ..
Mitglied: boulder02
18.11.2010 um 23:21 Uhr
So,
jetzt habe ich mit verschiedenen Pfaden rumprobiert aber hatte damit auch keinen Erfolg. Ich habe allerdings eben zufällig entdeckt, dass der Benutzer Admin ist! Vlt liegt da ja der Hase im Pfeffer von wegen den Berechtigungen auf die erzeugten .txt-Datei. Ich habe das beim hoster moniert und bin mal gespannt.
Das WE bin ich als Handwerker unbterwegs un komme erst nächste Woche wieder. Ich werde berichten...

LG Jörg
Bitte warten ..
Mitglied: boulder02
04.05.2012 um 18:31 Uhr
Hi,
nachdem jetzt 1 1/2 Jahre ins Land gegangen sind, in denen wir uns über verschiedene Notlösungen geholfen haben(Account-sharing, Verzicht auf die Serienbrief-Funktion, Umbenennen alter Benutzer), wurde das Problem neulich wieder akut, da wir mehrere neue Benutzer anlegen mussten, die die Serienbrieffunktion nutzen müssen.
Ich habe also wieder unseren IT-support angerufen und hatte jetzt einen Bearbeiter, der sehr motiviert ist und wirklich gut ist. Er hat einen Artikel aus der MS knowledgebase herausgesucht, der das Problem beschreibt und auch einen workaround anbietet, der funktioniert (Punkt 1: lokales Netz auf trusted stellen).

http://support.microsoft.com/kb/834699

Er hat gestern erst mal erfolgreich mit einem Benutzer probiert und da funktioniert es jetzt. Er wird die Änderung am Montag per Gruppenrichtlinie anbieten. Ich gehe mal davon aus, dass alles klappt und stelle deswegen den Beitrag auf gelöst.

Viele Grüße

@thomas: nochmal danke für deine Ideen. Wenn das jetzt nicht geklappt hätte, hätte ich mich wahrscheinlich an das Makro gesetzt. Aber so ists besser
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 7
Microsoft Word - Anzeigefehler bei Scrollen

Frage von heisenberg4 zum Thema Windows 7 ...

Windows 10
Surface 4 Pro Netzlaufwerk verbinden (4)

Frage von Yannosch zum Thema Windows 10 ...

Windows Server
gelöst Windows Server 2012 mit Fritzbox per VPN verbinden (13)

Frage von StefanT81 zum Thema Windows Server ...

Microsoft Office
gelöst Wie kann man die Standard-Schriftart bei einfügen von Text in Word 2013 festlegen? (3)

Frage von Rene1976 zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...