Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wordpress: Contact Form 7 funktioniert nicht

Frage Internet Blogs

Mitglied: greenhorn101

greenhorn101 (Level 1) - Jetzt verbinden

09.10.2014 um 23:08 Uhr, 8205 Aufrufe, 5 Kommentare

Hallo liebe community,

ich habe mittlerweile alles in meiner Macht stehende versucht um das Problem zu lösen, es aber bisher nicht geschafft.
Ich habe bei Wordpress das Plug-in
Contact Form 7
installiert. Ich benutzte Wordpress 4.0.
Wenn ich nun mein Formular nach meinen belieben angepasst habe und ich es dann das erste mla testen möchte funktioniert es nicht.
Es zeigt alle Felder so an wie ich möchte, also Layout-technisch ist alles in Ordnung.
Ich fülle dann die gesamten Felder aus und wenn ich nun auf "Senden" drücke, kommt die Fehlermeldung, dass die nachricht derzeit nicht gesendet werden kann.

Kann mir jemand von Euch helfen?

Vielen Dank und beste Grüße
greenhorn101
Mitglied: janzendi
10.10.2014 um 08:23 Uhr
Hab es gerade bei mir, mit der selben Konfiguration getestet und es funktioniert.
Sprich dieses Problem liegt wahrscheinlich nicht am Plugin.

Was für ein Anbieter hast du und hat er gegeben falls ein Update durchgeführt?
Welche Ordnerberechtigung hat das Script? Sprich kann es das Script überhaupt ausführen?

Das sind paar Anhaltspunkte, an denen ich letztes Jahr dran war und es dann durch dieses Vorgehen lösen konnte.
Bitte warten ..
Mitglied: greenhorn101
10.10.2014 um 09:02 Uhr
Guten morgen janzendi,

der Anbieter ist Goneo.
Mhhh das ist eine gute Frage. Muss ich dann die Rechte des Plug-Ins ändern per FTP?
Bitte warten ..
Mitglied: janzendi
10.10.2014 um 09:18 Uhr
Nur die Ordner Rechte. Ich glaub dass ich des damals einfach nur auf "chmod 750" gesetzt habe per "WebFTP".

Weil dies sofort funktioniert hat, jedoch sollte ich mir es vielleicht noch einmal anschauen. ^^

Das sind Ordnerrechte (Datei) nicht Wordpress. Ich hoffe dass du es verstanden hast.
Bitte warten ..
Mitglied: greenhorn101
10.10.2014 um 10:53 Uhr
Okay Danke. Ich glaube die habe ich anders eingestellt.
Danke für die Info, ich werde da dann mal nachschauen und mich melden ;)
Bitte warten ..
Mitglied: d4shoerncheN
10.10.2014, aktualisiert um 12:32 Uhr
Hallo Greenhorn,

bist du dir denn sicher das es direkt am Plugin liegt? Verschickt er das normale Kontaktformular denn?

Es könnte in deinem Fall auch falsch konfigurierte Mailserver Einstellungen in deinem Wordpress sein, oder aber gesperrte Funktionen seitens Goneo. Denn Contact Form arbeitet mit "additional_parameters" in der PHP-Funktion "mail". Und die könnte ggf. deaktiviert worden sein, kannst dir ja mal eine php_info erstellen und nachschauen. Hier könntest du in deiner Contact Form Konfiguration die Variable [your_mail] durch deine wirkliche E-Mail im Feld "Von" austauschen. Hier sollte eine E-Mail Adresse eingetragen werden, die den gleichen Domain-Namen aufweist.

Das Problem ist einfach das viele Mailprovider (in deinem Fall nun Goneo) verbieten, Mails in einem anderen Namen zu verschicken. Da genau dies geschieht bei einem Kontaktformular, denn der Absender ist ja nicht der Server, sondern die E-Mail Adresse die eingegeben wurde. Hier kannst du das Problem umgehen, indem du die Mails bei deinem Wordpress über SMTP verschickst, da gibt es sogar ein Plugin für:
https://wordpress.org/plugins/wp-mail-smtp/

Gruß
Toni
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Internetverbindung funktioniert erst nach ipconfig renew (6)

Frage von Joshh1 zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst W2008 R2 msiinstaller funktioniert nicht mehr (5)

Frage von Alix zum Thema Windows Server ...

C und C++
gelöst IF Abfrage funktioniert nicht mehr (2)

Frage von pablovic zum Thema C und C ...

Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...