Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

WSH Scripting

Frage Entwicklung Batch & Shell

Mitglied: schank

schank (Level 1) - Jetzt verbinden

01.06.2010 um 16:08 Uhr, 3516 Aufrufe, 2 Kommentare

Hallo an alle Leidensgenossen,
komme einfach nicht weiter und bin kurz vor dem Kolaps... aber sicherlich kann mir der EINE oder ANDERE eine Info bzw. Lösung geben.
Danke im Voraus.

Ich verteile per GPO (Windows 2008 Server 64bit) ein Startscript und möchte mit diesem gerne verschiedene Dll´s auf dem Client aktivieren, was leider nicht geht.
Das Script läuft ohne Fehler durch, jedoch auch ohne die Dll´s zu registrieren.

Folgender Aufruf wird aus dem Script gemacht (alle Vorabeiten im Script sind i.O., Dll ist im Verzeichnis des Client auch vorhanden):
...
ObjBatch.run "%windir%\System32\regsvr32.exe /s C:\Programme\Test.dll"

Ich habe auch versucht das Ganze über eine Batch zu machen, was auch nicht funktioniert (alle Vorabeiten im Script sind i.O., Dll ist im Verzeichnis des Client auch vorhanden):
...
ObjBatch.run "C:\Programme\InstallAddIn.bat"

Es wird einfach nicht ausgeführt, habe auch versucht mit runas -> auch ohne Erfolg!
runas macht auch keinen Sinn, da man beim Ausführen ein PW eingeben muss und das Ganze soll ohne Adminrechte und PW ablaufen!
Mit runasspc auch schon versucht, jedoch auch hier ohne Erfolg.

der ObjBatch.run wird einfach nicht ausgeführt.
Wenn ich über %Sysvoll%... auf dem Client das Script aufrufe, funktioniert alles einwandfrei, jedoch nicht beim Computerstart.
Mitglied: Edi.Pfisterer
01.06.2010 um 22:40 Uhr
Hallo!
Ferndiagnosen bei Gruppenrichtlinien sind immer schwer...
und leider habe ich keine Ehrfahrung mit Skripts, die dll's registrieren...

Für einen Denkanstoss bin ich aber allemal zu haben:
Könnte es daran liegen, dass Du beim Ausführen des Skripts via Sysvol schon als Admin angemeldet bist? Oder anders gesagt:
Könnte es sein, dass regsvr32 einen angemeldeten User mit Admin-Rechten braucht, damit er auf die entsprechenden Registry-Keys zugreifen kann (HKCU) und daher eine Gruppenrichtlinie, die das Startskript beim Systemstart (und nicht als Loginskript) anwirft, nicht funktionieren kann?
hm....

Falls Du eine Lösung hast würde ich mich freuen, wenn Du Sie hier mit uns teilen könntest...

vielleicht konnte ich Dir ja ein bisschen helfen...
lg
Edi
Bitte warten ..
Mitglied: schank
18.06.2010 um 08:04 Uhr
Hallo,

trage über GPO jetzt auf allen Client der Gruppe Hauptbenutzer den User "<Domäne>\Authentifizierte Benutzer" ein und dann läuft alles wie gewünscht!

Gruß
Ingo
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Open Source PowerShell Part 1 Hey Scripting Guy! Blog (2)

Link von AnkhMorpork zum Thema Batch & Shell ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (31)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...

RedHat, CentOS, Fedora
Fedora, RedHat, Centos: DNS-Search Domain setzen (13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...