Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

WSUS läuft nicht, EventId 18456. Reparaturinstallation?

Frage Microsoft Windows Server

Mitglied: Shakotai

Shakotai (Level 1) - Jetzt verbinden

17.03.2012 um 18:43 Uhr, 13918 Aufrufe, 5 Kommentare

Hallo,
muss ein wenig ausholen:
Mein Chef hat unserem Drängen nach mehr Plattenplatz nachgegeben und durch einen seiner Freunde zusätzliche HDD's im Server (WIn2k3 SBS) installieren lassen.

Als Erstes danach fielen mir Fehlermeldungen im Anwendungsprotokoll auf. (Login failed for user 'NT-AUTORITÄT\NETZWERKDIENST'. [CLIENT: <named pipe>] - EreignisId 18456) Eine Prüfung im SqlExpress\MSSQL$MICROSOFT##SSEE ergab, dass die WSUS Datenbank nicht mehr verzeichnet war. WSUS lief nicht. Erst danach fiel mir auf, dass das Laufwerk, auf der WSUS installiert wurde, nicht mehr die ursprüngliche Laufwerksbezeichnung trug. Eine einfache Änderung der Laufwerksbuchstaben brachte jedoch keinerlei Erfolg. Nachdem ich keine Lust hatte, jeden einzelnen Schritt des 'anderen Fachmannes' nachzuvollziehen, kam ich auf die Idee eine Reparaturinstallation durchzuführen. Eine DeInstallation zuvor brach mit der Meldung 'wegen eines Fehlers' zuvor ab. Der Versuch WSUS drüber zu installieren brachte jedoch das gleiche Ergebnis. Die Installationsroutine startet zunächst die Deinstallation, welche natürlich wieder mit gleicher Meldung abbricht.

Hat mir jemand vielleicht Hinweise wie ich entweder WSUS repariert bekomme oder - was wahrscheinlich einfacher ist - WSUS deinstalliert und neu installiert bekomme?

Danke und Gruß

Shakotai
Mitglied: Elefant54
17.03.2012 um 20:28 Uhr
hm...

ohne zu wissen welche Änderungen genau an "Deinem" System vorgenommen wurden wird die Fehlersuche ein wenig schwierig werden

Es wäre auf jeden Fall mal einen Versuch wert den "WSUS Konfigurations-Assistenten" zu starten und alle Schritte noch einmal "durchzuklicken". Hier solltest du auf jeden Fall genaues Augenmerk auf die Einstellungen hinsichtlich der WSUS-Datenbank legen. Evtl. kannst Du den WSUS so wieder zum Laufen bringen bzw. zumindest soweit zum Laufen bringen dass eine saubere Deinstallation möglich ist.

Falls Dich das nicht weiter bringt kannst Du Dir das WSUS "Server Diagnostic Tool" unter http://technet.microsoft.com/en-us/wsus/bb466192 laden um die Fehler genauer zu diagnostizieren...

Viel Erfolg!
Bitte warten ..
Mitglied: Shakotai
18.03.2012 um 11:10 Uhr
Guten Morgen,

den Konfigurationsassistenten hat die Deinstallationsroutine offenbar schon entfernt. An ein 'WIeder ans Laufen bringen' ist wohl ohne Neuinstallation nicht zu denken. Und an diese ohne restlose Deinstallation nict.
Ich vermute Reste der Deinstallation in der Registry oder irgend eine Abhängigkeit. mit dem Sql, welche mir da ins Handwerk pfuscht.

Das Diagnostic Tool hat mich leider auch nicht weiterbringen können.

Gruß
Shakotai
Bitte warten ..
Mitglied: Elefant54
18.03.2012 um 12:11 Uhr
Hallo,

es bleibt Dir dann wohl nichts anderes über als eine "manuelle Deinstallation" durchzuführen.

Unter SBS 2003 sollte Dir diese Anleitung weiterhelfen: http://blogs.technet.com/b/sus/archive/2008/11/05/how-to-manually-remov ...

Aber ACHTUNG:
Du solltest Dich vorher mit dem "SQL Management Studio" auf die "Windows Internal Database" verbinden und prüfen ob ausser der WSUS-DB
sonst noch etwas auf diesem SQL läuft. Wenn dem so sein sollte darfst Du natürlich nicht die ganze DB löschen.

Viel Erfolg!
Bitte warten ..
Mitglied: Shakotai
19.03.2012 um 08:22 Uhr
Hallo und guten Morgen!

Nur gut, dass noch niemand im Büro war, welcher meinen Freudentanz gerade hätte sehen können. Mein Ruf wäre auf Jahre lädiert gewesen...

Der WSUS und die intrerne Datenbank laufen wieder fehlerfrei. Seit einer Stunde habe ich keinerlei Fehlermeldungen mehr im Anwendungsprotokoll. Aktuell lädt er brav Updates runter..

Allerdings reichte die Anleitung nicht ganz aus, wenn sie auch wesentlich weiterhalf. Nachdem ich kontrolliert hatte, ob noch andere Datenbanken unter der Win Internal Database liefen, habe ich die Anleitung abgearbeitet. Danach versuchte die Installationsroutine zwar nicht mehr zu deinstallieren, brach jedoch mit der Fehlermeldung keinen Kontakt zur Microsoft##SSEE-Datenbank zu bekommen ab. Nachdem ich zunächst vergeblich versucht habe dieses manuell zu beseitigen, habe ich dann die Windows Internal Database deinstalliert und WSUS neu installiert. Welches dann auch ohne Probleme ging.

Herzlichen Dank für deine Unterstützung.

Gruß
Shakotai
Bitte warten ..
Mitglied: Elefant54
19.03.2012 um 08:34 Uhr
kein Problem - gern geschehen!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 7
Win 7 Keine Updates - Ewige Suche - WSUS läuft nicht (19)

Frage von metal-shot zum Thema Windows 7 ...

Windows Server
Windows Server 2016 WSUS, Updates auf Windows 10 werden nicht entfernt

Frage von Maeffjus zum Thema Windows Server ...

Windows Update
WSUS zeigt max. 69 Clients an (2)

Frage von TheGoodOne zum Thema Windows Update ...

Windows Server
WSUS Neuinstallation auf SBS2011 schlägt fehl (3)

Frage von Blongmon zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...