Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Was wurde im Netzwerkgeschehen von XP auf WIN 7 geändert?

Frage Microsoft Windows Netzwerk

Mitglied: hammherheadslf

hammherheadslf (Level 1) - Jetzt verbinden

24.07.2011 um 17:14 Uhr, 4555 Aufrufe, 7 Kommentare

probleme bei der Erkennung von LAN-Servern mit WIN7 ... wenn die Server auf XP (SP3) laufen funktioniert alles. Was ist anders?

Hallo,

ich bin auf ein seltsames Probelm gestoßen und habe auch schon viel im Inernet nachzulesen versucht.

Mein Problem, welches ich schon oft beobachtet habe, ist wie folgt:

ich habe in meinem netzwerk einen PC mit Win7 Ultimate (64Bit) und ein Notebook mit XP - SP3 (32Bit)

wenn ich zum beispiel über Hamachi ein "LAN" erstell und auf dem xp-Notebook verschiedene Server ( auch Dediziert ), so werden die meist ohne probleme von meinem Win7-PC und anderen im Hamachi-Netzwerk gesehen und können sich verbinden.
Wenn ich aber die gleichen Server auf dem Win7-PC erstelle .. wird selten bis kein Server gefunden.
auf beiden Systemen sind folgende einstellungen zum testen eingerichtet:

LAN-Verbindung mit DHCP ( Router vergibt aber immer die gleichen IP'S )
Hamachi-Netzwerk ( IP wird vom Programm festgelegt und zusätzlich ist ein Gateway 5.0.0.1 eingetragen )
Verbidungs-Priorität ist 1. Hamachi, 2. LAN-Verbindung, 3. LAN-Verbindung2 etc

zuletzt getestet mit FarCry2 Ingame-Server und Detiziert

ich hoffe Ihr könnt wisst eine Antwort, denn das scheint nicht nur mir so zu gehen ;)

im vorraus schon einmal vielen dank
Mitglied: sxxt60
24.07.2011 um 19:14 Uhr
Hallo,

Auf der Arbeit wurde mir von einem Kollegen eben von so einem Problem berichtet (ähnlich Konstellation - XP Client, Win7 und 2x Ubuntu). Ubuntu und XP haben zusammen einwandfrei funktoniert nur mit Win 7 gab es Probleme. Er hatte damals davon gesprochen die automatische Einrichtung der Heimnetzgruppen zu deaktivieren. Falls noch nicht geschehen könntest du dies ja mal testen und berichten.

lg
Bitte warten ..
Mitglied: kingkong
24.07.2011 um 20:21 Uhr
Schon mal geprüft, ob auf beiden Systemen die Firewall läuft? Evtl. fehlt eine Hamachi-Freigabe o.ä. Außerdem kann es auch noch verschiedene Probleme geben, wenn die Netzwerke als Heim-Netzwerk und nicht als Arbeitsplatz-Netzwerk definiert werden; dann versucht Windows 7 nämlich, ein passwortgeschütztes Heimnetz aufzubauen und bisweilen stört dies unter XP.

Der Internetzugang läuft ja für beide Rechner über denselben Router, oder? Gut, wobei das für Hamachi ja unerheblich sein sollte... Pings funktionieren beidseitig? Was sagt ein Trace? Und zu guter Letzt: Hast Du getestet, ob es funktioniert, wenn nur Rechner mit unterschiedlichem Internetzugang kommunizieren wollen (also XP und 7 jeweils an einem eigenen Internetanschluss)? Ich könnte mir vorstellen, dass die Priorisierung trotzdem nicht richtig funktioniert...
Bitte warten ..
Mitglied: hammherheadslf
24.07.2011 um 22:44 Uhr
Nabend,

also:
das ziel ist wie folgt: über hamachi eine verbindung von win7 Ultimate ( 64Bit ) -> Internet(Hamachi) -> zu win7 Ultimate ( 64Bit ) aufzubauen ( es ist sogar Identische Hardware verbaut - haben uns die gleichen Systeme zusammengestellt ) für die tests dient ein Notbook mit XP, welches aus dem eigenen netzwerk, sowie aus dem anderen netzwerk über hamachi erreichbar ist.

tracert ergab eine korrekte aufschlüsselung der IP ( direkt über den Hamachi-Client ), habe dennoch in der Hosts-Datei einen eintrag hinterlegt. ( Ohne erfolg )
IP-Range des gesammten Hamachi ist in der firewall freigegeben ( Beide PC's )
auf den Win7 systemen läuft nur die Win-eigene-Firewall und auf dem XP-Client zonealarm(free)
-> firewalls auf den win7 systemen wurde deaktiviert
-> verbindung auf XP Client erfolgte mit de- und aktivierter Firewall erfolgreich
-> Netzwerke sind als Heimnetzwerk eingestuft ( wo genau kann man diese Heimnetzgruppen abschalten? ich finde nur "heimnetzgruppe verlassen" )
-> Pings gehen in alle richtungen, und zu allen Clients mit ca. 62ms durch .. also verbindung an sich besteht, ich kann sogar auf Freigaben zugreifen. Nur die "Game-Server" sind nicht erreichbar.

Ich weiss nicht ob es generell bei FarCry2 so ist, das beim Starten eines "Dedicated-Server" auf win7-system, keinen Server findet, wenn man das Spiel selbst auf dem Gleichen rechner startet ( Listen-IP: Lokale IP des Rechners )

erstmal vielen dank für die ratschläge... ich werde morgen ein lokales Testfeld aufbauen und der sache auf den grund gehen ( 2x Win7 Ultimate 64Bit und das TestNotebook mit XP)
meine vermutung läuft dahin, das es bei Win7 im hintergrund noch einige Sicherheitsroutinen gibt, die man mit abschalten der Firewall nicht deaktivieren kann.

heute ist es schon spät, ich gebe morgen bescheid wie meine Tests verlaufen sind.

erster test mit lokalen IP-Adressen ( wenn es hier nicht funktioniert, sollte meine vermutung schon zutreffen, denke ich )
dann mit hamachi
und anschließend wieder über internet
Bitte warten ..
Mitglied: Connor1980
25.07.2011 um 08:08 Uhr
Hallo hammherheadself,

schon mal diese Anleitung befolgt?

Grüße
Bitte warten ..
Mitglied: hammherheadslf
25.07.2011 um 17:12 Uhr
Zitat von Connor1980:
Hallo hammherheadself,

schon mal diese Anleitung befolgt?

Grüße
Danke für dieses Tool... ich den fehler glaube ich :D

mir ist aufgefallen, das es manchmal mit win7 -> win7 funktionert ( bei anderen Systemen )

Nach stundenlangen Netzprotokollauswertungen gibt es folgendes zu sagen:

Bei den PC's/Notebook's, wo alles reibungslos funktioniert, existiert keine namensauflösung.
Bsp.
PC1(5.x.x.1) Sendet nur "5.x.x.1" und PC2(5.x.x.2) sendet nur"5.x.x.2" ! -> Hier funktioniert es Reibungslos

ABER:
sollte auch nur ein PC den PC-Name und "Lokaldomain" übermitteln kann bei einer Übertragung kein Signal zurückgesendet werden, da Hamachi es nicht versteht
Bsp:

PC1(5.x.x.1) sendet 5.x.x.1 und PC2(5.x.x.2) sendet 5.x.x.1
An PC2 wird die IP in eine domain verpackt und am PC2 kommt (wahrscheinlich dank SMB o. NetBIOS ) PC1.local an, daraufhin möchte PC2 antworten und nutzt vorranging idie Domain (pc1.local).
-> und hier ist der fehler der Hamachi-Client oder das Hamachi-Netzwerk versteht die angabe "PC1.local" nicht und sendet nicht korrekt
-> warum das allerdings im Lokalem netzwerk funktioniert ist mir ein Rätzel, es wird zwar mit der Hamachi-IP + "domain" kommunizert aber der Ping zeigt geschwindigkeiten des lokalen Netzwerks -> demnach geht die Verbindung nicht aus dem lokalem Netz und es gibt keine probleme mit der Namensauflösung im Hamachi.

wenn man das tool auf dem PC startet, bei dem es zu einer namesauflösung kommt, funktioniert die Server-erkennung reibungslos, ohne das Tool an anderen PC starten zu müssen.

@Connor1980
Vielen Dank nochmal;)
Deshalb funktioniert das Tool, weil es mit "gewalt" den netzwerkverkehr ins Hamachi lenkt
-> mir wird zwar im Protokoll angezeigt, das es bei der Namensauflösung bleibt, aber vllt. wird in dem Tool Diese aufgehoben.

auf alle fälle denke ich des Rätzel aufgeschlüsselt zu haben.. wie man das allerdings dauerhaft beheben kann, ohne das Tool einsetzten zu müssen, ist mir unbekannt und wenn's so funktioniert.... ist es schließlich egal :D

Ich hoffe, ich konnte meine Erkenntnisse rüberbringen

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: kingkong
25.07.2011 um 20:25 Uhr
Wenn ich es richtig verstehe ist das Problem also NetBIOS. Und das kann man in den Adaptereinstellungen eigentlich auch abschalten. Schau doch mal, ob die Option beim Hamachi-Adapter abgewählt ist. So würde dann die Namensauflösung im lokalen Netz wenigstens noch funktionieren. Wenn die Namensauflösung für Dich nicht notwendig ist, könntest Du sie natürlich auch auf allen Adaptern abschalten. Dann bräuchtest Du das Tool wohl nicht mehr, wenn ich es richtig verstehe.
Bitte warten ..
Mitglied: hammherheadslf
25.07.2011 um 22:29 Uhr
hi,

wahrscheinlich das NetBIOS oder SMB protokoll....
wie dem auch sei überall anderswo funktioniert es im lokalen netzwerk ... ich denke nur das Hamachi die namensauflösung PC1.local oder PC2.local nicht verträgt, da es meiner meinung auch eigentlich nur kennungen für ein reales InTRAnet ist ... aber mit dem tool klappt das ganze sehr gut...

ich bin mit dem ergebnis ganz zu frieden ... euch allen vielen dank ... vllt. find ich zeit, mich it der sache konkret zu beschäftigen...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows XP
gelöst Suche Win XP Home Premium ISO Datei (7)

Frage von Stefan007 zum Thema Windows XP ...

Windows Server
gelöst Nachverfolgung wann die Zeit geändert wurde (2)

Frage von Markus-MMU zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...