Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

X-server startet nicht beim Einschalten

Frage Linux Linux Desktop

Mitglied: Yet-Another-Linux-User

Yet-Another-Linux-User (Level 1) - Jetzt verbinden

18.01.2008, aktualisiert 13.03.2008, 8287 Aufrufe, 10 Kommentare

Hallo.

Seit einiger Zeit habe ich das Problem, dass ich beim Einschalten meines Rechners anstelle in KDE auf der Textkonsole lande.

Wenn ich nun
  • den Rechner via Strg-Alt-Del neu starte
oder
  • mich einlogge und "startx " eingebe
startet der X-server (und damit KDE) ohne Probleme.

Betriebssystem: OpenSuse 10.3 (32-bit)
Prozessor: AMD Athlon64 3000+

Hat dieses Problem sonst noch jemand (gehabt) und evtl. einen Lösungsvorschlag parat?
Mitglied: theton
18.01.2008 um 11:55 Uhr
Schau mal in einem Runlevel-Editor nach ob der KDM-Service aktiviert ist. Bei SuSE, Redhat u.a. RPM-basierten Distros muss der im Runlevel 5 gestartet werden, bei Debian-basierten Distros im Runlevel 2.
Bitte warten ..
Mitglied: Yet-Another-Linux-User
18.01.2008 um 12:09 Uhr
Schau mal in einem Runlevel-Editor nach ob der KDM-Service aktiviert ist.
Bei SuSE, Redhat u.a. RPM-basierten Distros muss der im Runlevel 5
gestartet werden, bei Debian-basierten Distros im Runlevel 2.

KDM taucht bei mir gar nicht auf. Meinst Du vielleicht xdm (RL 5)?
Bitte warten ..
Mitglied: theton
18.01.2008 um 13:34 Uhr
Ja, bei einigen Distros heisst die Start-Datei auch xdm.
Bitte warten ..
Mitglied: Yet-Another-Linux-User
18.01.2008 um 19:15 Uhr
Im "normalen" Betrieb ist xdm bei RL 5 aktiv.

Kann m.E. auch nicht das Problem sein, denn wenn der Rechner erst mal läuft, funktioniert's ja.

Das Problem tritt nur bei einem "Kaltstart" auf.
Sobald ich einen Reset durchgeführt habe, startet der x-server (inkl. KDE) ohne Probleme.
Bitte warten ..
Mitglied: MadTom
20.01.2008 um 17:58 Uhr
was steht denn in der /etc/inittab als Defalut runlevel? Bei Dir sollte irgendetwas in der Art:
...
  1. The default runlevel is defined here
id:5:initdefault:
...
stehen um X beim Systemstart sofort auszuführen.

Wenn das so ist und X trotzdem nicht hochfährt, dann sieh mal in die /var/log/message bzw. in die /var/log/Xorg.o.log. Da sollten Hinweise darauf stehen, warum X nicht gestratet wurde.

Außerdem sollte auf der Konsole etwas stehen, was zum Thema beiträgt und warum X nicht startet.

Gruß, Mad
Bitte warten ..
Mitglied: Yet-Another-Linux-User
21.01.2008 um 19:02 Uhr
Fehler gefunden. Der Hinweis mit der Xorg.o.log war der richtige ;.)

Auszug:
(EE) NVIDIA(GPU-0): Your GeForce 7600 GS graphics card does not have the necessary
(EE) NVIDIA(GPU-0): external power cables attached; X will not start unless
(EE) NVIDIA(GPU-0): this is rectified. Please shut down your computer, open
(EE) NVIDIA(GPU-0): its case, and attach the appropriate power connectors.
(EE) NVIDIA(GPU-0): Your video card may have multiple power connectors. If
(EE) NVIDIA(GPU-0): so, each must be attached to a separate power cable.
(EE) NVIDIA(GPU-0): Please see the documentation provided with your video card
(EE) NVIDIA(GPU-0): for more details. If you think you have received this
(EE) NVIDIA(GPU-0): message in error, you may specify the
(EE) NVIDIA(GPU-0): "NoPowerConnectorCheck" X configuration option in the
(EE) NVIDIA(GPU-0): Screen section of your X config file.
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found

Trotzdem seltsam.
Nach einem "Reboot" (OHNE an der Grafikkarte etwas geändert zu haben) gab's keine Probleme...
Bitte warten ..
Mitglied: theton
21.01.2008 um 19:21 Uhr
Evtl. ist dein Netzteil zu schwach?
Bitte warten ..
Mitglied: MadTom
29.01.2008 um 13:22 Uhr
Hmmm, ich hatte in meiner Kiste eine 7600 GT neben 2 Platten 2 DVD-LW und einem Tandberg SCSI-LW an einem 250 Watt Netzteil hängen und es lief problemlos. Allerdings kann es sein, dass Du die Stromzufuhr für die Graka an einem Kabel mit einem anderen stromintensiven Gerät hängen hast. Prüfe doch mal eine andere Kombination oder ein Kabel nur für die Graka.
Ich habe die Erfahrung gemacht, dass eher die Core-Spannung zusammenbricht, wenn das Netzteil zu schwach ist, aber ...
Bitte warten ..
Mitglied: Yet-Another-Linux-User
30.01.2008 um 17:21 Uhr
Allerdings kann es sein, dass Du die
Stromzufuhr für die Graka an einem Kabel
mit einem anderen stromintensiven Gerät
hängen hast. Prüfe doch mal eine
andere Kombination oder ein Kabel nur
für die Graka.

Bei Gelegenheit werde ich mir das nochmal anschauen müssen (Verkabelung und Leistung).

Das Netzteil müsste eigentlich ausreichend dimensioniert sein.

Könnte es evtl. damit zusammenhängen, dass es ein (wie nennt man das jetzt?) Netzteil ist, das seine Leistung dem Bedarf anpasst?

Das es beim Booten nicht schnell genug Leitung freigibt?

Komisch, dass der Fehler (übrigens auch unter Win-doof - da wird die Leistung der GraKa gedrosselt) nicht immer auftritt...
Bitte warten ..
Mitglied: 27688
13.03.2008 um 10:10 Uhr
> (EE) NVIDIA(GPU-0): Screen section
of your X config file.
> (II) UnloadModule: "nvidia"
> (II) UnloadModule: "wfb"
> (II) UnloadModule: "fb"
> (EE) Screen(s) found, but none have a
usable configuration.
>
> Fatal server error:
> no screens found

bin kein X spezialist, aber wie sieht es mit PNP aus ?
kann X inzw. nicht auch ein stückweit PNP und mit dem monitor kommunizieren?

evtl erkennt der X deinen monitor nach einem kaltstart nicht richtig und stört sich daran. bei einem warmstart hingegen meldet der monitor vieleicht einen besseren wert an X den er versteht und sich darauf einstellen kann.

ich würde mal versuchen eine monitorkonfiguration fest in X zu definieren vieleicht bekommst du dann stabilität hinein.
Bitte warten ..
Ähnliche Inhalte
CPU, RAM, Mainboards
PC startet mit 5 x beep
gelöst Frage von cpichlerCPU, RAM, Mainboards17 Kommentare

Hallo! Ich habe ja schon viele Rechner zusammengebaut, aber dieses Problem hatte ich noch nie: Hardware: AsRock H77 Board, ...

Sonstige Systeme
OS X Server und-oder Windows Server ?
gelöst Frage von pelzfruchtSonstige Systeme8 Kommentare

Abend, erstmal vorweg: Ich möchte auf garkeinen Fall einen Glaubenskrieg auslösen. Mir gehts halt nur um eine sachliche Diskussion. ...

Windows Server
MSSQL 2012: Datenkomprimierung einschalten
Frage von LaphroigWindows Server2 Kommentare

moin Gemeinde, kann man bei einer neu installierten MSSQL 2012 DB irgendwo die Datenkomprimierung von scratch einschalten? Hintergrund: wir ...

SAN, NAS, DAS
Einschalt-Möglichkeit bei HP MSA60
gelöst Frage von caspi-pirnaSAN, NAS, DAS8 Kommentare

Hallo, ich habe eine Frage zu den Möglichkeiten, ein HP MSA60 einzuschalten bzw. auch auszuschalten. Auf der Rückseite befindet ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Necur-Botnet soll Erpressungstrojaner Scarab massenhaft verbreiten

Information von BassFishFox vor 4 StundenErkennung und -Abwehr

12,5 Millionen Spam-Mails aus einem Bot-Netz mit 6 Millionen Computern? Eigentlich eine schwache Leistung. Die Erpresser setzen dabei auf ...

Microsoft

Nadeldrucker-Problem unter Windows - Microsoft liefert Updates

Information von BassFishFox vor 5 StundenMicrosoft

Hat ja nicht lange gedauert. Nachdem die November-Updates für Windows 7, 8.1 und 10 zahlreiche Nadeldrucker lahmgelegt hatten, stellt ...

Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 12 StundenLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Heiß diskutierte Inhalte
Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Windows Server
Kann man im KMS nachschauen , wieviele Clients den Key in Anspruch genommen haben
gelöst Frage von rainergugusWindows Server14 Kommentare

Hallo, wir haben einen KMS Windows 10 Key. Dieser ist ja W7 kompatibel. Aber unser Windows 7 Pool registriert ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...