Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Xampp für Linux

Mitglied: Xilence

Xilence (Level 1) - Jetzt verbinden

03.06.2013 um 18:48 Uhr, 2064 Aufrufe, 4 Kommentare

habe ein kleine oder großes Problem

wollte ein mysql Datenbankserver + Apache + phpmyadmin auf Ubuntu 12.10 64 bit (Terminalversion) installieren

Stand ist Apache + Webmin laufen

mysql , phpmyadmin nicht

um die Sache abzukürzen dachte ich mir das ich Xampp installiere

Fehlermeldung

Starte XAMPP fuer Linux 1.8.1...
XAMPP: Ein anderer Webserver laeuft bereits.
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP fuer Linux gestartet.

Was kann man machen ??? bzw ist Xampp sicher genug als Server

Hier noch mal die Meldung wo ich versucht habe den Datenbankserver zu installieren

Installiere Paket(e) mit Befehl apt-get -y --force-yes -f install mysql-client mysql-server ..
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
bluez bluez-alsa:i386 esound-common gconf-service gconf-service-backend
gconf2-common gvfs:i386 gvfs-libs:i386 libaa1:i386 libaio1:i386 libao-common
libao4:i386 libasn1-8-heimdal:i386 libasound2:i386 libasound2-plugins:i386
libasyncns0:i386 libatk1.0-0:i386 libaudio2:i386 libaudiofile1:i386
libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
libavc1394-0:i386 libcaca0:i386 libcairo-gobject2:i386 libcairo2:i386
libcanberra0:i386 libcap2:i386 libcapi20-3:i386 libcdparanoia0:i386
libdatrie1:i386 libdbus-glib-1-2:i386 libdrm-intel1:i386
libdrm-nouveau2:i386 libdv4:i386 libesd0:i386 libexif12:i386 libflac8:i386
libfontconfig1:i386 libfreetype6:i386 libgconf-2-4 libgconf-2-4:i386
libgcrypt11:i386 libgd2-xpm:i386 libgdbm3:i386 libgettextpo0:i386
libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
libglu1-mesa:i386 libgnome-keyring-common libgnome-keyring0:i386
libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386
libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgudev-1.0-0:i386
libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
libhx509-5-heimdal:i386 libibus-1.0-0:i386 libice6:i386 libidn11:i386
libiec61883-0:i386 libieee1284-3:i386 libjack-jackd2-0:i386 libjasper1:i386
libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386 libjson0:i386
libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386
libkrb5support0:i386 liblcms1:i386 libllvm3.1:i386 libltdl7:i386
libmad0:i386 libmikmod2:i386 libmng1:i386 libmpg123-0:i386 libodbc1:i386
libogg0:i386 libopenal-data libopenal1:i386 liborc-0.4-0:i386
libp11-kit0:i386 libpango1.0-0:i386 libpciaccess0:i386 libpixman-1-0:i386
libproxy1:i386 libpulse-mainloop-glib0:i386 libpulse0:i386 libpulsedsp:i386
libqt4-dbus libqt4-dbus:i386 libqt4-network:i386 libqt4-script:i386
libqt4-test:i386 libqt4-xml libqt4-xml:i386 libqt4-xmlpatterns:i386
libqtcore4 libqtcore4:i386 libraw1394-11:i386 libroken18-heimdal:i386
libsamplerate0:i386 libsasl2-2:i386 libsasl2-modules:i386
libsdl-mixer1.2:i386 libsdl-net1.2:i386 libsdl-ttf2.0-0:i386
libsdl1.2debian:i386 libshout3:i386 libsm6:i386 libsndfile1:i386
libspeex1:i386 libspeexdsp1:i386 libsqlite3-0:i386 libssl0.9.8:i386
libssl1.0.0:i386 libstdc++5:i386 libstdc++6:i386 libtag1-vanilla:i386
libtag1c2a:i386 libtasn1-3:i386 libtdb1:i386 libthai0:i386 libtheora0:i386
libtxc-dxtn-s2tc0:i386 libunistring0:i386 libusb-0.1-4:i386
libusb-1.0-0:i386 libv4l-0:i386 libv4lconvert0:i386 libvisual-0.4-0:i386
libvisual-0.4-plugins:i386 libvorbis0a:i386 libvorbisenc2:i386
libvorbisfile3:i386 libwavpack1:i386 libwebp2:i386 libwind0-heimdal:i386
libwrap0:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxaw7:i386
libxcb-glx0:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb1:i386
libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386
libxext6:i386 libxfixes3:i386 libxft2:i386 libxi6:i386 libxinerama1:i386
libxmu6:i386 libxp6:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
libxss1:i386 libxt6:i386 libxtst6:i386 libxv1:i386 libxxf86vm1:i386 odbcinst
odbcinst1debian2 odbcinst1debian2:i386 qdbus xaw3dg:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libaio1 libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl libterm-readkey-perl mysql-client-5.5
mysql-client-core-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5
Suggested packages:
libipc-sharedcache-perl tinyca mailx
The following NEW packages will be installed:
libaio1 libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient18
libnet-daemon-perl libplrpc-perl libterm-readkey-perl mysql-client
mysql-client-5.5 mysql-client-core-5.5 mysql-common mysql-server
mysql-server-5.5 mysql-server-core-5.5
0 upgraded, 15 newly installed, 0 to remove and 68 not upgraded.
Need to get 26.0 MB/27.2 MB of archives.
After this operation, 97.2 MB of additional disk space will be used.
Err http://de.archive.ubuntu.com/ubuntu/ quantal-updates/main mysql-common all 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 141.30.13.10 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-common all 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main libmysqlclient18 amd64 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-client-core-5.5 amd64 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-client-5.5 amd64 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-server-core-5.5 amd64 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-server-5.5 amd64 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-client all 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Err http://security.ubuntu.com/ubuntu/ quantal-security/main mysql-server all 5.5.29-0ubuntu0.12.10.1
404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-common_5. ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient1 ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-co ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client-5. ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-co ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server-5. ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-client_5. ... 404 Not Found [IP: 91.189.92.190 80]
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/mysql-server_5. ... 404 Not Found [IP: 91.189.92.190 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Danke in voraus

Mitglied: 64748
03.06.2013 um 20:42 Uhr
Guten Abend,

erstens finde ich hier den Satz
As of Ubuntu 12.04, MySQL 5.5 is installed by default. Whilst this is 100% compatible with MySQL 5.1 should you need to install 5.1 (for example to be a slave to other MySQL 5.1 servers) you can install the mysql-server-5.1 package instead.
Also sollte mysql-server doch bei Dir schon installiert sein.

zweitens bedeuten die Fehlermeldungen genau das was dort steht: Die Links funktionieren nicht. Also nix weltbewegendes.

Stelle erstmal fest, was auf Deinem System bereits installiert ist. Und wenn doch mysql-server und apache schon da sind, wo ist dann das Problem? wenn mysql oder was weiß ich nicht läuft, dann finde raus warum bzw. poste mal die Fehlermeldungen hier.

Markus
Bitte warten ..
Mitglied: Xilence
03.06.2013, aktualisiert um 21:23 Uhr
Hallo Markus ,

installiert wurden Apache und Webmin
über Webmin wollte ich mysqlDatenserver installiern (Fehlermeldung )

dann wurde auf kurzen Weg Xampp installiert

deswegen die Meldung
Starte XAMPP fuer Linux 1.8.1...

XAMPP: Ein anderer Webserver laeuft bereits. !!!
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP fuer Linux gestartet.

root@Server:~# sudo netstat -tap | grep mysql
tcp 0 0 *:mysql *:* LISTEN 7690/mysqld

mysql läuft

jetzt die Frage

welche Dateien müssen noch konfiguriert werden

wie startet man phpmyadmin
Bitte warten ..
Mitglied: mrtux
03.06.2013, aktualisiert um 21:40 Uhr
Hi!

Du hast vermutlich Xampp als einzelnes Komplettpaket installiert und damit doppelt gemoppelt.

Installiere entweder die einzelnen Pakete (also apache, php, mysql und phpmyadmin) aus deiner installierten Distribution (also in deinem Fall Ubuntu) mit dem Paketmanager (apt-get, aptitude, synaptic oder der Softwareverwaltung) oder eben NUR das Komplettpaket (z.B. als tar/gz) aber NIEMALS beides, denn das gibt Kuddelmuddel...

phpmyadmin startet man so wie man jede php-site startet:
01.
http://deinserver/pfad_wo_es_eben_auf_dem_server_liegt 
02.
z.B. http://localhost/phpmyadmin
mrtux
Bitte warten ..
Mitglied: nxclass
04.06.2013, aktualisiert um 14:56 Uhr
auf Ubuntu 12.10 64 bit
:i386
... ich glaube da passt noch was anderes nicht.

http://wiki.ubuntuusers.de/XAMPP

http://wiki.ubuntuusers.de/LAMP - benutze lieber diese Anleitung
Bitte warten ..
Ähnliche Inhalte
Apache Server
PfSense und XAMPP
gelöst Frage von micsonApache Server2 Kommentare

Hallo, zuerst wünsche ich euch allen ein frohes Osterfest! Folgendes Problem: Habe pfSense auf einem ALIX-Board laufen. Dort hängt ...

Hyper-V
Netzwerklastenausgleich auch mit Xampp ?
Frage von RasmusenHyper-V8 Kommentare

Hi, ich habe derzeit einen physikalischen Windows2008 R2 Server und einen HyperV Host mit 2 Win2012R2 VMs am laufen. ...

Hosting & Housing

XAMPP Website über Internet erreichbar machen

Frage von ShaddyHosting & Housing36 Kommentare

Vorwort (BITTE LESEN): -Ich weiß, dass es Sicherheitsbedenken gibt, wenn ich XAMPP vom Internet aus erreichbar mache. -Ich möchte ...

Internet

Xampp - Appache Dienst geht nicht!

gelöst Frage von FengShuiInternet9 Kommentare

Hallo zusammen, ein kleines Problem mit dem Appache Start. Heute habe ich Xampp installiert und nachdem habe ich den ...

Neue Wissensbeiträge
Vmware
VMware Update für den ESXi 5.5 verfügbar
Information von sabines vor 18 StundenVmware

Nach dem ganzen Hickhack um Update mit Microcode Anpassungen und Rückzug, gibt es nun für den ESXi 5.5 ein ...

CPU, RAM, Mainboards

Meltdown und Spectre: Intel zieht Microcode-Updates für Prozessoren zurück

Information von keine-ahnung vor 22 StundenCPU, RAM, Mainboards5 Kommentare

Moin, extrem lutztig. Nur gut, dass ich noch nicht beim Probanden-Bingo mitgemacht habe :-) LG, Thomas

Router & Routing
PfSense als Addon auf QNAP
Information von magicteddy vor 1 TagRouter & Routing7 Kommentare

Moin, für Spielereien eine ganz nette Idee aber ich fürchte das soetwas auch als echte Firewall genutzt wird: In ...

Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 1 TagDatenschutz1 Kommentar

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement26 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Server
TEMP-Profile
gelöst Frage von Forseti2003Windows Server21 Kommentare

Guten Morgen, wer kennt sie nicht, die lieben Temporären Benutzerprofile, vorallem immer dann, wenn man sie am wenigsten braucht. ...

Multimedia & Zubehör
Welches Tablet für die Verkäufer?
Frage von Hendrik2586Multimedia & Zubehör16 Kommentare

Guten Morgen meine Lieben, vielleicht könnt ihr mir ja helfen. Es geht um unsere Außendienstmitarbeiter /Verkäufer. Sie sollen demnächst ...

Ubuntu
Ubuntu - Routing mit 2 Netzwerkkarten?
Frage von gabrixlUbuntu13 Kommentare

Hei Folgende Situation: Ich habe zwei virtuelle Maschinen: 1 - Server für DHCP, DNS und Routing - Netzwerkkarte 1: ...