Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

XAMPP redirect abschalten

Frage Internet Server

Mitglied: ratzla

ratzla (Level 2) - Jetzt verbinden

01.08.2007, aktualisiert 02.08.2007, 10925 Aufrufe, 4 Kommentare

Ich muss / will einen XAMPP unter SuSE10.2 installieren.
Dummerweise ist es so dass beim Aufruf des Document Roots immer ein redirect auf das unterverzeichnis /xampp gemacht wird und die xampp seiten damit als startseit auftauchen. Nur wenn ich explizit die index.html angebe bleibe ich im korrekten Verzeichnis.

beispiel: Document Root ist auf /opt/lampp/htdocs (Standard bei xampp)

Eingabe im Browser http://SERVERIP/

Ergebnis /opt/lampp/htdocs/xampp/index.php wird zurückgegeben.

Weiss irgendjemand wie man dieses Verhalten anstellen kann (ist bei XAMPP 1.6 und XAMPP 1.6.3a genau das gleiche verhalten)

Danke
Mitglied: Jon
01.08.2007 um 22:25 Uhr
Benenn die index.php einfach mal um, index1.php oder so, dann ist dein problem beseitigt.

mfg
Jon
Bitte warten ..
Mitglied: ratzla
02.08.2007 um 10:58 Uhr
So einfach ist das leider nicht - das Verzeichnis xammp wird auch dann noch aufgemacht; es erscheint halt dann das Directory Listing oder einen Fehler wenn ich das Verzeichnis ganz wegnehme.
Ich habe zwar immer noch nicht gefunden woran es liegt, aber wenn das mod_rewrite modul deaktiviert wird dann scheint es zu laufen.
Bitte warten ..
Mitglied: Jon
02.08.2007 um 18:02 Uhr
Wenn du auf den webserver zugreifst, lädt er automatisch die index.html, index.php, index.htm,... (was da bevorzugt wird kann man einstellen). Wenn du also jetzt zugreifst, wird automatisch die index.html geladen. In dieser steht dann bei deiner Xampp-version, dass eine weiterleitung zum verzeichniss /xampp gemacht werden soll
<meta http-equiv="refresh" content="0;url=/xampp/">

Wenn du diese nun mit einer anderen index.html überschreibst, kannst du nicht mehr weitergeleitet werden; außer du schreibst oben genanntes wieder in die meta-tags rein ... . Mit mod_rewrite hat das ganze überhaupt nichts zu tun.
Bitte warten ..
Mitglied: ratzla
02.08.2007 um 19:34 Uhr
Ich kenne mich schon mit Apache aus - nur mit XAMPP habe ich noch nicht so viel gemacht.
Seltsamerweise hats nach dem dem auskommetieren des rewrite Moduls eine zeitlang geklappt, war aber keine dauerhafte Lösung.
Zuvor hatte ich das xampp verzeichnis umbenannt und eine eigene einfach index.html angelegt sowie alle anderen Dateien auf htdocs rausgeworfen (an sich war beabsichtigt den Document Root auf ein Unterverzeichnis zu "verbiegen"). Ergebnis war dass immer noch /xampp aufgerufen wurde (was dann halt in der error_log zu eine Eintrag geführt hat). Ich habe jedoch auch mit grep -ir xampp im gesamten etc verzeichnis keinen einzigen Eintrag gefunden.

Nachdem ich die jetzt die dns einträge der Maschine gesetzt hatte ging es plötzlich. Vorher war sie nur über IP erreichbar. Für mich noch immer schleierhaft wo das herkommt wen es nicht in den Apache Code irgendwo einkompiliert wurde ???

Trotzdem Danke nochmals
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Sticky Notes - Autostart unterbinden

Tipp von Pedant zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Server 2016 ES - kennwortgeschützte freigabe abschalten! (10)

Frage von tahato zum Thema Windows Server ...

Webentwicklung
Redirect - Ausnahme definieren in Htaccess (3)

Frage von dodo-r zum Thema Webentwicklung ...

Heiß diskutierte Inhalte
Flatrates
DeutschlandLAN der Telekom - welche internen IPs? (19)

Frage von qualidat zum Thema Flatrates ...

Batch & Shell
gelöst Base64 Decode (Batch,VBS) (16)

Frage von clragon zum Thema Batch & Shell ...

LAN, WAN, Wireless
Wie Gäste ins Internet bringen? (15)

Frage von xSiggix zum Thema LAN, WAN, Wireless ...