Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

xcopy - 0 datein kopiert - errorcode 0

Frage Entwicklung Batch & Shell

Mitglied: excalibur1977

excalibur1977 (Level 1) - Jetzt verbinden

22.10.2009 um 09:42 Uhr, 6631 Aufrufe, 4 Kommentare

hallo

ich will eine datei auf ein netzlaufwerk kopieren und alles was geschieht in ein log speichern, wenn der befehl nicht richtig ausgeführt werden kann, soll mir eine mail geschickt werden welche als anhang die log enthält. mein problem ist nun, wenn keine datei kopiert werden konnte erhalte ich trotzdem den errorcode 0 und ich bekomme keine mail aufgrund des errorcode 0. loginhalt ist unten zu sehen. die batchdatei wird unter server 2003 ausgeführt.

kann mir einer sagen wo der fehler ist? warum bekomme ich den errorcode 0 obwohl keine datein kopiert wurden?

xcopy.bat

net use z: \\xxx.xxx.xxx.xxx\Freigabe Passwort /user:Benutzer
set datum=%date:~6,4%%date:~3,2%%date:~0,2%
xcopy.exe C:\Programme\Anwendung\name.dmp z:\%datum%_dbdump\ /V /H /R /K /O /X /Y /F >> z:\%datum%.log 2>>&1
echo Errorcode = %errorlevel% >> z:\%datum%.log
if %errorlevel% == 0 goto OK
if not %errorlevel% == 0 goto FEHLER
:FEHLER
echo FEHLER
C:\Programme\blat262\full\blat.exe -to mail1@domain.de -f mail2@domain.de -u account -pw xxxxxxxx -server domain.de -s "Anwendung - xcopy error message" -body "diese nachricht wurde automatisch von blat erstellt und versand, da ein fehler aufgetreten ist." -attacht z:\%datum%.log
:OK
echo OK
net use z: /delete


log.log

Datei name.dmp nicht gefunden.
0 Datei(en) kopiert
Errorcode = 0
Mitglied: Netzheimer
22.10.2009 um 10:50 Uhr
Hallo.

Existiert denn dein Zielverzeichnis oder musst du es etwa vorher noch erstellen?

Wenn ja, schau dir mal den XCOPY-Parameter i an.

Gruß
Netzheimer
Bitte warten ..
Mitglied: excalibur1977
22.10.2009 um 11:02 Uhr
das ziel existiert. die log datei wird ja auch angelegt.

mich irritiert der errorcode 0 obwohl ja nicht kopiert wird.

Exit codes for Xcopy
0 Files were copied without error.
1 No files were found to copy.
2 The user pressed Ctrl+C to terminate xcopy.
4 Various errors including insufficient memory or disk space, an invalid drive name, or invalid syntax.
5 Disk write error occurred
Bitte warten ..
Mitglied: Netzheimer
23.10.2009 um 08:17 Uhr
Mir ist gerade aufgefallen, dass ich in meinen Batch-Skripten XCopy ohne .exe dahinter aufrufe.

Lass mal .exe weg und starte das ganze nochmal. Ich vermute es liegt daran.

Gruß
Netzheimer
Bitte warten ..
Mitglied: bennib22
26.10.2009 um 13:22 Uhr
Hi, erstmal.
Netzheimer hat recht.
Ich habs zwar jetzt nicht konkret ausgeführt,aber in bat-Befehlen het *.exe meistens nix verlohren!

mfG
bennib22
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Nach xcopy feststellen, ob Datei kopiert wurde oder nicht (9)

Frage von Scar61 zum Thema Batch & Shell ...

Batch & Shell
gelöst Xcopy leeren Folder1 nach Folder2 geht nicht (9)

Frage von Yauhun zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
gelöst Telefonanlage gesucht (39)

Frage von Xaero1982 zum Thema TK-Netze & Geräte ...

Windows Netzwerk
Anmeldung an Domäne schlägt oft fehlt (Fehlermeldung: falsches Passwort) (24)

Frage von harald.schmidt zum Thema Windows Netzwerk ...

Exchange Server
gelöst Wie freigegebenes Postfach immer als primäre Sendeadresse verwenden? (18)

Frage von Flinxit zum Thema Exchange Server ...

Microsoft Office
Outlook 2016 - Keine Mails sichtbar (nach Suche schon) (17)

Frage von Hirschix3 zum Thema Microsoft Office ...