Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

xcopy Daten von Server auf Client - Ungültige Laufwerkangabe

Frage Microsoft Windows Netzwerk

Mitglied: I3EDV2009

I3EDV2009 (Level 1) - Jetzt verbinden

21.01.2009, aktualisiert 11:32 Uhr, 4706 Aufrufe, 1 Kommentar

Hi,

ich versuche ein vorgefertigtes OpenOffice.org 3 Profil vom Server auf den Client (In den Anwendungsdatenordner, der auch auf einem Server liegt) zu kopieren.

Meine Batch sieht so aus:

01.
if exist "%appdata%\OpenOffice.org\3\user\basic\dialog.xlc" goto No-Install-OOo-Profil 
02.
 
03.
net use i: \\SERVER\Softwareinstallation$ /persistent:no > NUL: 2>&1 
04.
 
05.
xcopy "i:\OpenOffice\Profil\OpenOffice.org" "%appdata%\OpenOffice.org" /S /I 
06.
 
07.
:No-Install-OOo-Profil 
08.
 
09.
exit
Sollte eigentlich kein Problem sein.
Es kommt aber folgender Fehler:

01.
C:\WINDOWS>xcopy "i:\OpenOffice\Profil\OpenOffice.org" "\\<SERVER>\Anwendungsdaten\<USER>\OpenOffice.org" /S /I 
02.
Ungültige Laufwerkangabe 
03.
0 Datei(en) kopiert
Ich habe schon etliche dinge getestet, bin aber zu keinem Ergebnis gekommen.

Das Laufwerk i: kann ich Problemlos mit CMD durchlaufen und auch mit dem Arbeitsplatz.

<SERVER> und <USER> sind natürlich mit den jeweiligen Benutzer bzw. Server ersetzt.

Was kann ich tun?
Mitglied: I3EDV2009
21.01.2009 um 12:38 Uhr
Hi,

habe selber gelöst.

Konnte das Problem mit PSexec beheben:

01.
l:\Util\psexec /accepteula -u <DOMÄNE>\Administrator -p <PASSWORT> -i -d -e cmd "/C net use i: \\<SERVER>\Softwareinstallation$ /persistent:no > NUL: 2>&1 & xcopy "I:\OpenOffice\Profil\OpenOffice.org" "%appdata%\OpenOffice.org" /I /S & pause"
Komischer weise geht es OHNE das pause am Ende nicht.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...