Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

XCopy findet einige Dateien nicht

Frage Entwicklung Batch & Shell

Mitglied: Coloneltw

Coloneltw (Level 1) - Jetzt verbinden

06.07.2010, aktualisiert 13:48 Uhr, 7166 Aufrufe, 2 Kommentare

Hallo an alle und vielen Dank für Eure Hilfe im Vorraus

Ich habe hier ein kleines Rätsel was mich beschäftigt.
Kurz zum Hintergrund wir haben ein Backuphandbuch mit allerlei Dateien für den K-Fall.
Damit diese Dokumente nicht doppelt oder dreifach gepflegt werden müssen, liegen diese an ihren richtigen Platz im Netz.
Ich erstelle gerade ein Script, welches alle für das Backuphandbuch notwendigen Dateien in einen Ordner kopiert und mit den vorgesehenen Namen versieht.
Ich verwende dafür ganz einfach xcopy mit dem Parameter /Y fürs überschreiben.
Beide Pfade sind mit "" umgeben damit auch Leerstellen im Pfad möglich sind. Beide Pfade, Quelle wie Ziel sind komplett in UNC, also keine Laufwerksbuchstaben.
Von den ca. 45 Dateien funktionieren 40 super, 5 nicht.
Er schreibt dann das er die Datei nicht finden konnte.
Also habe ich den Pfad aus dem Script genommen und im Explorer als Adresse eingegeben und prompt öffnet er das korrekte Dokument, der Pfad stimm also.
Meine Frage ist woran kann es liegen?
Anbei die Zeilen die Probleme machen
01.
REM Systemdokumentation 
02.
xcopy "\\firma.com\abteilung\IT\IT-Dokumentation\4. IT-Infrastruktur\4.3 Netzwerke\Systemkonfiguration.pdf" "\\firma.com\abteilung\IT\IT-Dokumentation\4. IT-Infrastruktur\4.8 Backup\Backuphandbuch\BU09_Systemkonfiguration.pdf" /Y
Die Meldung besagt, dass er die Quelldatei nicht finden kann:
01.
Datei Systemkonfiguration.pdf nicht gefunden 
02.
0 Datei(en) kopiert
Also mich verwirrt das, da der Pfad stimmt und alle anderen Dateien kopiert werden können.
Ich dachte auch schon an die Pfadlänge aber bei einigen Fehlern liegen die Dokumente auf der gleichen Ebene und er kopiert nur ein paar und nicht alle.

Ich hoffe ihr könnt mir da weiterhelfen.
VG
Thomas
Mitglied: Coloneltw
06.07.2010 um 13:45 Uhr
Hallo nochmal, habe herausgefunden woran es lag, er mochte meine Umlaute nicht
Mit

echo off
chcp 1252

in den ersten Zeilen erkennt er Umlaute und findet den Pfad.
Bitte warten ..
Mitglied: Biber
06.07.2010 um 13:51 Uhr
[OT]
Moin Colonelbw,

Zitat von Coloneltw:
Hallo nochmal, habe herausgefunden woran es lag, er mochte meine Umlaute nicht
Mit

echo off
chcp 1252

in den ersten Zeilen erkennt er Umlaute und findet den Pfad.

Ursprüngliche Problembeschreibung:
Die Meldung besagt, dass er die Quell Datei nicht finden kann

Datei Systemkonfiguration.pdf nicht gefunden
0 Datei(en) kopiert

Das verleitet mich summa summarum zu der Schlussfolgerung, einige von euren IT-Fachkräften
müssen die Quelldatei "Süstemkonfiguration.pdf" geschrieben haben.
Beschäftigt ihr eigentlich mehr Leverkusener oder Delmenhorster?

Grüße
Biber
[/OT]
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows 7
Kopierte Dateien im Hintergrund anzeigen (1)

Frage von MichiBLNN zum Thema Windows 7 ...

Festplatten, SSD, Raid
Reallocated sectors count: Welche Dateien befinden sich in den beschädigten Sektoren? (9)

Frage von DunkleMaterie zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...