Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

XenServer Snapshot VM auf anderem Server wiederherstellen.

Frage Virtualisierung Xenserver

Mitglied: strobocom

strobocom (Level 1) - Jetzt verbinden

07.04.2013 um 17:44 Uhr, 3647 Aufrufe, 14 Kommentare

Hallo,
wir haben online 4 virtuelle Maschinen (Linux) auf einem XenServer laufen. Jetzt haben wir einen Snapshot der Maschinen erstellt den wir herunterladen wollten. Das ganze hat auchj funtkioniert. Jetzt wollten wir dieses BAckup des Snapshots vor Ort auf einem Server einspielen leider funtkioniert dies nicht. Hat jemand eine Idee?

Es handel sich um 4 Debian Lenny
Mitglied: 2hard4you
07.04.2013 um 19:41 Uhr
Moin,

falsche Begrifflichkeit - ein Snapshot ist ein unvollständiges Abbild einer VM - bsaierend auf der VM - was Ihr braucht ist ein Image - Snapshots sind keine Art des Backups....

Gruß

24
Bitte warten ..
Mitglied: Dobby
07.04.2013 um 19:56 Uhr
Hallo @2hard4you,

kann man das auch mit Shadow Copys machen oder muss man die VM "ausschalten" und dann das Image kopieren?

Gruß
Dobby
Bitte warten ..
Mitglied: strobocom
07.04.2013 um 20:06 Uhr
Gibt es eine möglichkeit ein Backup zu machen ohne die VM runter zu fahren oder wie kann man einen Imagesnapshot machen?
Bitte warten ..
Mitglied: 2hard4you
07.04.2013 um 20:06 Uhr
Moin,

beim XEN-Server kann ich Dir das nicht so genau sagen, Snapshot geht immer online, Image geht manchmal online, Shadow Copy setzt Windows voraus - ich bin halt ESX-Mensch, und da geht ein Image offline zu erstellen. (aber es geht schnell)

Gruß

24
Bitte warten ..
Mitglied: 2hard4you
07.04.2013, aktualisiert um 20:11 Uhr
Zitat von strobocom:
Imagesnapshot machen?

Image <> Snapshot - jetzt verstanden?


24

P.S. - mach nen Clone, der sollte online gehen....
Bitte warten ..
Mitglied: Dobby
07.04.2013 um 20:10 Uhr
Shadow Copy setzt Windows voraus
Danke
Bitte warten ..
Mitglied: strobocom
07.04.2013 um 20:11 Uhr
Klar vertanden jab ich das schon, bin nur nach einer möglichkeit am suchen das direkt auf dem Xen zu machen... aber wie ich das sehe muss ich die VM runterfahren ;-/ und dann dauert es lange
Bitte warten ..
Mitglied: smartino
07.04.2013 um 22:31 Uhr
Zitat von 2hard4you:

falsche Begrifflichkeit - ein Snapshot ist ein unvollständiges Abbild einer VM - bsaierend auf der VM - was Ihr braucht ist
ein Image - Snapshots sind keine Art des Backups....

so ganz stimmt das nicht. Der allererste Snapshot basiert (da er der erste ist) nicht auf einem Vorgänger und ist somit vollständig. Er muß nur noch konvertiert werden und taugt danach ohne Probleme zum importieren.

Gruss, Thomas
Bitte warten ..
Mitglied: 2hard4you
07.04.2013 um 22:37 Uhr
da würde ich schwer widersprechen - dann wäre der erste Snapshot genauso groß wie ein Image oder ein Clone - und das isser nicht...

Gruß

24
Bitte warten ..
Mitglied: Der-Phil
08.04.2013 um 08:50 Uhr
Hallo!

Das ist ja mal geballtes Halbwissen hier...

Bei Xenserver enthält ein "EXPORTIERTER Snapshot" die gesamte VM, jedoch eben in dem "unsauberen" Zustand zur Zeit des Snapshots.

Ein Snapshotbackup ist demnach genauso lauffähig, wie ein hart ausgeschalteter Server.

Du schreibst nur: "Funktioniert nicht".
Was funktioniert denn nicht? Lässt sich die VM nicht importieren, oder läuft anschließend die VM nicht hoch?
Was hast Du für eine Fehlermeldung?
Hast Du mit "preserve UID" importiert?
Hast Du "doppelte MACs" bei den Netzwerkschnittstellen?

Phil
Bitte warten ..
Mitglied: smartino
08.04.2013 um 21:51 Uhr
Zitat von 2hard4you:
da würde ich schwer widersprechen - dann wäre der erste Snapshot genauso groß wie ein Image oder ein Clone - und
das isser nicht...


doch, isser.

Gruss, Thomas
Bitte warten ..
Mitglied: smartino
08.04.2013 um 21:54 Uhr
Zitat von Der-Phil:
Hallo!

Das ist ja mal geballtes Halbwissen hier...

Bei Xenserver enthält ein "EXPORTIERTER Snapshot" die gesamte VM, jedoch eben in dem "unsauberen" Zustand
zur Zeit des Snapshots.

Ein Snapshotbackup ist demnach genauso lauffähig, wie ein hart ausgeschalteter Server.

nicht, wenn man den Server vorher runterfährt

Unabhängig davon verträgt so mancher Server ein hartes Ausschalten gut. Bei älteren XenServers habe ich früher auf diese Weise im laufenden Betrieb zwecks Desaster Recovery Server abziehen können. Ab Xen 6.02 brauchts das ja nicht mehr.

Gruss, Thomas
Bitte warten ..
Mitglied: strobocom
09.04.2013 um 14:14 Uhr
Hallo,

-die VM lässt sich importieren!
-jedoch bekomme ich eine Fehlermeldung beim Start der VM schaue es mir heute abend wieder an und Maile dann die Fehlermeldung habe Sie gerade nicht hier.

Es ist ein Debian Lenny um das es sich handelt!

Vielen Dank schonmal!
Bitte warten ..
Mitglied: strobocom
09.04.2013 um 18:50 Uhr
So habe alles wieder durchgespielt:

Den Snapshot importiert dann wurde ein Template erstellt
dieses Template habe ich dann genutz um eine neu VM zu machen das hat geklappt.

Jetzt wollte ich die VM starten dann kommt folgender Fehler:

"The bootloader for this VM returned an error -- did the VM installation succeed? Error from Bootloader: no bootable disk"

Weis nur nich was ich noch probieren kann
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Xenserver
Xenserver 6.5 - Backup Server und VM auf NAS (1)

Frage von caspi-pirna zum Thema Xenserver ...

Windows Server
Snapshot auf einen Server spielen ohne die neuen Daten zu beschädigen? (1)

Frage von meisterluehrs zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...