Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Xorg-Treiber (ATI) Konfiguration will nicht

Frage Linux Linux Desktop

Mitglied: MagicJojo

MagicJojo (Level 1) - Jetzt verbinden

12.01.2009, aktualisiert 19:12 Uhr, 4286 Aufrufe, 4 Kommentare

Debian 5.0 (Lenny) Beta 2
ATI Radeon HD4850

Hallo,

ich habe folgendes Problem:
Wenn ich auf meinem System (siehe oben) die Treiber für meine Grafikkarte installieren möchte und in der Console "aticonfig --initial" eingebe, erscheint nach dem nächsten Reboot nur ein schwarzer Bildschirm, wenn gdm fertig geladen ist. Die Treiber habe ich von da: http://ati.amd.com/support/drivers/de/linux/linux-radeon.html

Ich habe auch schon versucht die xorg.conf im Verzeichnis /etc/X11/ manuell zu bearbeiten, damit mir 1680x1050px (22" Widescreen) dargestellt werden und auch OpenGL-Spiele laufen, aber bisher leider erfolglos.

Kann mir wer helfen? Für einen sinnvollen Rat wäre ich mehr als dankbar!

Grüße
MagicJojo
Mitglied: theton
12.01.2009 um 20:00 Uhr
Wie sieht denn die xorg.conf aus und ist das fglrx-Kernelmodul geladen?
Bitte warten ..
Mitglied: MagicJojo
12.01.2009 um 20:23 Uhr
Ich denke, es liegt am Kernelmodul. Habe schon des Öfteren simpel Kernel kompiliert, aber noch nie mit Modulen gearbeitet. Kann mir das wer erklären, wie ich fglrx einbaue und wo es sich befindet?

Danke
Bitte warten ..
Mitglied: theton
13.01.2009 um 14:25 Uhr
Das Kernel-Modul wird durch den Installer eigentlich mitinstalliert. Allerdings werden die Warnungen gern überlesen, die der Installer auswirft, wenn keine Kernel-Quellen/Header auf dem Rechner installiert sind, die notwendig sind um das Modul zu kompilieren. Also Kernel-Sources für den laufenden Kernel nach /usr/src/linux packen, die /boot/config-[kernelversion] nach /usr/src/linux/.config kopieren, in /usr/src/linux einmal 'make oldconfig' laufen lassen. Ggf. die Kernel-Header korrekt nach /usr/include verlinken. Danach den Installer nochmal laufen lassen.

Mitunter reicht es aber auch schon, wenn das Paket kernel-header-[installierte-kernelversion] installiert ist. Einfach mal ausprobieren.
Bitte warten ..
Mitglied: 64748
14.01.2009 um 10:41 Uhr
Guten Morgen zusammen,

noch ein Hinweis: das Skript aticonfig modifiziert die /etc/X11/xorg.conf und legt von der alten xorg.conf ein Backup an.
Mit dem Befehl: aticonfig --initial -f wird eine "Defaulteinstellung" konfiguriert (bei mir funktioniert das einwandfrei, und aticonfig gibt nur drei Zeilen mit einer kurzen Info aus).
aticonfig ohne Optionen gibt eine sehr ausführliche Beschreibung aus.

Markus
Bitte warten ..
Ähnliche Inhalte
Linux Desktop
Linux VGA Treiber für VIA (1)

Frage von bluepython zum Thema Linux Desktop ...

Windows Tools
gelöst ADSIEDIT - Wo Konfiguration? (1)

Frage von emeriks zum Thema Windows Tools ...

Server-Hardware
gelöst Fehlende Treiber! (11)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Internet
gelöst Gibts bei Dell keine Treiber mehr? (4)

Frage von Phill93 zum Thema Internet ...

Neue Wissensbeiträge
Windows 10

Heise Newsticker: Microsoft veröffentlicht das "Fall Creators Update

(8)

Information von Penny.Cilin zum Thema Windows 10 ...

LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (16)

Frage von sunics zum Thema Hosting & Housing ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...