Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

XP Dienste starten nicht, was tun?

Frage Microsoft Windows Systemdateien

Mitglied: Leuchtfeuer1

Leuchtfeuer1 (Level 1) - Jetzt verbinden

27.02.2012 um 18:26 Uhr, 4574 Aufrufe, 14 Kommentare

Hallo Ihr hoffentlich Wissenden,

ich nutze die Gunst der schweren Stunde, da nun auch auf mich ein mir unlösbares Problem einstürzt. Daher bitte ich um Hilfe.

Zum Sachverhalt:
Mehrere Leute nutzen ihre Remotedesktopverbindung, um auf einen Rechner mit XP-Pro zu gelangen. Das funktionierte bisher gut, und wie es immer so ist, bis es eben auf einmal nicht mher geht.

Dies habe ich zum Anlass genommen, um mir das Ereignisprotokoll vorzuknöpfen. Bin dort hinreichend fündig geworden.
Lange Rede kurzer Sinn, ich hab die "große" Reparatur mittel Install.-CD vorgenommen. Im Wesentlichen sind die Probleme jedoch weiterhin vorhanden:

Ereigniskennung 7023:
Der Dienst "6to4" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.

Der Dienst "Ias" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.

Der Dienst "Iprip" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.

Der Dienst "Irmon" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.

Der Dienst "NWCWorkstation" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.

Der Dienst "Nwsapagent" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.

Ereigniskennung 7022:
Der Dienst "Systemereignisbenachrichtigung" wurde nicht ordnungsgemäß gestartet.
-> Dienst ist jedoch gestartet.

Diese Dienste werden ja auch über den svchost.exe -k netsvcr gestartet, nur warum geht dies hier nicht, bei anderen, gestarteten Diensten funktioniert es ja offenbar (z.B. Computerbrowser).

Ich denke, das Problem liegt in der Registrierung. Sicher nur ein kleiner Handgriff, wenn man weiß wo. Chkdsk bereits ausgeführt,
Viren können wir auch ausschließen. Keine vorhanden (Kaspersky). Einstellungen daran wurden auch keine vorgenommen, nachdem RD lief.

Hoffe, ich habe nun alle wichtigen Information. Wenn Ihr noch was benötigt, sende ich es Euch gerne umgehend. Bin sehr an einer Lösung interessiert, da das Teil laufen muss und komplette Neuinstallation keine befriedigende Option ist.

Gruß Christian
Mitglied: DevTig
27.02.2012 um 20:48 Uhr
Hallo,

lassen sich auf dem System EXE-Dateien starten ?
Das liest sich so, als wären die .exe Zuordungen in der Registry defekt

Grüße
DevTig
Bitte warten ..
Mitglied: Leuchtfeuer1
27.02.2012 um 21:40 Uhr
Hallo DevTig,

andere Prozesse starten, ich kann auch ganz normal Programme starten. Also klappt das soweit mit den exe-files. Meintest Du das?

Gruß Christian
Bitte warten ..
Mitglied: DevTig
27.02.2012 um 23:06 Uhr
Ja das meine ich.

Probiere mal eine Reparatur-Installation vom SAP. Sollte es danach funktionieren - kannst Dir ja denken was dann auf Dich zukommt - viel arbeit.

Das liegt dann daran das die Rep.-Install von Windows die Registry wieder hergestellt hat ohne die installierten Programme einzubinden.

Grüße
DevTig
Bitte warten ..
Mitglied: Leuchtfeuer1
27.02.2012 um 23:32 Uhr
Ich glaub, jetzt stehe ich auf dem Schlauch - vom SAP reparieren? Ich hab´s nicht so mit Abkürzungen ;(

Ich habe als ersten Versuch mit sfv /scannow was zu erreichen. Hat nichts geändert. Dann habe ich versucht, den Fehler zu beheben, indem ich die Reparatur--Instal. von XP durchgeführt habe. Das gab einen Teilerfolg ->z.B. Prozess Computerbrowser lief danach wieder.

Der Rest an o.g. Prozessen lässt sich nach wie vor nicht starten, weder von Hand, noch automatisch.

ANMERKUNG: Für alle, die mal ihr XP reparieren, und das System danach hängt (man kann die Version nicht aktivieren), im abgesicherten Modus ohne Netz IE8 installieren. Danach fährt das System normal hoch. Das rauszufinden hat mich knapp 3 Studen gekostet...

Danke vorab

Christian
Bitte warten ..
Mitglied: DevTig
27.02.2012 um 23:54 Uhr
Zitat von Leuchtfeuer1:
... vom SAP reparieren? Ich hab´s nicht so mit Abkürzungen ;(
Ok war wohl etwas undeutlich.

Hast Du Software von der Firma SAP oder NetMeeting auf dem Rechner installiert ?

Wenn nicht solltest Du mal nach
Nwsapagent
googlen.
Könnte sein das sich ein Trojaner eingeschlichen hat.
Hier mal ein Link auf eines der Ergebnisse http://www.bleepingcomputer.com/startups/Nwsapagent.dll-16189.html
Bitte warten ..
Mitglied: Leuchtfeuer1
28.02.2012 um 00:04 Uhr
Das System ist eine XP-pro SP3 mit "aufgebohrten" Instanzen, also gleichsamen anmelden von 4 Benutzern möglich. Ein kleiner Windows-Server via XP.

Hab ganz normal die Win-CD in die Hand genommen und dann gings los. Einloggen zuvor zu dem Rechner ganz standard über dem Win-RemoteDesktop, ohne dass dort noch Zusatzsofware notwenig war.

Ping geht auch durch (DynDNS), daran liegt es also nicht.

Beim googlen bin ich auch nur auf Viren ect. Dinge gestoßen. Kann ich aber nicht bestätigen. Denke Kaspersky hätte sonst Alarm geschlagen (habe es auch vorher komplett durchlaufen lassen, da mein Verdacht als erstes darauf fiel), Hijackthis gibt mir auch nichts auffälliges aus und ein Nwsapagent-file gibt es auch nicht (wenn, wäre das wohl auch bei der Reparatur-Install über den Jordan gegangen).

Das offensichtliche habe ich wohl schon ausgelotet, denke ich, aber der Tip war trotzdem gut...hätte ja sein können...
Bitte warten ..
Mitglied: 60730
28.02.2012 um 00:12 Uhr
moin Mädelzz..
Das System ist eine XP-pro SP3 mit "aufgebohrten" Instanzen, also
(wenn, wäre das wohl auch bei der Reparatur-Install über den Jordan gegangen).

  • Brauche märr garnedd weidderredde...
Das offensichtliche habe ich wohl...
..übersehen?
Ich würde ja in die Bucht gehen EUR 169,90 +EUR 5,90 Versand für ne 2k3 std oder EUR 219,00 +EUR 6,00 Versand für ne 2k3R2 abdrücken
FDISK und neu, fettisch

Gruß
Bitte warten ..
Mitglied: DevTig
28.02.2012 um 00:16 Uhr
Kannst mal unter
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services
schauen.

Dort werden die meisten (98%) aller Dienste gestartet. Eventuell die Einträge für die Fehlerdienste
Ereigniskennung 7023:
Der Dienst "6to4" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.
Der Dienst "Ias" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.
Der Dienst "Iprip" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.
Der Dienst "Irmon" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.
Der Dienst "NWCWorkstation" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.
Der Dienst "Nwsapagent" wurde mit folgendem Fehler beendet:
Das System kann die angegebene Datei nicht finden.
manuell rauslöschen.
Danach einfach mal schauen ob der Rechner die Dienste eventuell anmäkelt. Wenn nicht auch gut

Und RDP geht wieder ?
Bitte warten ..
Mitglied: Leuchtfeuer1
28.02.2012 um 00:19 Uhr
Das Sytem lief doch bereits 2 Jahre ohne Probleme mit den "aufgebohrten" Instanzen. Das kann ja nicht die Lösung sein, jetzt alles über Bord zu werfen, was sich erprobt und bis jetzt bewährt hat. Ich denke, wenn ich den Rechner plätten würde, würde das wie vorher gehen, nur ist das echt ein Elend mit der ganzen Sicherein. Die Lösung ist sicher ganz einfach, wenn man weiß wie...
Bitte warten ..
Mitglied: 60730
28.02.2012 um 00:26 Uhr
du sei mir nicht böse, aber die Reihenfolge war doch laut deinen Zeilen diese...
  • Das funktionierte bisher gut, und wie es immer so ist, bis es eben auf einmal nicht mher geht.
  • Dies habe ich zum Anlass genommen, um mir das Ereignisprotokoll vorzuknöpfen. Bin dort hinreichend fündig geworden.
  • Lange Rede kurzer Sinn, ich hab die "große" Reparatur mittel Install.-CD vorgenommen. Im Wesentlichen sind die Probleme jedoch weiterhin vorhanden:

Und was lernst du daraus?
Irgendein Patch oder eine defkete Platte oder wtf war der Auslöser und das man ein normeles XP nur selten geschweige denn ein getrixtes Xp nicht mehr via Rep Install wieder frisch kriegt, das hast du sicherlich auch schon 1-2mal irgendwo gelesen (wenn du schon 3 Stunden googelst, wegen dem IE8 Thema...)

Mea culpa, wer nicht will der hat schon.
Bitte warten ..
Mitglied: Leuchtfeuer1
28.02.2012 um 00:34 Uhr
Das habe ich leider auch schon durchpflügt. Ich habe keine Ahnung, wo der Dienststart im Detail gereglt wird. Es ist nicht ein Dienst aus meiner Liste dort zu finden...(und die dort aufgeführten Dienste sind wirklich lang).

Ich finde die besagten Dienste nur als Zusammenfassung in
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\svchost ->netsvcs. Netsvcs wird aber auch nicht unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services geregelt. Ich bekomm langsam das Gefühl, dass ich zu blöd bin zum suchen



.
Bitte warten ..
Mitglied: DevTig
28.02.2012 um 00:43 Uhr
Naja dann

...kann ich mich nur TimoBeil anschliesen.
Deckel zumachen und kräftig spülen. Soll heißen => Datensicherung machen und das Ding neu hochziehen.
Ansonsten verbrennst Du locker nochmal 10 Stunden mit Fehlersuche.

Um das ganze mal in Geld umzurechnen
Bei 10 Stunden mit einem niedrigen Ansatz von nur 50 Euro/Stunde kannste mal locker Win 2K3R2 kaufen und installieren.


Grüße
DevTig
Bitte warten ..
Mitglied: Leuchtfeuer1
28.02.2012 um 01:00 Uhr
Oh man, genau das wollte ich vermeiden...aber vielleicht die beste und sauberste Lösung. Wird viel Kraft und Nerven kosten....hätte es lieber einfacher gehabt

Mal schauen, vielleicht funktioniert die sys-wiederherstellung ja und der Dienst ist nicht mehr betroffen. Einen Versuch ist es wert. Ansonsten muss ich wohl die Kröte schlucken.
Bitte warten ..
Mitglied: Leuchtfeuer1
28.02.2012 um 14:40 Uhr
Hab die Dienst, die wir eindeutig als nicht benötigt identifizieren konnten deaktiviert:
- ias deaktiviert
- irmon deaktiviert
- nwc workstation deaktiviert

- nwsapagent weiterhin auto, aber kann nicht gestartet werden, gleiches gilt für las und iprip

Der Dienst für die Win-Firewall ging ja nach der Reparatur wieder und wurde deaktiviert damit Kapsersky wieder den job macht.

Dann noch die Instanzen erweitert (termsrv.dll) und alles ist wie vorher von der Funktionabilität.

Ping läuft auf die ip und damit der RDP auch wieder...wo der Haken nun konkret lag, weiß wohl nur Windows...

Einige Fehlermeldungen bleiben trotzdem im Protokoll. Ich denke, solange hier keine weiteren Einschränkungen dadurch auftauchen bleibt das so. Der Rechner wird ohnehin dieses Jahr noch ersetzt, solange muss er durchhalten um die Arbeit nicht 2x zu haben.
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (29)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (20)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...