Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

-XP- Netzwerkumgebung braucht ewig zum laden..

Frage Microsoft Windows Netzwerk

Mitglied: seim-mehrals6zeichen

seim-mehrals6zeichen (Level 1) - Jetzt verbinden

09.10.2008, aktualisiert 12.10.2008, 11957 Aufrufe, 7 Kommentare

Mein Rechner braucht sehr lange um die Arbeitsgruppe über Explorer > Netzwerkumgebung> Gesamtes Netzwerk> Microsoft Windows Netzwerk usw zu finden. Danach braucht er wieder so lange um die Rechner in dieser Arbeitsgruppe anzuzeigen..

Hi,
also bei mir habe ich den "Bug", dass Windows zum anzeigen der PCs/Gruppen in der Nethood einfach nur ewig braucht! Allerdings war dies vor einiger Zeit nicht der Fall - da ging es auf Anhieb..

Also mein Netzwerk sieht so aus, dass ich ein Router habe; 4 PCs/Laptops und einen Debian-"Server" wobei der nicht viel mehr zu tun hat als per WakeOnLAN aufzuwachen und per Samba jede Menge Speicher zur Verfügung zu stellen.

Das Problem habe ich bisher nur bei meinem Laptop näher untersucht. PCs über die IP/Name lassen sich sofort öffnen ("\\server"), aber in der Netzwerkumgebung ist der PC dann jedesmal kurz vor'm Absturz.
-Der Firewall Dienst ist an und die Firewall aktiv, Freigaben gehen auch - dauert nur eben eine Weile in der Netzwerkumgebung
-Ein gewisser Dienst "WebClient" wurde auf Hinweis eines Freundes abgeschaltet - brachte jedoch keinen Erfolg und auch keinen größeren Misserfolg, daher ist er immernoch aus
Das witzigste ist allerdings, dass ich in VMware ein Windows XP installiert habe, das per Bridged-Network betrieben wird und da geht das ganze ohne Probleme trotz gleicher Protokolle (QoS-Paketplanter deaktiviert, IPX hinzugefügt)..

Ich freue mich schon auf eure Antworten, Gruß
Seim


P.S. Evtl. kann mir noch jemand sagen wie man sich in einer Freigabe "umloggen" kann, also auf einen anderen User switchen - Mein Lappi loggt sich auf dem Media Center PC nämlich immer mit Gast ein (und das Konto muss auch aktiv bleiben für alle anderen User die darauf zugreifen wollen), aber ich brauche dort Adminzugriff (auf "\\KellerMCE\c$")
Mitglied: stillnameless
09.10.2008 um 14:42 Uhr
Also als erstes würde ich mal direkt bei allen Clients die automatische Suche nach Freigaben ausstellen (Explorer - Extras - Ordneroptionen - Ansicht - "Automatisch nach Netzwerkordnern und Druckern suchen").
Des weiteren kannst du auch direkt bei allen evtl. vorhandenen Geräten (Router etc.) UPnP ausstellen. Danach sollte das eigentlich ohne Probleme tun =).

Mit dem "umloggen" - ist auch ganz einfach. Verbinde ein Netzwerklaufwerk zu der Freigabe - dort steht dann auch direkt "mit anderem Benutzernamen anmelden"...


Gruss & viel Glück =)
Bitte warten ..
Mitglied: seim-mehrals6zeichen
09.10.2008 um 17:40 Uhr
Die automatische Suche ist bereits ausgeschaltet und das UPnP will ich nicht abschalten, da ich hier ein paar Programme habe die darüber Ports öffnen. Außerdem geht es ja per VMware und früher (wann genau weis ich nicht) ging es auch mal bei angeschaltetem UPnP..
Bitte warten ..
Mitglied: aqui
10.10.2008 um 01:14 Uhr
UPnP ist auch Unsinn und hat damit rein gar nichts zu tun ! Das sollte man aus Sicherheitsgruenden auch richtigerweise immer ausgeschaltet lassen !!
Ohne WinS oder DNS ist dieses Verhalten durchaus normal, denn es basiert auf einem Broadcast Prinzip. Windows kaspert immer einen sog. Master Browser aus der sich alle per Broadcast im Netz bekannt gemachten Resourcen merkt und erst dann werden sie in der Netzumgebung dargestellt.
Wenn du nun diesen Master Browser abschaltest geht das alles wieder von vorne los.
Dieser Prozess kann laut MS Knowledgebase bis zu 20 Minuten dauern also ist das durchaus normales Verhalten was du siehst...

Um das abzustellen solltest du alle deine Rechner mit ihren Systemnamen und ihrer IP in die Datei hosts oder lmhosts eintragen !!
Diese Datei findest du unter c:\windows\system32\drivers\etc\ und sie ist selbsterklaerend wenn du sie editierst !!
In der Regel reicht IP und Name. Wenn du alle Rechner darin aufgenommen hast sollte es keine Wartezeit mehr geben !!
Bitte warten ..
Mitglied: seim-mehrals6zeichen
10.10.2008 um 12:45 Uhr
Du kannst mir doch nicht erzählen, dass zur gleichen Zeit ein "VMware PC", der selbstverständlich auch später angeschaltet wurde als der Host Rechner, die Netzwerkumgebung >>instant<< und ich möchte betonen INSTANT/SOFORT/innerhalb von 1-2sek lädt während der Host Recher bzw. mein Laptop fast abkackt und nach erst nach 1min die Arbeitsgruppe anzeigt und für die Rechner in besagter Arbeitsgruppe noch einmal solange..
Bitte warten ..
Mitglied: aqui
10.10.2008 um 22:07 Uhr
Vielleicht solltest du das lesen um es zu verstehen:
http://support.microsoft.com/kb/288801/de
Bitte warten ..
Mitglied: datasearch
11.10.2008 um 09:07 Uhr
Aqui hat vollkommen recht. Ich möchte nur noch einige Ergänzungen machen, die dir evt. weiterhelfen könnten.

Dieses Verhalten ist bei aktivem NetBIOS über TCP/IP (NetBT) völlig normal, wenn folgende Dinge zutreffen:

  1. Du verwendest WindowsXP mit aktivem Computerbrowser (Default)
  2. Du hast keinen Windows-Server (egal welcher) im Netzwerk
  3. Dein Samba auf dem Debian-Server ist mit einem OS-Level kleiner als 10 Konfiguriert
  4. Dein Samba-Server wurde nicht mit den Optionen "local master = yes", "preferred master = yes", "domain master = yes", "wins support = yes" konfiguriert.
  5. Deine PC´s haben nicht den Samba-Server als WINS-Server eingetragen.

Windows verwendet per Default folgende Methode zur Namensauflösung in Netzwerken.

  1. prüfung des lokalen Cache nach dem Namen oder Netzwerk (Die Dateien LMHOSTS und HOSTS werden beim starten des Computers in den Cache geladen)
  2. Abfrage beim lokalem WINS Server nach dem Namen oder dem Netzwerk
  3. Broadcast an das Netzwerk und suche nach dem "MasterBrowser". Kann ca. 30sec dauern.
  4. Kopieren der Browserliste des Masterbrowsers
  5. Abfrage des Namens aus der lokalen Browserliste

Das ganze kannst du in einem Netzwerksniffer sehr gut beobachten. Du kannst dein Windows-Netzwerk extrem beschleunigen, wenn du auf dem Samba den WINS-Server aktivierst und auf allen Clients den WINS-Server unter den TCP/IP Einstellungen konfigurierst. Zudem kannst du noch etwas herausholen, indem du dem Samba erlaubst, immer den lokalen Masterbrowser zu bekommen "local master = yes", "preferred master = yes". Dann versuchen die Clients nämlich nicht alle paar Stunden ihren MB neu auszuhandeln.

Anmerkung:
Aufgrund der sehr schlechten Performance und ineffizienz dieses Protokolls, deaktiviert man NetBT in größeren Netzwerken eigentlich immer. Wenn 100 Rechner um die Vorherrschaft der Browserliste kämpfen, hast du 30% Broadcast-Traffic auf einem 100MBit-Netzwerk. Bei 300 Rechnern in einem Segment, kann das auch schonmal das komplette 10/100er Netzwerk auslasten.
Bitte warten ..
Mitglied: seim-mehrals6zeichen
12.10.2008 um 12:25 Uhr
Das ist mal eine Erklärung mit der man was anfangen kann! Danke an euch beide..

Ich werd' mir demnächst überlegen wie ich das Problem lösen werde.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 10
Drucker braucht ewig. Win 10 und Netzwerkdrucker (7)

Frage von killtec zum Thema Windows 10 ...

Windows Netzwerk
W7 TCP NDIS problem - Netzwerk braucht ewig zum vollständigen Start (4)

Frage von spiderx zum Thema Windows Netzwerk ...

Webbrowser
gelöst Google Geschäftsbedingungen laden ewig (5)

Frage von JensDND zum Thema Webbrowser ...

Hyper-V
gelöst Bestehende XP-Installation mit Hyper-V virtualisieren (30)

Frage von fox14ch zum Thema Hyper-V ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...