Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

XP Unattended läuft nicht korrekt

Frage Microsoft Windows Installation

Mitglied: Candyman1985

Candyman1985 (Level 1) - Jetzt verbinden

13.11.2008, aktualisiert 27.11.2008, 5247 Aufrufe, 11 Kommentare

Hallo,

mein letztes Problem bzgl. der unattended Installation von XP.

Eine automatische Partitionierung erfolgt mittels diskpart über WinPE. Soweit so gut (möchte zwei Partitionen haben).

Mein Script sieht so aus:

@ECHO OFF
SET AnswerFile=R:\i386\winnt.sif
SET SetupFiles=R:\i386

diskpart /s %systemdrive%\diskpart.txt

%SetupFiles%\winnt32.exe /unattend:%AnswerFile% /makelocalsource

ECHO Ende!
exit

Die Windows-Installation startet bei T-59. Er kopiert Dateien. Startet neu und landet in dieser "DOS-Oberfläche", scannt C:\, kopiert Dateien und startet neu.

JETZT das Problem!

Er kopiert mir nicht die Daten aus $OEM$. Er greift zu keinem Zeitpunkt mehr auf die Installationsscripte zu.

Merkwürdiger Weise muss ich bei %SetupFiles%\winnt32.exe /unattend:%AnswerFile% /makelocalsource die Antwortdatei mit angeben. Normalerweise erfolgt eine automatische Einbeziehung.

Ich hoffe einer von Euch hat eine Idee, da es ziemlich eilig ist.

VG
Matthias
Mitglied: Fiasko
13.11.2008 um 08:40 Uhr
Moin Matthias

Kann dir zwar nicht konkret zu deinem Problem helfen, weil ich bei meiner Unattended-Installation einfach nur eine Partition erstellen lasse und ich ganz abgesehen davon mittlerweile eher zu einer RIS / MDD-Lösung tendiere, aber vielleicht kann dir hier konkreter geholfen werden.

http://www.windows-unattended.de/forum/

Die sind dort ziemlich fit was das unbeaufsichtigte installieren angeht.



P.S.

Was mir jetzt gerade doch noch so auffällt ... deine "cmdlist.txt" existiert noch?
Bitte warten ..
Mitglied: Candyman1985
13.11.2008 um 08:46 Uhr
Danke soweit erst mal.
Ja, die cmdlist.txt existiert noch. Die ist unter dem Ordner $OEM$. Alle dort enthaltenden Ordner sollten ja auf die Platte kopiert werden, aber dies erfolg ja schon gar nicht.
Bitte warten ..
Mitglied: Fiasko
13.11.2008 um 08:49 Uhr
Was hast du denn groß im $OEM$-Ordner drin?

Nur Treiber?

Zur not regel das kopieren von z.B. Verknüpfungen über die "runonceex.cmd"
Bitte warten ..
Mitglied: Candyman1985
13.11.2008 um 08:50 Uhr
In dem Ordner befinden sich Treiber (Ordner drivers) und Programme (Ordner apps und postinstall).
Die runonceex.cmd wird ja auch nicht ausgeführt. Nichts aus der cmdlines.txt wird abgearbeitet.
Bitte warten ..
Mitglied: Fiasko
13.11.2008 um 09:00 Uhr
Treiber hab ich (mittlerweile) via NLite eingebunden, da landen die Treiber gleich in der "drivers.cab" was ich komfortabler finde, da man gleich für Rechner aus verschiedenen Serien, also durchaus mit unterschiedlicher Hardware (wir haben hier nur Hp-Rechner) hat.

Machst du das eigentlich für deinen bzw. einen Rechner oder hast du vor dass Ganze auf mehrere Rechner anzuwenden?
Wenn du bzw. dein Rechner in einer Domäne bist würde ich die Installation der Software via AD / Gruppenrichtlinien vorschlagen.


hmm magst du mal deine winnt.sif posten?
Bitte warten ..
Mitglied: Candyman1985
13.11.2008 um 09:04 Uhr
Das ist für 10+ Notebooks gedacht. Diese hängen nicht in einer Domäne.

Die ganze Installation hat soweit perfekt funktioniert, als es noch net über die WinPE-Oberfläche ging. Diese nutze ich auch nur, da ich zwei Partitionen voll automatisch haben möchte.

;SetupMgrTag
[Data]
AutoPartition=1
MsDosInitiated="0"
UnattendedInstall="Yes"

[Unattended]
UnattendMode=FullUnattended
OemSkipEula=Yes
OemPreinstall=Yes
TargetPath=\WINDOWS
UnattendSwitch=yes
Repartition=No
UseWholeDisk=No
WaitForReboot=No
OemPnPDriversPath="drivers00_modem;drivers01_wlan;drivers02_lan;drivers03_extut;drivers04_smar
t;drivers05_device1;drivers06_device2;drivers07_chip1;drivers08_chip2;drivers09_
card"
DriverSigningPolicy=Ignore

[GuiUnattended]
AdminPassword=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
EncryptedAdminPassword=Yes
OEMSkipRegional=1
TimeZone=110
OemSkipWelcome=1
ProfilesDir="D:\Dokumente und Einstellungen\"

[UserData]
ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
FullName="Land Niedersachsen"
OrgName="Zentraler IT-Betrieb -FVT StA-"
ComputerName=Staatsanwalt

[RegionalSettings]
LanguageGroup=1
Language=00000407

[Identification]
JoinWorkgroup=STAATSANWALTSCHAFT

[Networking]
InstallDefaultComponents=Yes

[Components]
msmsgs=off
msnexplr=off
freecell=off
hearts=off
minesweeper=off
pinball=off
solitaire=off
spider=off
zonegames=off
chat=off
oeaccess = off

[SetupParams]
UserExecute="%SystemDrive%\PostInstall\XPinstall.exe"
Bitte warten ..
Mitglied: Fiasko
13.11.2008 um 09:14 Uhr
AutoPartition=1 ?

Bin mir nicht mehr ganz sicher was der Befehl genau bewirkt, aber automatisch möchtest du doch eigentlich nicht oder zumindest nich automatisch vom Windows-Setup her.

Aber davon ab hats leider wenig mit deinem Problem zu tun denke ich.
Da du geschrieben hast das es ziemlich eilig ist ... mag zwar doof klingen aber mach die Partitionierung doch von Hand?
Das geht mit Sicherheit schneller als eine Lösung für das Problem zu finden. ;)
Bitte warten ..
Mitglied: Candyman1985
13.11.2008 um 09:20 Uhr
Ja natürlich geht es mit der Hand und so wie es gerade ausschaut, habe ich noch weniger Zeit als gedacht und ich werde es jetzt wirklich mit der Hand auf die alte Variante machen müssen.

Eine Lösung hätte ich doch ganz gerne für die Zukunft.

PS: AutoPartition=1 sagt aus, dass Windows sich auf irgendeine Partition installiert. Bei 0 muss man dies selber auswählen.
Bitte warten ..
Mitglied: Fiasko
13.11.2008 um 09:23 Uhr
Glaub ich gern, aber das mit dem partitionieren ist bislang meines erachtens nach eh nicht sonderlich glücklich bzw. komfortabel gelöst, deswegen hab ich mir den Teil auch gleich gespart.

Hast du schon auf der windows-unattend-Seite ein paar Ideen gefunden?
Bitte warten ..
Mitglied: Candyman1985
23.11.2008 um 19:03 Uhr
Hallo,

außer das meine winnt.sif ganz gut aussieht, kam es noch zu keiner Lösung. Evtl. hab ich nächste Woche wieder Zeit mich damit zu beschäftigen. Aber immerhin, bis auf die automatische Partitionierung am Anfang, läuft jetzt wirklich ALLES unattended ab^^
Bitte warten ..
Mitglied: Candyman1985
27.11.2008 um 10:45 Uhr
Jetzt läuft es... Mein Problem war, bei einer "normalen" XP Unattended liegt der Ordner $OEM$ auf einer Ebene mit dem I386-Ordner. Bei der Erstellung einer Setup-Routine mit dem AIK, muss $OEM$ jedoch UNTER I386 sein.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Voice over IP
Mysterium Fax über VoIP - was man tun kann, damit es besser läuft (7)

Anleitung von LordGurke zum Thema Voice over IP ...

Linux
SW-Verteilung und unattended OS Installation

Frage von winlin zum Thema Linux ...

Exchange Server
Exchange 2013 Health Mailbox läuft voll (4)

Frage von bootloader zum Thema Exchange Server ...

Windows Server
gelöst Win10 Deployment mit unattended.xml - DiskConfiguration kann nicht analysiert werden

Frage von JiggyLee zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...