Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Yast2 lässt sich nicht bedienen openSuse 12.1

Frage Linux Suse

Mitglied: alex-tech

alex-tech (Level 1) - Jetzt verbinden

22.05.2013 um 15:22 Uhr, 1967 Aufrufe, 3 Kommentare

Hallo,

ich habe openSUSE 12.1 (x86_64) im Textmodus, ohne Desktop, installiert.

Über Yast habe ich openssh nachinstalliert, wieder deinstalliert und den Yast2-SSh-Server installiert.

Seither kann ich Yast nicht mehr bedienen. D.h. ich kann das Yast2 Control Center starten, will ich aber ein Modul auswählen passiert garnichts.

Wenn ich Yast über einen Befehl "yast lan" starte bekomme ich die Meldung:

01.
Can't locate Config.pm in @INC (@INC contains: /y2update/modules /root/.yast2/modules /usr/share/YaST2/modules /usr/lib/perl5/site_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.12.1 /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.1 /usr/lib/perl5/5.12.1/i586-linux-thread-multi /usr/lib/perl5/5.12.1 .) at /usr/lib/perl5/5.12.1/diagnostics.pm line 195. 
02.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.12.1/diagnostics.pm line 195. 
03.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi/YaST/YCP.pm line 119. 
04.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.12.1/i586-linux-thread-multi/YaST/YCP.pm line 119. 
05.
Compilation failed in require at /usr/share/YaST2/modules/URLRecode.pm line 16. 
06.
BEGIN failed--compilation aborted at /usr/share/YaST2/modules/URLRecode.pm line 16. 
07.
Compilation failed in require. 
08.
BEGIN failed--compilation aborted.
Habe auch schonmal google bemüht, kam damit aber nicht weiter.

Kann mir jemand weiterhelfen?

Vielen Dank
Mitglied: hmarkus
22.05.2013 um 17:07 Uhr
Hallo,

ich hab von Suse keine Ahnung.

Ist Suse standardmäßig als Multilib-System installiert? also so, dass auf einem 64bit System auch 32bit Binaries ausgeführt werden können?
Du schreibst, dass Du die x86_64 Version installiert hast. Hier bei mir liegen auf dem 64bit System alle Perlmodule in /usr/lib64/perl/.
Es sieht so aus, also sei auf Deinem System die 32bit Version von Perl installiert.

Markus
Bitte warten ..
Mitglied: Cthluhu
22.05.2013, aktualisiert um 17:39 Uhr
Hi,

Da scheint was mit den dependencies beim heruminstallieren kaputt gegangen zu sein. Hatte ich auch mal mit einer älteren Suse (12.1 gilt seit Mai als veraltet; 12.3 wäre aktuell), als ich aus versehen ein Update abgebrochen hab.
Versuch mal mit
01.
  zypper se ssh

rauszufinden wie die ssh-Pakete heißen die du drauf hast (links steht ein "i" bei den grade installierten Paketen). Mit
01.
  sudo zypper rm $PAKETNAME 

kannst du die händisch deinstallieren und mit
01.
  sudo zypper in $PAKETNAME 

wieder installieren. Dabei sollten die Abhängigkeiten (wie z.B. fehlende perl module) aufgelöst werden.

mfg

Cthluhu

Edit: code-tags eingefügt
Bitte warten ..
Mitglied: alex-tech
23.05.2013 um 10:56 Uhr
Super das wars.

Vielen Dank.
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows Server
gelöst Exchange HyperV Prozessorlast (19)

Frage von theoberlin zum Thema Windows Server ...

Windows Server
Server mit Netzwerkaussetzern (18)

Frage von SarekHL zum Thema Windows Server ...

LAN, WAN, Wireless
gelöst Batchdatei um einen Proxy einzustellen (14)

Frage von CrystalFlake zum Thema LAN, WAN, Wireless ...

Netzwerke
Vorschlag Hotelverkabelung (14)

Frage von FA-jka zum Thema Netzwerke ...