Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

ZÄHLENWENN Funktion in nicht zusammenhängenden Bereichen

Frage Microsoft Microsoft Office

Mitglied: freecube

freecube (Level 1) - Jetzt verbinden

21.07.2008, aktualisiert 08:57 Uhr, 13134 Aufrufe, 4 Kommentare

Ich versuche in einer Excel Tabelle (Excel 2002) die ZÄHLENWENN Funktion in einem nicht zusammenhängenden Bereich zu benutzen. Dieses scheint allerdings nicht zu funktionieren.
Die Tabelle sieht folgendermaßen aus:

Zeile A1 bis W1 mit Kalenderwochen ausgefüllt
Zeile A2 bis W2 alternierend "Früh" und "Spät"
Zeile A3 bis W3 Buchstaben wie "S", "N", "R" und "X"


Ich möchte gerne herausfinden, wie oft ein Mitarbeiter in der Frühschicht gearbeitet hat und möchte dazu nur den Buchstaben "X" auswerten. Die anderen Buchstaben dürfen nicht erkannt werden. Wenn ich die ZÄHLENWENN Funktion auf den gesamten Bereich anwende funktioniert sie einwandfrei, allerdings bekomme ich auch die Spätschichten gezählt (Bsp. =ZÄHLENWENN(A3:W3;"x") )

Möchte ich nur die Frühschichtzellen auswerten (Bsp. =ZÄHLENWENN(A3;C3;E3;G3;I3;K3;M3;O3;Q3;S3;U3;W3;"x") bekomme ich eine Fehlermeldung. Wahrscheinlich funktioniert die Funktion so nicht.

Vielleicht hat jemand eine Idee, was verkehrt ist oder wie man mein Problem auf eine andere Art lösen könnte.

Gruß

freecube
Mitglied: SarekHL
21.07.2008 um 08:07 Uhr
Naja, spontan fällt folgendes ein:

=ZÄHLENWENN(A3;"x")+ZÄHLENWENN(C3;"x")+........

Ist natürlich etwas aufwendig, aber da ZÄHLENWENN eben im Gegensatz zu manch anderer Funktion nur mit einer Matrix arbeitet, sehe ich keinen anderen Weg
Bitte warten ..
Mitglied: freecube
21.07.2008 um 08:19 Uhr
Hallo SarekHL,

tja, manchmal kommt man auf die einfachsten Lösungen nicht!! Ist zwar wirklich etwas aufwendiger aber zumindest ein gangbarer Weg!!

Vielen Dank für die spontane Hilfe und eine angenehme Woche noch!!

Gruß

freecube
Bitte warten ..
Mitglied: kristov
21.07.2008 um 08:26 Uhr
Hallo,
ich bin von da: http://www.administrator.de/Z%C3%84HLENWENN_abh%C3%A4ngig_von_2_Bedingu ... nach da: http://excelformeln.de/formeln.html?welcher=273 gekommen und hab das auf Dein Beispiel umgemünzt:

=SUMME((A3:W3="x")*(A2:W2="Früh"))

Nach dem Eingeben der Formel in die Zelle, STRG+SHIFT+ENTER drücken, dann wird's richtig erkannt (kriegt so geschwungene Klammern rundherum)

Hoffe, das ist einigermaßen verständlich

lg,
kristov
Bitte warten ..
Mitglied: freecube
21.07.2008 um 08:57 Uhr
Hallo kristov,

wunderbar!! Ist vom Aufwand her noch viel einfacher und funktioniert sogar

Vielen Dank für diesen Tip!!

Gruß

freecube
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Powershell Funktion Ausgabe in Datei (2)

Frage von schicksal zum Thema Batch & Shell ...

Hyper-V
gelöst Nach Updateinstallation - Hyper-V-Replikation stellt die Funktion ein (7)

Frage von DerWoWusste zum Thema Hyper-V ...

Microsoft Office
gelöst Formel-Funktion in Word produziert unsaubere Resultate bei Indizes (1)

Frage von Yauhun zum Thema Microsoft Office ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (52)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (25)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...