Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zählenwenn bereich einen bestimmten wert auffeiste?

Frage Microsoft Microsoft Office

Mitglied: DerParte

DerParte (Level 1) - Jetzt verbinden

18.10.2007, aktualisiert 19.10.2007, 7209 Aufrufe, 7 Kommentare

Hallo!

Ich habe ein Problem.


Ich möchte das Excel in den Zellen A1 bis A13 voll gendes ausgibt:

Zuerst soll verglichen werden in welchen zellen der spalte E steht und dann soll gezählt werden in welchen zellen der spalte d dazu werte eingetragen sind.

In der Spalte E stehen die Zahlen 0 bis 12.
Mitglied: 8644
18.10.2007 um 17:05 Uhr
Hallo DerParte,

ich bin mir ziemlich sicher, dass es für dein Problem eine simple Lösung gibt.
Genauso sicher bin ich mir aber auch, dass es wenige Leute gibt, die dein Problem verstehen!
Lies dir deinen Text bitte noch mal (laut) durch und passe ihn dann so lange an, bis du ihn selber verstehst!

Wenn dir das nicht gelingt, poste bitte ein Beispiel von dem was du hast und von dem was du möchtest!

Psycho
Bitte warten ..
Mitglied: DerParte
19.10.2007 um 06:05 Uhr
Ich meine folgendes:

=ZÄHLENWENN(Bereich E1-E200 = 1; ANZAHL(D1:D200);"") Aber das geht nicht.

Es soll also geschaut werden wo im Bereich E1-E200 die Zahl 1 steht und dann soll gezählt werden wo im Bereich D1-D200 überall etwas drin steht.
Bitte warten ..
Mitglied: 8644
19.10.2007 um 07:17 Uhr
Moin,

ich glaube, verstanden zu haben! Nur der Effekt erschließt sich mir noch nicht.
Du willst also quasi die Anzahl der Zeilen erhalten, in denen in Spalte E eine 1 steht und dazu in Spalte D zusätzlich ein beliebiger Wert bzw. Text?
Also zum Beispiel so:

DE
A3
7
F1
S4
1
5
G7
A1
2

Würde hier also 2 ergeben, da ich zwei Zeilen habe, in denen beide Bedingungen erfüllt sind.

Die Formel könnte so aussehen:
01.
=SUMME(UND(ZÄHLENWENN(E1:E200;1))*(ISTTEXT(D1:D100)))
Achtung, hierbei handelt es sich um eine Array-Formel, deren Eingabe und Bearbeitung du jedesmal mit [Strg] + [Shift] + [Enter] abschließen mußt!
Dadurch entstehen um die Formel geschweifte Klammern!
Also:
01.
{=SUMME(UND(ZÄHLENWENN(E1:E200;1))*(ISTTEXT(D1:D100)))}
Psycho
Bitte warten ..
Mitglied: bastla
19.10.2007 um 10:04 Uhr
... wobei auch
01.
=SUMME((E1:E200=1)*(D1:D200<>""))
genügen würde.

Auch diese Formel ist eine Array-Formel und daher entsprechend Psycho Dad's Hinweis zu behandeln.

Grüße
bastla
Bitte warten ..
Mitglied: 8644
19.10.2007 um 10:08 Uhr
@bastla:

keine Ahnung, warum ich es immer so kompliziert machen muß!

Im speziellen Fall könnte es aber daran liegen, dass es schon so kompliziert war, das Problem zu durchschauen

Psycho
Bitte warten ..
Mitglied: bastla
19.10.2007 um 10:48 Uhr
@psycho

Im speziellen Fall könnte es aber daran liegen, dass es schon so kompliziert war, das Problem zu durchschauen
Kein Widerspruch - ich hatte schon angenommen, es wäre ein Lückentext geplant gewesen (... in welchen zellen der spalte E ...................... steht ...) und gerätselt, was da wohl hin sollte.

Grüße
bastla
Bitte warten ..
Mitglied: DerParte
19.10.2007 um 18:59 Uhr
Nabend, vielen dank für die zahlreichen antworten und tricks.

Bastla deine formel wars.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Bestimmten Bereich einer Textdatei ausgeben mittels Batch (10)

Frage von Django.Durano zum Thema Batch & Shell ...

Batch & Shell
gelöst Wie speichere ich von einer "Grundbatchdatei" einen bestimmten Wert? (5)

Frage von IchBins01000010 zum Thema Batch & Shell ...

Neue Wissensbeiträge
LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte