Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zählenwenn mit3 Kriterien davon 2 Datumskriterien

Frage Microsoft Microsoft Office

Mitglied: Ruesseltier

Ruesseltier (Level 1) - Jetzt verbinden

27.02.2009, aktualisiert 13:36 Uhr, 11747 Aufrufe, 7 Kommentare

Hallo,
ich habe eine Tabelle mit folgenden Beispielwerten:
Spalte D Spalte E
Soll-Termin IST-Termin
_____________________
01.05.2008 30.05.2008
04.05.2008 26.06.2008
08.05.2008 30.05.2008
10.05.2008 25.07.2008
10.05.2008
10.05.2008
10.05.2008
10.05.2008 10.10.2008
18.05.2008 07.05.2008
29.05.2008
06.06.2008 26.08.2008


Ich möchte jetzt rausbekommen wieviele SollTermine im Bereich 10.5.2008 bis 18.05.2008 liegen
Dann weiter
- Bei wievielen die Spalte E leer ist
- Bei wievielen die Spalte E im gleichen Zeitraum liegt (10.05.2008 bis 18.05:2008)

Iche gehe Schrittweise an das Problem, doch schon beim ersten Punkt, wieviele SollTermien in dem Zeitraum liegen, scheitere ich, mit folgender Abfrage:
=SUMMENPRODUKT((D2:D11>="10.05.2008")*(!D2:D11<="18.05.2008"))
Als ergebnis bekomme ich hier 0

Wer kann helfen ?
Vielen Dank.

Ich nutze Excel 2003
Mitglied: Minion
27.02.2009 um 13:34 Uhr
Mit ZAEHLENWENN ist das nicht so einfach, aber:

Frage doch die Sollterminspalte ab und baue eine Ergebnisspalte auf:

=WENN(UND(B3>=$B$15;B3<=$B$16);B3;""), hier B3 der erste Wert der Spalte und in B15 steht der 10.05.08, in B16 der 18.05.08.

Es werden nur die Werte übernommen, die im Bereich liegen, ansonsten bleibt die Zelle leer.
Dann kannst Du über den Berech mit ANZAHL() die Werte ermitteln.

Bei IST-Terminen genau so.

=ANZAHLLEEREZELLEN(Bereich) gibt die Leerzellen zurück.

OK?
Bitte warten ..
Mitglied: Ruesseltier
27.02.2009 um 13:49 Uhr
Gibt es eine elegeante Möglichkeit ohne diesen Hilfsspalten ?
Bitte warten ..
Mitglied: bastla
27.02.2009 um 14:41 Uhr
Hallo Ruesseltier!

Mit Array-Formeln der Art
=SUMME(WENN(D2:D11>=B15;1;0)*WENN(D2:D11<=B16;1;0))
bzw (für Wert aus D und Wert aus E im angegebenen Zeitraum)
=SUMME(WENN(D2:D11>=B15;1;0)*WENN(D2:D11<=B16;1;0)*WENN(E2:E11>=B15;1;0)*WENN(E2:E11<=B16;1;0))
benötigst Du nur eine Zelle.

Die Eingabe (und jede Änderung) einer solchen Formel ist mit der Tastenkombination Strg+Umsch+Enter abzuschließen. Dass die Formel richtig übernommen wurde, kannst Du (außer am Ergebnis ) daran erkennen, dass sie in der Bearbeitungszeile zwischen geschweiften Klammern {} dargestellt wird.

Grüße
bastla
Bitte warten ..
Mitglied: Minion
27.02.2009 um 15:46 Uhr
Fein, Man lernt immer was Neues:
{=SUMME(WENN(D2:D11>=B15;1;0)*WENN(D2:D11<=B16;1;0))} das ist schon Klasse ...
Aber:
{=SUMME(WENN(D2:D11>=B15;1;0)*WENN(D2:D11<=B16;1;0)*WENN(E2:E11>=B15;1;0)*WENN(E2:E11<=B16;1;0))}
bringt ja nur ein Ergebnis, wenn in einer Zeile von Sollspalte und Istspalte der Datumswert im Bereich liegt.
War das gefordert?
Gruss
Bitte warten ..
Mitglied: bastla
27.02.2009 um 16:12 Uhr
@Minion
War das gefordert?
Kann ich aufgrund der Fragestellung
- Bei wievielen die Spalte E im gleichen Zeitraum liegt (10.05.2008 bis 18.05:2008)
nicht mit Bestimmtheit sagen.

Da es allerdings meines Wissens keinen akuten Speicherplatzmangel auf den Forumsservern gibt, habe ich vorsichtshalber auch diese Variante hinzugefügt - ignorieren kann sie Ruesseltier ja immer noch ...

Grüße
bastla
Bitte warten ..
Mitglied: Biber
27.02.2009 um 19:30 Uhr
Moin Ruesseltier,

viele Mit-Rater finden das evtl. schön, wenn die Fragestellung so nebulös ist, das eigentlich keine Antwort völlig falsch sein kann.
Dann will ich auch eine (in diesem Sinne) "Lösung" beitragen, so wie ich nun wieder die Frage interpretiere.

Wenn ich hier anfange:
Ich möchte jetzt rausbekommen wieviele SollTermine im Bereich 10.5.2008 bis 18.05.2008 liegen

...is' es sich einfach...
01.
=SUMMENPRODUKT((D2:D12>=DATWERT("10.05.2008"))*(D2:D12<=DATWERT("18.05.2008")))
--> Ergebnis : 6 ( 5x der 10.05.08 und 1x der 18.05.)

Wenn ich das ganze spielerisch erweitere auf die Fragestellung, die mir einleuchtend vorkäme:
"Welche Projekte oder Eisprünge oder um was immer es geht hatten
  • ihren SOLL-Termin zwischen dem 10.05.08 und 18.05.08
  • ihren IST-Termin unerwarteterweise auch zwischen dem 10.05.08 und 18.05.08 ?"

Dann sähe eine zusammenharkte SummenProduktformel logischerweise so aus :
01.
=SUMMENPRODUKT((D2:D12>=DATWERT("10.05.2008"))*(D2:D12<=DATWERT("18.05.2008")) *(E2:E12>=DATWERT("10.05.2008"))*(E2:E12<=DATWERT("18.05.2008")))
... und würde allerdings auch als Ergebnis 0 liefern.
Das deutet aber nicht auf einen Fehler in der Formel hin, sondern eher darauf, dass es doch um IT-Projekte geht.

Wenn ich in eines der Leer-Felder in Spalte E das Datum "14.05.08" reinlüge, ändert sich der Wert auf "1".

As should do...

Unterm Strich @Ruesseltier:
Wenn Du in der Lage bist, das konkrete Ziel/die tatsächliche Aufgabe rüberzubringen, dann bekommst Du auch die passende Lösung.
Im Moment ist es mehr ein heiteres Formel-Copy&Paste.

Grüße
Biber
Bitte warten ..
Mitglied: Ruesseltier
02.03.2009 um 08:46 Uhr
Zitat von Ruesseltier:
Hallo,
ich habe eine Tabelle mit folgenden Beispielwerten:
Spalte D Spalte E
Soll-Termin IST-Termin
_____________________
01.05.2008 30.05.2008
04.05.2008 26.06.2008
08.05.2008 30.05.2008
10.05.2008 25.07.2008
10.05.2008
10.05.2008
10.05.2008
10.05.2008 10.10.2008
18.05.2008 07.05.2008
29.05.2008
06.06.2008 26.08.2008

> Vielen Dank.

Ich nutze Excel 2003

Hallo Ihr,
nunja, leider sieht man manchmalk den Ast vot vor Bäumen nicht, ich dachte meine Ausführungen sind ausreichend.
Also es handelt sich hier um Liefertermine.
In Spalte D steht drin, wann WARE geliefert werden sollte (wert wird berechnet) und in Spalte E steht der tatsächliche Lieferwert. Wenn die Zelle in Spalte E leer ist, dann wurde noch nicht geliefert.

Mit dieser Formel möchte ich dann eben herrausbekommen, A) wieviele Liefertermine in diesem Zeitraum liegen und wiele davon pünktlich waren (Pünktlich = gleiche Zeitraum).

Vielen Danke, für die vielen Vorschlaäge, ich werde die heut durchprobieren.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...