Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

%-Zeichen fehlt beim Ausführen einer Batchdatei

Frage Microsoft

Mitglied: 5643

5643 (Level 1)

16.10.2004, aktualisiert 19:35 Uhr, 7896 Aufrufe, 2 Kommentare

Ich versuche eine Batchdatei zu schreiben um mich ins Internet einzuwählen. Der Befehl funktioniert in der Eingabeaufforderung nur wenn ich ihn über meine Batchdatei ausführe, fehlt ein %-Zeichen.

Ich versuche eine Batchdatei zu schreiben um mich ins Internet einzuwählen. Der Befehl funktioniert in der Eingabeaufforderung nur wenn ich ihn über meine Batchdatei ausführe, fehlt ein %-Zeichen.

Der Befehl lautet wie folgt:

<font class="code">call C:\windows\system32\rasdial.exe adsl dslflat/1000192%portable128.ngi xxxxxx</font>

Im DOS-Fenster wird allerdings nur folgendes ausgeführt:

<font class="code">call C:\windows\system32\rasdial.exe adsl dslflat/1000192portable128.ngi xxxxxx</font>

Wie kann ich das Prozentzeichen mit ausführen oder hat jemand eine bessere Idee, wie ich die Verbindung zum Internet über eine Batchdatei herstellen kann?

mfg Lars
Mitglied: alaska
16.10.2004 um 19:24 Uhr
Die % Zeichen bei Variablen in einer Batchdatei müssen Verdoppelt werden.

Also in der Eingabeaufforderung genügt %portable128.....

und in der Batch

%%portable128.......

Tschau
w.s.
Bitte warten ..
Mitglied: 5643
16.10.2004 um 19:35 Uhr
Danke für deine schnelle Antwort. Es hat geklappt.

Ich musste nur noch das Wort 'call' weglassen.

Lars
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batchdatei auf einem Server ausführen mit psexec.exe (18)

Frage von imebro zum Thema Batch & Shell ...

Batch & Shell
gelöst Unterdrücken eines DOS Fenster bei Ausführen einer Batchdatei (10)

Frage von Zockervogel zum Thema Batch & Shell ...

Batch & Shell
gelöst Office Deployment Tool mit einer Batchdatei per GPO Shutdown Skript ausführen (3)

Frage von McBainHH zum Thema Batch & Shell ...

Windows 10
Windows 10 Installation Gerätetreiber fehlt (10)

Frage von blade999 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Installation
Eine etwas (wirklich) speziellere Frage: Windows 10-Installation über (16)

Frage von DerFurrer zum Thema Windows Installation ...

Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Multimedia & Zubehör
gelöst Iphone 6 prob (12)

Frage von jensgebken zum Thema Multimedia & Zubehör ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...