Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zelleninhalte vergleichen und übernehmen

Frage Microsoft Microsoft Office

Mitglied: msc461

msc461 (Level 1) - Jetzt verbinden

23.04.2008, aktualisiert 24.04.2008, 11692 Aufrufe, 15 Kommentare

Hallo liebes Forum,

ich bin leider absoluter Excel-Neuling und habe in den letzten Zügen meiner Diplomarbeit von meinem Auftraggeber eine angestrebte Excel-Lösung vor die Nase gesetzt bekommen. Ich hoffe, ihr könnt mir dabei weiterhelfen.

Ich habe in einem anderen System Makros mit Stücklisteninformationen programmiert. Diese Stücklisten werden in Excel (TABELLE1) ausgeben. Der wichtigste Inhaltspunkt dieser Stücklisten ist eine mehrstellige ID, die ich selbst vergeben kann. Ich habe nun zusätzlich eine Excel-Tabelle (TABELLE2) angelegt, in der alle bisher vorhandenen ID's in der ersten Spalte aufgelistet sind. In den Spalten dahinter befinden sich noch weitere Informationen, wie Name des Bauteils, Kosten und verschiedene Attribute.

Nun zu meinem Problem:
Ich möchte in einer Kostentabelle (TABELLE3) alle ID's in einer Spalte aus TABELLE1 übernehmen und diese mit den ID-Informationen aus TABELLE2 vergleichen. Wenn eine gleiche ID gefunden wurde, sollen die Informationen in der übereinstimmenden ID-Zeile übernommen werden und in meine Kostentabelle (TABELLE 3) eingefügt werden.
Ich möchte also zum Schluss in meiner Kostentabelle alle in TABELLE1 enthaltenen ID's in der ersten Spalte haben, zeilenweise aufgefüllt mit den dazugehörigen Informationen aus TABELLE2.

Ich weiß, dass die einfachste und beste Lösung für eine dauerhafte Nutzung wohl eine Datenbank wäre, allerdings bleibt mir weder die Zeit dafür noch will das mein Auftraggeber (leider!).

Vielleicht kann mir jemand weiterhelfen oder einen Anstoß geben!

Danke schon mal...
Lieben Gruß,
Martin
Mitglied: 8644
23.04.2008 um 12:59 Uhr
Hallo Martin und willkommen im Forum!

Verständnisfrage(n):

- In Tabelle1 stehen alle ID's, die es gibt?
- In Tabelle2 können welche fehlen?
- In Tabelle3 willst du die aufführen, die in Tabelle1 und Tabelle2 vorhanden sind und zusätzlich die Informationen aus Tabelle2 übernehmen?
- Wenn das so ist, haben wir dann nicht in Tabelle2 und Tabelle3 genau die gleichen Informationen?

Vielleicht kannst du mal ein kleines Beispiel deiner Struktur bringen.

Psycho
Bitte warten ..
Mitglied: msc461
23.04.2008 um 13:36 Uhr
Hab mich etwas kompliziert ausgedrückt

Also:
- in Tab1 stehen nicht alle ID's, die es gibt, sondern nur die der im Programm (was ich geschrieben habe) verwendeten Bauteile

- in Tab2 stehen alle ID's, die es gibt (mit jeweils zusätzlichen Informationen)

- in Tab3 sollen alle ID's aus Tab1 übernommen werden und zusätzlich mit den Informationen aus Tab2 aufgefüllt werden.

BSP.:

Tab1: Spalte 1 => 12345 (ID1), 67895 (ID2)

Tab2: Spalte 1 => 00001, 00002, ..., 12345, ..., 67895, u.s.w. (alle ID's die es gibt)
zusätzlich in Spalte 2,3,4 noch Informationen zu den ID's z.B bei ID 12345, "Bauteil Tisch", "NEU"

Tab3: soll entstehen: Spalte 1 => 12345 (aus Tabelle 1)
Spalte 2 => Bauteil Tisch
Spalte 3 => Neu

Ich hoffe, jetzt ist's verständliche. Sorry nochmal, ansonsten bitte einfach nachfragen. Ist ein komplexes Thema...
Bitte warten ..
Mitglied: 8644
23.04.2008 um 13:49 Uhr
... na dann evtl. so:

Tabelle3 - A2:
01.
=WENN(ISTZAHL(Tabelle1!A2);Tabelle1!A2;"")
Tabelle3 - B2
01.
=WENN(ISTZAHL(A2);SVERWEIS(A2;Tabelle1!A2:C60000;2;FALSCH);"")
Tabelle3 - C2:
01.
=WENN(ISTZAHL(A2);SVERWEIS(A2;Tabelle1!A2:C60000;3;FALSCH);"")
und so weiter.
Die Formeln kannst du dann gemeinsam nach unten kopieren.

Psycho
Bitte warten ..
Mitglied: msc461
23.04.2008 um 14:27 Uhr
Leider funktioniert garnichts... also es passiert nichts.

Meine ID's stehen in Tabelle1 in I3, I4, I5, ... je nach dem wie viele ich habe.

Muss dann in Tabelle3 - A2:

=WENN(ISTZAHL(Tabelle1!A2);Tabelle1!A2;"")

statt A2 I3?
Bitte warten ..
Mitglied: 8644
23.04.2008 um 14:31 Uhr
natürlich musst du die Zellbezüge in der Formel an deine Struktur anpassen! Sollten deine ID's keine reinen Zahlen sein, musst du ISTZAHL durch ISTTEXT ersetzen.

Psycho
Bitte warten ..
Mitglied: msc461
23.04.2008 um 14:55 Uhr
Super, die erste Spalte klappt schon mal! Also Tabelle 3 - A2.

Die B2 klappt leider noch nicht.
Was bedeuten denn da "SVERWEIS" und "C60000"?
Bitte warten ..
Mitglied: 8644
23.04.2008 um 16:13 Uhr
Jo, das muß dann natürlich auch noch angepasst werden - mein Fehler!

Also SVERWEIS ist eine Funktion, die eine bestimmte Matrix nach einem Wert durchsucht und einen Wert aus der gefundenen Zeile ausgibt.

Syntax: SVERWEIS(Suchbegriff oder wert;Matrix(Bereich von bis);Spalte, aus der ein Wert zurückgegeben wird;Das Falsch steht da, falls die Spalte nicht sortiert ist)

Bsp:

ABC
1MeierOttoBerlin
2MüllerPaulMünchen
3WeberEgonBremen

01.
=SVERWEIS("Müller";A1:C3;3;Falsch)
Ergibt München

Heisst: Durchsuche die Matrix A1 bis C3 nach dem Begriff "Müller" und gebe mir aus, was in der dritten Spalte dieser Matrix steht.

Was ich damit sagen will, ist, dass du auch hier die Bezüge entsprechend anpassen musst.

Psycho
Bitte warten ..
Mitglied: msc461
23.04.2008 um 17:09 Uhr
Ja, das ist genau das was ich wollte.

Ich habe allerdings jetzt in die Zelle geschrieben:

=WENN(ISTTEXT(A3);SVERWEIS(A3;Tabelle2!A1:M65536;2;FALSCH);"")

Leider erscheint dann ein #NV.

Kann ich auch, um das noch zu ergänzen, nicht nur was in Spalte 2 steht auch Spalte 2 und 3 übernehmen? Also:

=WENN(ISTTEXT(A3);SVERWEIS(A3;Tabelle2!A1:M65536;2&3;FALSCH);"")
Bitte warten ..
Mitglied: 8644
23.04.2008 um 17:31 Uhr
An welcher Position der Matrix steht denn deine ID? Also in welcher Spalte? Sverweis kann nämlich nur Werte liefern, die hinter dem gefundenen stehen. Optimal wäre, wenn die ID in der ersten Spalte der Matrix steht.
Um deine zweite Frage kümmern wir uns, wenn das erste Problem aus der Welt ist.

Psycho
Bitte warten ..
Mitglied: msc461
23.04.2008 um 17:49 Uhr
IDs stehen in der ersten Spalte.

Super, dass Du dir so viel Zeit für mich nimmst...
Bitte warten ..
Mitglied: 8644
23.04.2008 um 17:54 Uhr
IDs stehen in der ersten Spalte.

und der Wert in A3 kommt durch die andere Formel zustande?
Grübel....
Ist es eine Zahl oder ein Text?

Super, dass Du dir so viel Zeit für mich nimmst...

Kein Problem!
Bitte warten ..
Mitglied: msc461
23.04.2008 um 18:03 Uhr
Der Wert in A3 kommt aus der ersten Tabelle, was ja auch soweit schon funktioniert.
A3 ist die ID, allerdings als Text in Excel markiert, da sie mit einer null anfängt und Excel das sonst nicht übernimmt.
Bitte warten ..
Mitglied: 8644
23.04.2008 um 18:54 Uhr
Mach mal ne Zahl draus und formatiere sie wie folgt:

Menü Format -> Zelle -> Reiter Zahlen -> Benutzerdefiniert -> so viele Nullen eingeben, wie du Stellen möchtest.

Psycho
Bitte warten ..
Mitglied: msc461
23.04.2008 um 19:15 Uhr
Hab alle entsprechenden Spalten als Zahl formartiert und dementsprechend den Eintrag auf
ISTZAHL geändert, leider steht da immer noch #NV.

Werd jetzt gleich aus dem Büro rausgeschmissen, hab dann leider kein Internet mehr.
Kann also erst wieder morgen antworten...
Wäre schön, wenn wir morgen weiter an meinem Problemchen arbeiten könnten!

Trotzdem schon mal vielen vielen Dank!
Und einen schönen Abend noch...
Bitte warten ..
Mitglied: msc461
24.04.2008 um 11:47 Uhr
Hab den Fehler gefunden, hatte beim Import in Tabelle 1 nen Blank in jedem Zellenanfang.
Allerdings macht er den SVERWEIS immer noch nicht.
Hab's jetzt per Hand in jeder Zeile mit VERWEIS gelöst...

Falls es noch jemanden interessiert:

=VERWEIS(A3;Tabelle2!A:A;Tabelle2!B:B)

Vielen Dank nochmal an Psycho!!!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Batch & Shell
gelöst Powershell - Dateien aus verschiedenen Arrays - Attribute vergleichen (5)

Frage von Giffas zum Thema Batch & Shell ...

Administrator.de Feedback
gelöst Bug beim Übernehmen der Überschriften-Texte von Links? (2)

Frage von Lochkartenstanzer zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...