Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zend mit MSSQL - Quoting Problem ?

Frage Entwicklung PHP

Mitglied: nxclass

nxclass (Level 2) - Jetzt verbinden

29.11.2011, aktualisiert 12:25 Uhr, 3097 Aufrufe, 2 Kommentare

Hallo,

ich arbeite mit dem Zend Framework und suche in einer MSSQL Datenbank nach einer Zeichenkette welche außer Zahlen auch zwei Slashes enthält.

application.ini
01.
; ... 
02.
; Konfiguration MSSQL Server 
03.
resources.multidb.mssql.adapter = "PDO_MSSQL" 
04.
resources.multidb.mssql.pdoType = "dblib" 
05.
; ...
Bootstrap.php
01.
// ... 
02.
$dbResource = $this->getPluginResource('multidb'); 
03.
$dbResource->init(); 
04.
// ... 
05.
Zend_Registry::set('Zend_Db_Mssql', $dbResource->getDb('mssql')); 
06.
// ...
in der Action bzw Model
01.
$dbMs = Zend_Registry::get('Zend_Db_Mssql'); 
02.
$Referenznummer = '123/4567/890'; 
03.
$result = $dbMs->select()->from( array'tabelle', array( 'id' )) 
04.
    ->joinInner( 
05.
    ->where('"Referenznummer" = ?', $Referenznummer) 
06.
    ->query()->fetchAll();
Das Problem ist nun, dass die generierte SQL Abfrage optisch funktioniert. - soll heißen: kopiert und manuell auf dem Server ausführen funktioniert und liefert die gewünschten Ergebnisse.
Sobald jedoch ->query() ausgeführt wird, passiert gar nichts mehr - keine Exception - nichts.

Ich habe nun folgendes versucht:
01.
$result = $dbMs->query( <<<__SQL__ 
02.
SELECT "id" FROM "tabelle" WHERE "Referenznummer" = '123/4567/890'            
03.
__SQL__ 
04.
)->fetchAll();

... und es geht.

vielen Dank schon mal für eure Tipps

EDIT: das Problem liegt scheinbar doch noch woanders - in der Originalen SQL Abfrage ist noch ein ->joinInner() enthalten und eines der Datenfelder (Datentyp Money) verursachte das Problem.
Mitglied: msr972
29.11.2011 um 12:25 Uhr
Hallo,

ich wollte nur was anmerken, obwohl ich leider noch nicht in ZF wirklich firm bin. Du schreibst hier in einem Codeblock:
01.
->where('"Referenznummer" = ?', $Referenznummer) 
Ist denn dei Anweisung so richtig? Oder gehört das ? nicht auch noch in ' ' ... ? Wiegesagt, meine ZF Kenntnisse betragen 0, aber das fiel mir so spontan auf...
Bitte warten ..
Mitglied: nxclass
29.11.2011 um 13:19 Uhr
Ist denn dei Anweisung so richtig? Oder gehört das ? nicht auch noch in ' ' ... ?
...das ist in Ordnung so - der Wert aus der Variablen wird dann gequotet und ersetzt den Platzhalter '?'
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Datenbanken
gelöst MSSQL 2014 Problem bei Vollständigkeitsprüfung (9)

Frage von StefanLausL zum Thema Datenbanken ...

SAN, NAS, DAS
gelöst Synolgy 1815+ - Rechte- und Richtlinien-Problem User-Ordner Home (3)

Frage von Nintox zum Thema SAN, NAS, DAS ...

Peripheriegeräte
Roccat Ryos - Support verzweifelt an Problem mit Profilen

Frage von sascha382 zum Thema Peripheriegeräte ...

Windows Update
gelöst Windows Server 2012 R2 - WSUS Problem (1)

Frage von aladin.inder zum Thema Windows Update ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...