Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zertifikat funktioniert mit Internet Explorer bei Firefox und anderen kommt Fehlermeldung

Frage Microsoft Windows Server

Mitglied: 116480

116480 (Level 2)

28.10.2014, aktualisiert 26.07.2016, 1307 Aufrufe, 6 Kommentare

Hallo,

ich habe aus einem *.pfx File 3 Exporte gemacht

  1. Export the private key file from the pfx file

openssl pkcs12 -in domain.tld_11.12.2016.pfx -nocerts -out domain.tld_11.12.2016.pfx.pem


  1. Export the certificate file from the pfx file

openssl pkcs12 -in domain.tld_11.12.2016.pfx -clcerts -nokeys -out domain.tld_11.12.2016.pem


  1. This removes the passphrase from the private key so Apache won't
  2. prompt you for your passphase when it starts

openssl rsa -in domain.tld_11.12.2016.pem -out domain.tld_11.12.2016_key.pem

File wurde dann entsprechend als *.cer und *.key umbenannt.
Nun wurde es auf einem Abacus Server implementiert.

Nun geht das Zertifikat auf Internet Explorer von Extern.
Bei Firefox hingegen, geht das Zertifikat nicht !



Gruss
Ralf
Mitglied: Chonta
28.10.2014 um 11:41 Uhr
Hallo,

der Internetexplorer verwendet den Zertifikatsspeicher des Systems Firefox hat seinen eigenen.
Wenn das Zertifikat bzw. die CA bei deinem Systen als vertrauenswürdig hinterlegt ist dann meckert der IE nicht.

Fierefox wird solange meckern, bis CA oder Zertifikat auch für den FF konfiguriert sind.

Gruß

Chonta
Bitte warten ..
Mitglied: 116480
28.10.2014 um 13:01 Uhr
Hallo Chonta,

das ist eben mein Problem "Zertifikat auch für den FF konfiguriert sind" ? Wie macht man dieses ?
Im Chrome z.bsp ist das Zertifikat auch ok !

Gruss
Ralf
Bitte warten ..
Mitglied: 116480
28.10.2014 um 13:37 Uhr
Hallo,

also das Problem sieht man auch hier



Gruss
Rlaf
Bitte warten ..
Mitglied: 116480
28.10.2014 um 13:52 Uhr
Habe es nun lösen können , denke ich.
Das File mit *.key , musste den Inhalt vom Public**.key erhalten.
Da waren die Infos Validiert von drinnen.

Gruss
Ralf
Bitte warten ..
Mitglied: 116480
28.10.2014 um 14:41 Uhr
Es ging nur temporär. Scheinbar war da was gcached. Nun mit Thawte Zertifikatschekcer geprüft.
Der zeigte an, das eine Kette fehlt. Diese im Key ergänzt. Nun ist es ok.

Gruss
Ralf
Bitte warten ..
Mitglied: Chonta
29.10.2014 um 10:21 Uhr
Hallo,

schön das Du was immer Dein Problem für Dich war beheben konntest.
Für uns alle war Das Problem, das Du Dich nicht richtig ausdrücken konntest und eine anständige Fehlerbeschreibeung/Aufgabenstellung geben konntest und das nach mehrmaligem nachfragen.

Chrome verwendet unter Windows den Systemzertifikatsspeicher.

Gruß

Chonta
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Https-Verbindung nur über Internet-Explorer (21)

Frage von Leo-le zum Thema Windows Server ...

Verschlüsselung & Zertifikate
gelöst Root Zertifikat in Firefox importieren (6)

Frage von DarkScabs zum Thema Verschlüsselung & Zertifikate ...

Webbrowser
gelöst Intranetseite per SSL aufrufen . ohne Zertifikat . mit dem Internet Explorer ? (4)

Frage von donnyS73lb zum Thema Webbrowser ...

Webbrowser
gelöst Sandboxie mit Firefox funktioniert nicht mehr (2)

Frage von KMP1988 zum Thema Webbrowser ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (20)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (13)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...