Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zertifikatsanforderung kann nicht abgeschlossen werden

Frage Microsoft Exchange Server

Mitglied: PhobosX

PhobosX (Level 1) - Jetzt verbinden

02.08.2013, aktualisiert 15:41 Uhr, 7513 Aufrufe, 9 Kommentare

Hallo zusammen.
Wir haben bereits einen Exchange 2013 (auf einem Server 2012) mit einem StartSSL Single-Domain Zertifikat im Einsatz.

Nun haben wir das Class 2 Zertifikat gekauft. Zudem haben wir nun einen weiteren Exchange Server.

Auf diesem würde ich gerne das SSL Zertifikat für mail.domain.de bekanntmachen.

Nun habe ich erst ein mycertrequest.REQ gemacht, wo aber ein Tippfehler drin war. Also habe ich den offenen Request gelöscht und danach einen neuen Request angelegt. Hier stimmen nun die Daten.

Nun habe ich bei StartSSL die Domain mail.domain.de zertifizieren lassen. Danach erhält man das Zertifikat, welches ich dann in eine .cer Datei geschrieben habe.

Damit wollte ich dann den Request auf dem Exchange abschließen, aber der Status ändert sich nicht auf abgeschlossen. Es kommt aber auch kein Fehler.


Woran liegt das nun? Hätte ich den fehlerhaften Request erst abschließen sollen? Die Datei davon habe ich noch, nur erscheint sie nicht merh in der ECP.


Was meint ihr?

VG



EDIT: Oder anders herum gefragt. Wie importiere ich das Zertifikat ohne den Request (wenn ich den private Key von StartSSL erzeugen hab lassen)?
Mitglied: Dani
02.08.2013, aktualisiert um 19:16 Uhr
Moin,
oder ein Wildcard-Zertifikat... schenkt sich meistens nicht viel und kann für beliebig viele Subdomains + Hauptdomain genutzt werden. Den Privatekey, etc... dafür aber gut verstauen.

Zum Exportieren/Importieren gibt es zwei Möglichkeiten - Link


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013 um 08:58 Uhr
Hallo zusammen.
Bei StartSSL bekommt man ein offizielles Zertifikat. Und wir haben auch ein Wildcard-Zertifikat.

Von daher passt das. Haben wir ja auch schon beim ersten Exchange so realisiert.

@Dani
Ich will ja kein Zertifikat umziehen, sondern ein neues Importieren.

Kann ich beim Exchange 2013 auch ein *.domain.de (Wildcard) Zertifikat ohne eine .req Datei einspielen?

Wenn ja, wie?

Und ist es problematisch einen bestehenden Request zu löschen?


Danke un und viele Grüße!
Bitte warten ..
Mitglied: Dani
05.08.2013 um 09:17 Uhr
Moin,
steht alles im Technet. Leider haben wir noch keinen Testserver mit Exchange 2013.

Und ist es problematisch einen bestehenden Request zu löschen?
Eigentlich nicht...


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013, aktualisiert um 11:37 Uhr
Also ich versuche nun eine PKCS#12 (PFX) Datei zu importieren.

ef8c2f36683634c94fa284558ea509e0 - Klicke auf das Bild, um es zu vergrößern


Der Exchange sagt mir aber, dass bereits ein Zertifikat mit diesem Fingerabdruck vorhanden sei. Da ist aber kein Zertifikat in der Exchange-Verwaltungskonsole zu sehen.

Wie kann das sein?


Grüße


EDIT:
So, konnte den Fehler zumindest ausfindig machen und beheben. Unter der MMC war das alte Zertifikat sichtbar und ließ sich nun löschen.


ABER:
Ich habe nun ein wildcard Zertifikat verwendet. Das lautet auf *.domain.de

Der Exchane mag das aber nicht, da es kein FQDN darstellt.

Warnung
Dieses Zertifikat mit dem Fingerabdruck 96.... und dem Antragsteller '*.domain.de' kann für POP-SSL/TLS-Verbindungen nicht verwendet werden, da der Antragsteller kein vollqualifizierter Domänenname (FQDN) ist. Verwenden Sie den Befehl 'Set-POPSettings', um X509CertificateName auf den FQDN des Diensts festzulegen.


Dieses Zertifikat mit dem Fingerabdruck 96... und dem Antragsteller '*.domain.de' kann für IMAP-SSL/TLS-Verbindungen nicht verwendet werden, da der Antragsteller kein vollqualifizierter Domänenname (FQDN) ist. Verwenden Sie den Befehl 'Set-IMAPSettings', um X509CertificateName auf den FQDN des Diensts festzulegen.


Wie lässt sich das *.domain.de Zertifikat für den Exchange verwenden?


Grüße
Bitte warten ..
Mitglied: Dani
05.08.2013 um 13:39 Uhr
Moin,
musste noch kurz einen Exchange 2013 installieren.

Ich habe es mit unserem Wildcard-Zertifikat versucht. Funktioniert auf Anhieb ohne Probleme. Wichtig ist das, der private Schlüssel enthalten ist. Steht doch dran, was du zu tun hast. Öffne die Exchange Management-Powershell und gebe ein:
01.
Set-PopSettings -X509CertificateName domain.de
Dienste neustarten und die Management Oberfläche aktualisieren.


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013 um 13:43 Uhr
Heyhey, das nenn ich doch mal Wissensdurst

Ich hab jetzt nicht unser Wildcard- sonder ein Single-Domain-Zertifikat genommen und die Dienste zugewiesen. Ging/geht ja auch und erfüllt seinen Zweck.

Ich denke das Thema kann ich dann als gelöst markieren.

Vielen Dank für eure Hilfe! Wie immer top!
Bitte warten ..
Mitglied: Dani
05.08.2013 um 13:45 Uhr
Heyhey, das nenn ich doch mal Wissensdurst
Eigentlich nicht... hab heut entspannte Schicht im NOC. Eis, Fernseher und nichts zu tun.


Grüße,
Dani
Bitte warten ..
Mitglied: PhobosX
05.08.2013 um 14:35 Uhr
Ein Hoch auf das Sommerloch. Ich kann so auch etwas entspannter die Exchange Migration durchführen.

Also viel Spaß noch!

VG
Bitte warten ..
Ähnliche Inhalte
Verschlüsselung & Zertifikate
gelöst KRA Zertifikat auf dem Client nicht verfügbar (1)

Frage von Snipes zum Thema Verschlüsselung & Zertifikate ...

Exchange Server
gelöst Probleme bei der Deinstallation eines Exchange auf einem SBS 2011 (19)

Frage von manuel1985 zum Thema Exchange Server ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (26)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (18)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...

Voice over IP
Über Fritzfax over IP gehen nur einige Faxe (12)

Frage von shearer9 zum Thema Voice over IP ...