Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zertikfikatsinformationen und Zertifizierungpfad werden mit Apache nicht angezeigt

Frage Linux Apache Server

Mitglied: testexc

testexc (Level 1) - Jetzt verbinden

21.08.2007, aktualisiert 22.08.2007, 3901 Aufrufe, 5 Kommentare

Ich habe unter Windows 2003 R2 einen Apache 2.0.55 Server am laufen.
Auf diesem Server ist ssl aktiviert.
Wenn ich nun ein Zertifikat einbinde erscheint der Zertifizierungspfad ebenso wenig wie die Zertifikatsinformationen.
Wenn ich SSLCertificateChainFile deklariere, kommt mein Apache Dienst nicht mehr hoch.
Wenn ich das File mit Apache -t prüfe ist aber alles ok.
Hat jemand ne Idee?
Mitglied: DerBiba
21.08.2007 um 21:14 Uhr
Poste doch mal deine ssl.conf und vielleicht auch die http.conf.
Dann kann man mal schauen wo das Problem liegt...

Biba
Bitte warten ..
Mitglied: testexc
22.08.2007 um 11:59 Uhr
ssl.conf ist leer

httpd.conf

Hab nur mal das von Virtual hosts gepostet

Listen 443
Listen 80

NameVirtualHost *:80
NameVirtualHost *:443


<VirtualHost *:80>
ServerName www.meinedomaene.de
DocumentRoot "C:\Apache2\htdocs\meinedomaene"
</VirtualHost>

<VirtualHost *:80>
ServerName www.meinedomaene2.de
DocumentRoot "C:\www\Apache2\htdocs\meinedomaene2"
</VirtualHost>

SSLMutex default
SSLRandomSeed startup builtin
SSLSessionCache none

ErrorLog logs/SSL.log
LogLevel warn
<VirtualHost *:443>
ServerName www.meinedomaene.de
DocumentRoot c:/apache2/htdocs/meinedomaene
SSLEngine On
SSLCertificateFile conf/ssl/usercert.pem
SSLCertificateKeyFile conf/ssl/key.pem
  1. SSLCertificateChainFile conf/ssl/root.pem

</VirtualHost>
Bitte warten ..
Mitglied: DerBiba
22.08.2007 um 15:46 Uhr
Der Apache kommt aus der Unix Ecke und ist deshalb auch etwas pingelig. Der mag deine Backslashs nämlich nicht.

Ändere daher mal deine
01.
"C:\Apache2\htdocs\meinedomaene"
in
01.
C:/Apache2/htdocs/meinedomaene"
Anschliessend mal den Pfad vom DocumentRoot in Anführungszeichen setzen und für das Zertifikat und das Keyfile mal den vollständigen Pfad (mit Slash statt Backslash, also / statt \ !!!!) angeben (auch hier ist der Apache teils etwas zickig unter Windows).

Und zum Schluß nun die obligatorische Weissheit der EDV: "Eigentlich musste das jetzt gehen"

Ansonsten meld dich noch mal, wenn es nicht geholfen hat.

Biba
Bitte warten ..
Mitglied: testexc
22.08.2007 um 21:04 Uhr
Habe die Backslashes durch slashes ersetzt, das DocumentRoot in Anführungszeichen gesetzt und den Kompletten Pfad bei Keyfile und Zertifikat angegeben.

Aber leider wieder ohne Erfolg

sobald ich SSLCertificateChainFile einfüge startet mein Dienst nicht mehr
Bitte warten ..
Mitglied: DerBiba
22.08.2007 um 23:24 Uhr
Stimmen deine Zertifikate denn überhaupt?

Für dein SSLCertificateChainFile müssen nämlich _alle_ übergeordneten Certs der einzelnen CAs übergeben werden. In der Reihenfolge von der ServerCert-CA bis zur Root-CA !!

Überdenk und kontrollier das mal.

Biba
Bitte warten ..
Ähnliche Inhalte
Apache Server
Wordpress und Apache als Reverse Proxy (2)

Frage von sleaper zum Thema Apache Server ...

Apache Server
gelöst Apache Konfiguration Website Weiterleitung (5)

Frage von Brigomaglos zum Thema Apache Server ...

Microsoft Office
Passwortabfrage Office bei Dokumenten von Apache Server

Frage von Cougar77 zum Thema Microsoft Office ...

Administrator.de Feedback
gelöst Fragen werden nicht angezeigt? (8)

Frage von Lochkartenstanzer zum Thema Administrator.de Feedback ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (58)

Frage von pjrtvly zum Thema Internet ...

DSL, VDSL
VDSL Signal via PowerLine an Fritzbox - Möglich? (19)

Frage von Seichobob zum Thema DSL, VDSL ...

Windows Server
Benutzer sperrt sich immer wieder im Active Directory Contoller (15)

Frage von Kirdy1301 zum Thema Windows Server ...