Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zielframe in Dreamweaver8

Frage Entwicklung HTML

Mitglied: leucanthemum

leucanthemum (Level 1) - Jetzt verbinden

25.08.2010 um 19:33 Uhr, 2901 Aufrufe, 9 Kommentare

Hoffentlich kann mir jemand helfen und mein Problem in Dreamweaver lösen.

Ich erstelle eine Site mit Framesets. Die Buttonleiste ist seperat zum mainframe. Die einzelnen Seiten sollen im mainframe geöffnet werden. Leider funktuniert das nicht!
Ich habe die richtige Zielframe eingegeben, keine Rechtschreibfehler, alles einzeln abgespeichert und kann einfach keinen Fehler finden. Hier der code:

<body>
<table width="129" border="0" align="center">
<tr>
<th width="123" height="114" scope="row"><p><a href="home.html" target="mainframe"><img src="Oase_Logo1.gif" alt="home" width="83" height="81" border="0" /></a><br />
<img src="Oase_Logo2.gif" alt="home" width="99" height="13" /></p></th>
</tr>
<tr>
<th height="59" scope="row"><a href="laden.html" target="mainframe"><img src="ButtonLaden3.gif" alt="Der Laden" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="58" scope="row"><a href="ware.html" target="mainframe"><img src="ButtonWaren1.gif" alt="Warenangebot" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="56" scope="row"><a href="lichtraum.html" target="mainframe"><img src="ButtonLichtraum3.gif" alt="Lichtraum" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="55" scope="row"><a href="kontakt.html" target="mainframe"><img src="ButtonKontakt3.gif" alt="Kontakt" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="55" scope="row"><a href="impressum.html" target="mainframe"><img src="ButtonImpressum3.gif" alt="Impressum" width="122" height="40" border="0" /></a></th>
</tr>
</table>
<br />
<br />
</body>
</html>


Es geht um die Buttons laden, ware, lichtraum, etc. Ich hab auch das Frameset schon neu aufgebaut und das mainframe unter einem anderen Namen gespeichter usw. Weiß mir keinen Rat mehr


Kann mir bitte Irgendjemand einen Hinweis geben und mir weiterhelfen.

Vielen Dank im Voraus!

VG
Mitglied: mrtux
25.08.2010 um 19:59 Uhr
Hi !

Hast Du auf Gross- und Kleinschreibung geachtet? Die Browser reagieren da meist empfindlich drauf...

[ot]
Umscheib das mal bitte in Code-Tags des Forums....So ist das etwas unübersichtlich...
[/ot]


mrtux
Bitte warten ..
Mitglied: leucanthemum
25.08.2010 um 20:49 Uhr
Hi,

ja, hab ich!

er öffnet immer in einem seperatem Fenster und nicht im Zielframe.

leuci
Bitte warten ..
Mitglied: kristov
26.08.2010 um 09:46 Uhr
Hallo,

poste doch mal den Quellcode des Framesets selbst (bitte Code-Tags verwenden). Der Code, den Du gepostet hast, scheint übrigens nicht vollständig zu sein.

kristov
Bitte warten ..
Mitglied: leucanthemum
21.09.2010 um 20:20 Uhr
Hallo,

war eine zeitlang im Urlaub und bin immer noch weiter am Verzweifeln!
Hoffentlich steht die Hilfe noch?
Hier der Quellcode des Framesets:


<frameset rows="*" cols="120,*" frameborder="no">
<frame src="leftframe.html" id="leftframe" />
<frameset rows="*" cols="750,*" frameborder="no">
<frameset rows="120,*" cols="*" frameborder="no" bordercolor="#FFFFFF">
<frame src="topframe.html" frameborder="no" scrolling="no" id="topframe" />
<frameset rows="450,*" cols="*" frameborder="no">
<frameset rows="*" cols="150,600" frameborder="no">
<frame src="menuframe.html" frameborder="no" scrolling="no" id="menuframe" />
<frame src="mainframe.html" frameborder="no" scrolling="no" id="mainframe" />
</frameset>

<frame src="bottomframe.html" frameborder="no" id="bottomframe" />
</frameset>
</frameset>
Bitte warten ..
Mitglied: kristov
27.09.2010 um 10:20 Uhr
Hallo,

das ist immer noch nciht der gesamte Quelltext. Ein Quelltext fängt so an und hört so auf:

01.
<html> 
02.
.... 
03.
</html>
(und so sieht das mit den hier oft gewünschten code-tags aus). Hast Du in Deiner Buttonleiste vielleicht noch irgendwo ein

01.
<base target="irgendwas">
drin stehen (näheres dazu findest Du hier?

kristov
Bitte warten ..
Mitglied: leucanthemum
27.09.2010 um 14:01 Uhr
Ok, hier nochmal der gesamte Quelltext:

<!DOCTYPE html PUBLIC " -W3CDTD XHTML 1.0 Framese tEN" "http:www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">
<html xmlns="http://www.w3.org/1999/xhtml;>"
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Die Oase</title>
</head>

<frameset rows="*" cols="120,*" frameborder="no">
<frame src="leftframe.html" id="leftframe" />
<frameset rows="*" cols="750,*" frameborder="no">
<frameset rows="120,*" cols="*" frameborder="no" bordercolor="#FFFFFF">
<frame src="topframe.html" frameborder="no" scrolling="no" id="topframe" />
<frameset rows="450,*" cols="*" frameborder="no">
<frameset rows="*" cols="150,600" frameborder="no">
<frame src="menuframe.html" frameborder="no" scrolling="no" id="menuframe" />
<frame src="mainframe.html" frameborder="no" scrolling="no" id="mainframe" />
</frameset>

<frame src="bottomframe.html" frameborder="no" id="bottomframe" />
</frameset>
</frameset>

<frame src="rightframe.html" frameborder="no" scrolling="no" id="rightframe" />
</frameset>
</frameset>
<noframes><body>
</body>
</noframes></html>



Den Code von meiner Menuleiste sieht wie so aus:
hier ist auch target zu finden. Mehr kann und weiß ich nicht!
Hoffentlich hab ich jetzt das Richtige!

<!DOCTYPE html PUBLIC " -W3CDTD XHTML 1.0 Transitiona lEN" "http:www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml;>"
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Die Oase</title>
<style type="text/css">
<!--
body {
background-color: #F5F0CB;
}
-->
</style></head>

<body>
<table width="134" border="0" align="center">
<tr>
<th width="128" height="114" scope="row"><p><a href="home.html" target="mainframe"><img src="Oase_Logo1.gif" alt="home" width="83" height="81" border="0" /></a><br />
<img src="Oase_Logo2.gif" alt="home" width="99" height="13" /></p></th>
</tr>
<tr>
<th height="59" scope="row"><a href="laden.html" target="mainframe"><img src="ButtonLaden3.gif" alt="Der Laden" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="58" scope="row"><a href="ware.html" target="mainframe"><img src="ButtonWaren1.gif" alt="Warenangebot" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="56" scope="row"><a href="lichtraum.html" target="mainframe"><img src="ButtonLichtraum3.gif" alt="Lichtraum" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="55" scope="row"><a href="kontakt.html" target="mainframe"><img src="ButtonKontakt3.gif" alt="Kontakt" width="122" height="40" border="0" /></a></th>
</tr>
<tr>
<th height="55" scope="row"><a href="impressum.html" target="mainframe"><img src="ButtonImpressum3.gif" alt="Impressum" width="122" height="40" border="0" /></a></th>
</tr>
</table>
<br />
<br />
</body>
</html>


Danke
LG
leuci
Bitte warten ..
Mitglied: kristov
27.09.2010 um 14:24 Uhr
Aloah!

Mach mal bei ersterem so, also "id=" durch "name=" ersetzen (näheres s. bitte hier, auch wenn es Dich nicht sonderlich zu interessieren scheint):

01.
<!DOCTYPE html PUBLIC " -W3CDTD XHTML 1.0 Framese tEN" "http:www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd"> 
02.
<html xmlns="http://www.w3.org/1999/xhtml&quot;&gt; 
03.
<head> 
04.
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> 
05.
<title>Die Oase</title> 
06.
</head> 
07.
 
08.
<frameset rows="*" cols="120,*" frameborder="no"> 
09.
<frame src="leftframe.html" name="leftframe" /> 
10.
<frameset rows="*" cols="750,*" frameborder="no"> 
11.
<frameset rows="120,*" cols="*" frameborder="no" bordercolor="#FFFFFF"> 
12.
<frame src="topframe.html" frameborder="no" scrolling="no" name="topframe" /> 
13.
<frameset rows="450,*" cols="*" frameborder="no"> 
14.
<frameset rows="*" cols="150,600" frameborder="no"> 
15.
<frame src="menuframe.html" frameborder="no" scrolling="no" name="menuframe" /> 
16.
<frame src="mainframe.html" frameborder="no" scrolling="no" name="mainframe" /> 
17.
</frameset> 
18.
 
19.
<frame src="bottomframe.html" frameborder="no" name="bottomframe" /> 
20.
</frameset> 
21.
</frameset> 
22.
 
23.
<frame src="rightframe.html" frameborder="no" scrolling="no" name="rightframe" /> 
24.
</frameset> 
25.
</frameset> 
26.
<noframes><body> 
27.
</body> 
28.
</noframes></html>
Bei zweiterem kannst Du das auch so machen, durch Angabe von "base target="mainframe"" sparst Du Dir das "target="mainframe"" bei jedem Link, denn dieser tag gilt für alle Links in diesem Dokument, sofern nicht dezidiert anders angegeben (Du kannst es aber auch so lassen, wie es ist, wenn Du unsicher bist), näheres s. bitte hier:

01.
<!DOCTYPE html PUBLIC " -W3CDTD XHTML 1.0 Transitiona lEN" "http:www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
02.
<html xmlns="http://www.w3.org/1999/xhtml&quot;&gt; 
03.
<head> 
04.
<base target="mainframe"> 
05.
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> 
06.
<title>Die Oase</title> 
07.
<style type="text/css"> 
08.
<!-- 
09.
body { 
10.
background-color: #F5F0CB; 
11.
12.
--> 
13.
</style></head> 
14.
 
15.
<body> 
16.
<table width="134" border="0" align="center"> 
17.
<tr> 
18.
<th width="128" height="114" scope="row"><p><a href="home.html"><img src="Oase_Logo1.gif" alt="home" width="83" height="81" border="0" /></a><br /> 
19.
<img src="Oase_Logo2.gif" alt="home" width="99" height="13" /></p></th> 
20.
</tr> 
21.
<tr> 
22.
<th height="59" scope="row"><a href="laden.html"><img src="ButtonLaden3.gif" alt="Der Laden" width="122" height="40" border="0" /></a></th> 
23.
</tr> 
24.
<tr> 
25.
<th height="58" scope="row"><a href="ware.html"><img src="ButtonWaren1.gif" alt="Warenangebot" width="122" height="40" border="0" /></a></th> 
26.
</tr> 
27.
<tr> 
28.
<th height="56" scope="row"><a href="lichtraum.html"><img src="ButtonLichtraum3.gif" alt="Lichtraum" width="122" height="40" border="0" /></a></th> 
29.
</tr> 
30.
<tr> 
31.
<th height="55" scope="row"><a href="kontakt.html"><img src="ButtonKontakt3.gif" alt="Kontakt" width="122" height="40" border="0" /></a></th> 
32.
</tr> 
33.
<tr> 
34.
<th height="55" scope="row"><a href="impressum.html"><img src="ButtonImpressum3.gif" alt="Impressum" width="122" height="40" border="0" /></a></th> 
35.
</tr> 
36.
</table> 
37.
<br /> 
38.
<br /> 
39.
</body> 
40.
</html>
Bitte warten ..
Mitglied: leucanthemum
27.09.2010 um 20:48 Uhr
Hi,

es lag sicher nicht am Interesse, sondern einfach weil ich mich grenzenlos überfordert fühle!
Aber jetzt hab ich es verstanden und es hat geklappt, indem dass ich überall "name" eingesetzt habe!

Vielen herzlichen Dank für die ausdauernde Hilfe!

Leuca
Bitte warten ..
Mitglied: kristov
29.09.2010 um 09:37 Uhr
Morgen!

Ja, wunderbar! "Mehr kann und weiß ich nicht" hat sich für mich so nach "sagt's mir einfach, was da los ist, der Rest interessiert mich nicht" angehört, eine Mentalität, die sich leider ausbreitet. Du scheinst aber nicht in diese Kategorie zu gehören

Hoffe, Dein Urlaub war erholsam.

kristov
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...