Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kein Zugriff auf externe IP aus dem Intranet

Frage Netzwerke LAN, WAN, Wireless

Mitglied: GIS-olli

GIS-olli (Level 1) - Jetzt verbinden

08.08.2007, aktualisiert 11:51 Uhr, 4771 Aufrufe, 4 Kommentare

Ich habe folgendes Problem. Wir haben ein Firmennetzwerk mit einem Win2003 SBS laufen. An diesem Server sind mehrere Clients in einer Domäne zusammgefasst. Der Internetzugang erfolgt bei uns über einen Innominate MGuard Router. Wir haben eine vom ISP feste IP, 213.23.xx.xx. Ich habe den Router für den Routerbetrieb konfiguriert, d.h. er hat extern die IP vom ISP und intern die IP 192.168.1.250, Subnet 255.255.255.0. Soweit funktioniert der Internetzugang für alle Rechner einwandfrei. Nun habe ich auf unserem Server (192.168.1.201, gleiches Subnet) einen Apache Webserver auf dem Port 8080 laufen. Wenn ich im Intranet nun die Seite 192.168.1.201:8080 eingebe (oder alternativ auch den Servernamen:8080) sehe ich den Webinhalt einwandfrei. Jetzt wollte ich den Webinhalt aus dem Internet erreichbar machen, also über 213.23.xx.xx . Dazu habe ich im Router eine Portweiterleitung eingerichtet. Wenn eine Anfrage an den http Port von aussen an die IP 213.23.xx.xx kommt, soll er die Anfrage an 192.168.1.201:8080 weiterleiten. Das funktioniert auch, allerdings nur aus dem Internet. Wenn ich nun die IP 213.23.xx.xx aus unserem Firmennetzwerk aufrufe kommt eine Zeitüberschreitung im Browser. Allerding, und das ist das komische, sehe ich im Log des Routers, dass die Firewallregel gegriffen hat, mit den richtigen Quell IPs usw... Aber es kommt am Client nichts an. Ich habe auch schon versucht, die Firewall komplett auszuschalten, also den ganzen eingehenden Verkehr mal zugelassen, mit dem gleichen Ergebnis. Aber wie gesagt, von aussen gehts. Kann mir jemand weiterhelfen?
Mitglied: aqui
08.08.2007 um 11:05 Uhr
Sehr wahrscheinlich hat der NAT Prozess im Router ein Problem damit eine aus seinem internen lokalen Netz kommete Quelladresse auch wieder als Forwarding IP einzusetzen. Ein recht häufig sichtbares Phänomen bei NAT Routern.

Auf der anderen Seite musst du dich aber auch mal ernsthaft fragen lassen was der Unsinn soll aus dem lokalen Intranet als Zieladresse für einen lokalen Webserver eine externe IP Adresse und dann auch noch die des Routers auf dem Internet Port anzugeben. Normal ist das ja eigentlich nicht und der Sinn erschliesst sich erstmal auch nicht !
Bitte warten ..
Mitglied: GIS-olli
08.08.2007 um 11:15 Uhr
Danke erstmal für die rasche Antwort.
Also das mit der IP lässt sich einfach erklären: Ich erstelle Webanwendungen, welche auf einen Mapserver zugreifen. Dieser arbeitet OGC-konform, d.h. er greift über einen konformen Request auf einen Server zu. In diesem Request ist natürlich die IP mit drin. Das hätte zur Folge, dass ich bei der Entwicklung der Anwendung alle IPs lokal halten müsste, und dann alles auf "öffentlich" umstellen müsste. Also muss es mit der öffentlichen IP gehen, da ich sonst eine sehr umständliche Arbeit habe.

Nun zum NAT:
Ich habe bei unserem Router unter NAT folgendes probiert: Unter dem Punkt "Network Address Translation/IP Masquerading" stand ursprünglich 192.168.1.0/24. Damit ging es nicht. Dann habe ich es in 0.0.0.0/0 umgewandelt, da in der Router Anleitung stand, dass damit alles verarbeitet wird. Es gibt dann aber noch die Möglichkeit eines 1:1-NAT. Dabei muss ich das lokale Netzwerk, das externe Netzwerk und die Netzmaske angeben. Das habe ich auch schon ausprobiert, hat aber auch keine Änderung gebracht.
Bitte warten ..
Mitglied: aqui
08.08.2007 um 11:44 Uhr
Ein Lösung kann sein eine IP aus dem öffentlichen Kontingent eurer IP Adresse zu nehmen. Das funktioniert aber nur wenn ihr statt einer einzigen IP eine Subnetz oder Teile davon bekommen habt.
Dann könntest du dir eine statische NAT Regel konfigurieren nur für den Webserver sofern der Router sowas kann. Allerdinsg würde das dann letztendlich keinen Sinnmachen, denn dann könnte man sich eine DMZ einrichten und den Server auch mit einer öffentlichen IP betreiben und hätte das Problem erst gar nicht....

Das ist vermutlich ein Bug oder Feature des NAT Prozesses in der Firmware deines Routers. Ggf. fixt ein Firmware Image das auf das neueste Release. Wie gesagt nicht alle Router zeigen so ein Verhalten bei vielen klappt das problemlos. Eine feste Regel wer es kann und wer nicht gibt es aber nicht, da hilft leider nur der versuch
Evtl. solltest du mal die Hotline des Herstellers kontaktieren. Innominate nutzt m.W. ein embeddetes Linux auf ihren Systemen und da sollte eine Lösung allemal möglich sein !
Bitte warten ..
Mitglied: GIS-olli
08.08.2007 um 11:51 Uhr
Danke erstmal. Ich hab noch einen DLink Router rumliegen, ich probiers erstmal mit dem ob es wirklich daran liegt.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Externer Zugriff auf IP Arcor Speed Modem 200
gelöst Frage von bloedernameLAN, WAN, Wireless17 Kommentare

Hallo, ich würde gern eine IP Kamera anschließen und komme nicht weiter. Bei mir zu Hause funktioniert alles tadellos ...

LAN, WAN, Wireless
Externe IP von intern ansprechen
gelöst Frage von X42KampfpanzerLAN, WAN, Wireless3 Kommentare

Hallo, ich bin seit langem stiller Mitleser und habe mich jetzt mal angemeldet weil ich eine Frage habe. Durch ...

Router & Routing
Externe IP von innen erreichbar machen
gelöst Frage von Windows10GegnerRouter & Routing28 Kommentare

Hallo, ich habe bei mir nen kleinen FTP eingerichtet und möchte diesen auch intern von der Adresse von ddns.net ...

LAN, WAN, Wireless
Gerät über externe IP identifizieren
gelöst Frage von achkleinLAN, WAN, Wireless9 Kommentare

Hallo, der Zugang zum Mailserver eines Bekannten wurde gesperrt, weil 5x ein falsches Passwort verwendet wurde. Die betreffende externe ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 StundeBatch & Shell1 Kommentar

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 3 StundenHumor (lol)5 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 18 StundenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 19 StundenSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Linux
OpenSource Groupware
Frage von FA-jkaLinux13 Kommentare

Hallo, ich suche eine Groupware als Alternative zum Exchange. Wesentliche Aufgaben sind die Handhabung von E-Mails (persönliche und gemeinsam ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...