Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Zugriff auf mdb nach Kopiervorgang nicht möglich

Frage Microsoft Microsoft Office

Mitglied: borgadmin

borgadmin (Level 1) - Jetzt verbinden

27.05.2010 um 20:32 Uhr, 8151 Aufrufe, 5 Kommentare

Ein Benutzer kann die Datenbank öffnen, bei den nächsten Benutzer erscheint die Meldung: "Datei konnte nicht gesperrt werden"

Hallo zusammen,

folgendes Problem wurde heute festgestellt und bisher nicht gelöst werden:

Ausgangssituation:

Die Datenbank lag auf einem NAS und konnte in der Vergangenheit problemlos von mehreren Nutzern geöffnet werden. Da das NAS jedoch eine Fehlfunktion hatte musste dieses getauscht werden. Alle Daten unter Berücksichtigung und Beibehaltung der Ordnerstrukturen wurden auf einen SBS 2008 kopiert und anschließend wieder zurück auf ein baugleiches NAS mit den gleichen Einstellungen transferiert.

Problem:

Seit diesem Vorgang kann nur noch 1 Benutzer die Datenbank öffnen, bei allen anderen Nutzern erscheint die Meldung: "Datei konnte nicht gesperrt werden". Ich habe daraufin zur Sicherheit die Berechtigungen für den Ordner in dem sich die Datenbank befindet jedem Vollzugriff gewährt. Leider hat dies kein Erfolg gezeigt. Sobald der erste Benutzer die Datenbank öffnet, konnte ich beobachten, dass die LDB - Datei erstellt wird. Schließt dier Benutzer die Datenbank wieder, wird die LDB Datei wiederf gelöscht.

Ich hoffe, dass sich hier in diesem Forum jemand findet der mir bei der Lösung helfen kann. Was kann ich noch tun?

Viele Grüße

borgadmin
Mitglied: Biber
27.05.2010 um 21:25 Uhr
Moin borgadmin,

um mit den einfachsten Nachfragen anzufangen
  • welche Access-Version (und WTF muss ich danach fragen??)
  • hast du in dem Reiter "Optionen" -"Weitere" nachgeschaut, ob die Mehrbenutzerfähigkeit eingestellt ist?

Also
  • "Standarderöffnungsmodus" ="Freigegeben" und nicht etwa "Exklusiv"
  • "Standard bei Datensatzsperrung" auf gar keinen Fall "Alle Datensätze"
  • und das Häkchen bei "Datenbank mit Sperrung auf Datensatzebene öffnen" nur dann anhaken, kein keine oder eine strohdoofe Applikation drüberliegt.

Grüße
Biber
Bitte warten ..
Mitglied: StefanKittel
27.05.2010 um 22:04 Uhr
Hallo,
was für ein NAS denn? Es gibt auch welche die das gleichzeitige bearbeiten von Benutzern nicht können. Stichwort Firmware Version.
Stefan
Bitte warten ..
Mitglied: borgadmin
28.05.2010 um 10:34 Uhr
Hallo zusammen,

schonmal Danke für die Antworten. Es sind Access 2000, Access 2003 sowie Access 2007 im Einsatz.

Das NAS ist ein Netgear ReadyNAS 1100 mit aktueller Firmware.
Bitte warten ..
Mitglied: borgadmin
28.05.2010 um 12:28 Uhr
So, die Probleme werden mehr anstatt weniger. Inzwischen erscheint beim Öfnnen bei allen Benutzern ausser mir: "Das System kann die angegebene Datei nicht öffnen".

Was habe ich gemacht? Ich habe eine Kopie der datenbank angelegt und in dieser versucht die Sicherheitseinstellungen zu setzen (Datenbanktools -->Benutzer und Berechtigung). Dummerweise können die anderen Benutzer nun weder die Kopie noch das Original ändern.

Wäre super wenn mir jemand helfen könnte...

Nachtrag:

• Ist der "Standarderöffnungsmodus" ="Freigegeben" und nicht "Exklusiv"
• Der "Standard bei Datensatzsperrung" darf nicht auf "Alle Datensätze" gesetzt sein
• Ob das Häkchen bei "Datenbank mit Sperrung auf Datensatzebene öffnen" gesetzt ist

ist alles mit ja zu beantworten
Bitte warten ..
Mitglied: borgadmin
28.05.2010 um 23:36 Uhr
Hi,

ich habe das Problem gelöst. Es ist zwar nicht das gelbe vom Ei, aber es funktioniert. Die Datenbank wurde vom NAS auf einen anderen, im Netzwerk freigegebenen Ordner verschoben. Jetzt klappt der Multiuser - Zugriff. Könnte daher wirklich mit StefanKittels Hinweis in Verbindung stehen. Vielen Dank an der Stelle dafür.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
Kein RDP zugriff mehr möglich nach entfernen der RDS Rollen (4)

Frage von Remoteserverneuling zum Thema Windows Server ...

Windows 10
Windows Problem: Kein Zugriff auf das LAN via Ethernet möglich (4)

Frage von ReinerWahnsinn zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...